summaryrefslogtreecommitdiffstats
path: root/audio/wmusic-xmms
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2018-09-16 19:37:29 +0100
committer David Spencer <idlemoor@slackbuilds.org>2018-09-17 23:11:57 +0100
commitb391444293305ce5e6746f8830a69605b12ce6ab (patch)
treeccbbe1af456d2a06d4a064a32e3681c49ea29c4d /audio/wmusic-xmms
parent28528be906556fdeab87fedee7f3478fbb1250e9 (diff)
downloadslackbuilds-b391444293305ce5e6746f8830a69605b12ce6ab.tar.gz
slackbuilds-b391444293305ce5e6746f8830a69605b12ce6ab.tar.xz
audio/wmusic-xmms: Added (xmms remote control dockapp).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'audio/wmusic-xmms')
-rw-r--r--audio/wmusic-xmms/README11
-rw-r--r--audio/wmusic-xmms/slack-desc19
-rw-r--r--audio/wmusic-xmms/wmusic-xmms.SlackBuild77
-rw-r--r--audio/wmusic-xmms/wmusic-xmms.info10
4 files changed, 117 insertions, 0 deletions
diff --git a/audio/wmusic-xmms/README b/audio/wmusic-xmms/README
new file mode 100644
index 0000000000..ff85213e30
--- /dev/null
+++ b/audio/wmusic-xmms/README
@@ -0,0 +1,11 @@
+wmusic-xmms (xmms remote control dockapp)
+
+- VCR style controls including fast rewind and fast forward
+- Time and Playlist position display
+- Super stylee rotating arrow
+- Hiding of the xmms windows (on startup and through middle-click)
+
+This is actually wmusic version 1.5.0. It works only with xmms 1.x,
+which is the xmms that ships with Slackware. If you want to control
+xmms2, or other audio players such as audacious, amarok, vlc, etc,
+install wmusic instead.
diff --git a/audio/wmusic-xmms/slack-desc b/audio/wmusic-xmms/slack-desc
new file mode 100644
index 0000000000..c3530b22a4
--- /dev/null
+++ b/audio/wmusic-xmms/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+wmusic-xmms: wmusic-xmms (xmms remote control dockapp)
+wmusic-xmms:
+wmusic-xmms: wmusic is a dockapp that remote-controls xmms. Features VCR style fast
+wmusic-xmms: forward and rewind, time and playlist position display, hiding of XMMS
+wmusic-xmms: window and more.
+wmusic-xmms:
+wmusic-xmms:
+wmusic-xmms:
+wmusic-xmms:
+wmusic-xmms:
+wmusic-xmms:
diff --git a/audio/wmusic-xmms/wmusic-xmms.SlackBuild b/audio/wmusic-xmms/wmusic-xmms.SlackBuild
new file mode 100644
index 0000000000..6d9093c676
--- /dev/null
+++ b/audio/wmusic-xmms/wmusic-xmms.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for wmusic-xmms
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=wmusic-xmms
+SRCNAM=wmusic
+VERSION=${VERSION:-1.5.0}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# ./configure ignores CFLAGS, hence the sed stuff. -include string.h
+# kills a couple of warnings.
+./configure
+sed -i "s,-g -O2,$SLKCFLAGS -include string.h," src/Makefile
+make
+
+# 'make install' ignores DESTDIR, it's only 1 file anyway.
+mkdir -p $PKG/usr/bin
+install -s -m0755 src/wmusic $PKG/usr/bin/$PRGNAM
+
+mkdir -p $PKG/usr/man/man1
+sed -e '/see the Info files/d' -e "s,$SRCNAM,$PRGNAM,g" -e "s,${SRCNAM^^},${PRGNAM^^},g" \
+ debian/$SRCNAM.1 | \
+ gzip -9c > $PKG/usr/man/man1/$PRGNAM.1.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/wmusic-xmms/wmusic-xmms.info b/audio/wmusic-xmms/wmusic-xmms.info
new file mode 100644
index 0000000000..d135a638e3
--- /dev/null
+++ b/audio/wmusic-xmms/wmusic-xmms.info
@@ -0,0 +1,10 @@
+PRGNAM="wmusic-xmms"
+VERSION="1.5.0"
+HOMEPAGE="https://www.dockapps.net/wmusic"
+DOWNLOAD="https://www.dockapps.net/download/wmusic-1.5.0.tar.gz"
+MD5SUM="20b39e0528089161998e2b0c77b1e4ea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"