summaryrefslogtreecommitdiffstats
path: root/audio/wmusic
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2016-08-16 00:09:41 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-20 07:50:03 +0700
commit9ea8ca2f3e46cddd21def8169693e13e39442e93 (patch)
treefa636520e65cd44ccb2f47a3a96a9e8f21877875 /audio/wmusic
parent4038188a747c97c3c4e7bae2eda993396d742b81 (diff)
downloadslackbuilds-9ea8ca2f3e46cddd21def8169693e13e39442e93.tar.gz
slackbuilds-9ea8ca2f3e46cddd21def8169693e13e39442e93.tar.xz
audio/wmusic: New maintainer, minor fixes.
Diffstat (limited to 'audio/wmusic')
-rw-r--r--audio/wmusic/wmusic.SlackBuild31
-rw-r--r--audio/wmusic/wmusic.info4
2 files changed, 23 insertions, 12 deletions
diff --git a/audio/wmusic/wmusic.SlackBuild b/audio/wmusic/wmusic.SlackBuild
index 2140c50d60..46de480ff5 100644
--- a/audio/wmusic/wmusic.SlackBuild
+++ b/audio/wmusic/wmusic.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for wmusic
#
-# Copyright 2015 Gethyn ThomasQuail <gethyn@bloodbathsoftworks.com>
+# Copyright 2015 Gethyn ThomasQuail <email removed>
# All rights reserved.
#
# Based on:
@@ -25,14 +25,23 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Currently maintained by B. Watson <yalhcru@gmail.com>
+
+# 20160816 bkw:
+# - take over maintenance
+# - BUILD=2
+# - actually use SLKCFLAGS
+# - install binary stripped
+# - remove 'see the Info files' from man page, as there is no info file.
+
PRGNAM=wmusic
VERSION=${VERSION:-1.5.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +52,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -72,17 +81,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# ./configure ignores CFLAGS, hence the sed stuff. -include string.h
+# kills a couple of warnings.
./configure
+sed -i "s,-g -O2,$SLKCFLAGS -include string.h," src/Makefile
make
+# 'make install' ignores DESTDIR, it's only 1 file anyway.
mkdir -p $PKG/usr/bin
-mv src/wmusic $PKG/usr/bin
+install -s -m0755 src/wmusic $PKG/usr/bin
mkdir -p $PKG/usr/man/man1
-
-# Compresses man page and moves it into place
-gzip -9 debian/wmusic.1
-mv debian/wmusic.1.gz $PKG/usr/man/man1
+sed '/see the Info files/d' debian/$PRGNAM.1 | \
+ gzip -9c > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README COPYING $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/audio/wmusic/wmusic.info b/audio/wmusic/wmusic.info
index 08d2c1f4b5..177f38f9d9 100644
--- a/audio/wmusic/wmusic.info
+++ b/audio/wmusic/wmusic.info
@@ -6,5 +6,5 @@ MD5SUM="20b39e0528089161998e2b0c77b1e4ea"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Gethyn ThomasQuail"
-EMAIL="gethyn@bloodbathsoftworks.com"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"