summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Grigorios Bouzakis <grbzks@xsmail.com>2010-04-18 22:10:38 -0400
committer David Somero <xgizzmo@slackbuilds.org>2010-05-15 10:38:24 +0200
commit6e89236570b7513dda366c820b5e867fce458379 (patch)
treee59d75e798f9a8364dbdd6b202374d039e1afa20 /audio
parenta34d866caefe789a75804e432a41947670c49857 (diff)
downloadslackbuilds-6e89236570b7513dda366c820b5e867fce458379.tar.gz
slackbuilds-6e89236570b7513dda366c820b5e867fce458379.tar.xz
audio/moc: Updated for version 2.5.0_alpha4.
Diffstat (limited to 'audio')
-rw-r--r--audio/moc/Makefile.patch11
-rw-r--r--audio/moc/README10
-rw-r--r--audio/moc/moc.SlackBuild62
-rw-r--r--audio/moc/moc.info14
-rw-r--r--audio/moc/slack-desc10
5 files changed, 66 insertions, 41 deletions
diff --git a/audio/moc/Makefile.patch b/audio/moc/Makefile.patch
new file mode 100644
index 0000000000..4859504b0d
--- /dev/null
+++ b/audio/moc/Makefile.patch
@@ -0,0 +1,11 @@
+--- moc-2.5.0-alpha4.orig/Makefile.in 2009-09-25 11:57:33.000000000 +0300
++++ moc-2.5.0-alpha4/Makefile.in 2010-04-11 03:26:29.856249035 +0300
+@@ -245,7 +245,7 @@
+ build_vendor = @build_vendor@
+ datadir = @datadir@
+ datarootdir = @datarootdir@
+-docdir = $(datadir)/doc/$(PACKAGE)
++docdir = @docdir@
+ dvidir = @dvidir@
+ exec_prefix = @exec_prefix@
+ host = @host@
diff --git a/audio/moc/README b/audio/moc/README
index 4fb619b26c..2688843951 100644
--- a/audio/moc/README
+++ b/audio/moc/README
@@ -1,2 +1,8 @@
-MOC is a console audio player for LINUX/UNIX designed to be powerful
-and easy to use.
+MOC is a console audio player with simple ncurses interface.
+It supports OGG, wave, and MP3 formats. Just run mocp, go to some directory
+using menu and press enter to start playing file, program will be playing
+automaticaly rest of the files in the directory.
+With no options and no file arguments the program begins in current directory
+or in MusicDir if StartIn‐MusicDir option is set. If you give a directory on
+the command line, MOC will try to go there. With files or multiple directories,
+everything will be added to the playlist recursively.
diff --git a/audio/moc/moc.SlackBuild b/audio/moc/moc.SlackBuild
index 1ec6aee561..21d517e311 100644
--- a/audio/moc/moc.SlackBuild
+++ b/audio/moc/moc.SlackBuild
@@ -1,29 +1,28 @@
#!/bin/sh
-
# Slackware build script for moc
# (C) 2009 Michael Wagner <slackware.wagnerm@arcor.de>
+# Copyright 2010 Grigorios Bouzakis <grbzks@xsmail.com>
# All rights reserved.
#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
+# Permission to use, copy, modify, and distribute this software for any purpose
+# with or without fee is hereby granted, provided that the above copyright
+# notice and this permission notice appear in all copies.
#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
+# INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
+# FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+# AUTHORS AND COPYRIGHT HOLDERS AND THEIR CONTRIBUTORS BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=moc
-VERSION=2.4.4
+VERSION=${VERSION:-2.5.0_alpha4}
+SRCVER=2.5.0-alpha4
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -44,14 +43,16 @@ elif [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
fi
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS TODO"
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.bz2
+cd $PRGNAM-$SRCVER
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -59,27 +60,34 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Get --docdir working
-sed -i 's,$(datadir)/doc/$(PACKAGE),@docdir@,' Makefile.in
+patch -p1 < $CWD/Makefile.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
--libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
--mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
--disable-debug \
- --disable-static \
--build=$ARCH-slackware-linux
make
-make install-strip DESTDIR=$PKG
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-gzip -9 $PKG/usr/man/man1/*.?
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/audio/moc/moc.info b/audio/moc/moc.info
index 7b8e68ad7f..786297bb0a 100644
--- a/audio/moc/moc.info
+++ b/audio/moc/moc.info
@@ -1,10 +1,10 @@
PRGNAM="moc"
-VERSION="2.4.4"
-HOMEPAGE="http://moc.daper.net"
-DOWNLOAD="ftp://ftp.daper.net/pub/soft/moc/stable/moc-2.4.4.tar.bz2"
-MD5SUM="647c770a5542a4ae5437386807a89796"
+VERSION="2.5.0_alpha4"
+HOMEPAGE="http://moc.daper.net/"
+DOWNLOAD="ftp://ftp.daper.net/pub/soft/moc/unstable/moc-2.5.0-alpha4.tar.bz2"
+MD5SUM="2dd0cb6481d77fda09c58ec3154a21c0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Michael Wagner"
-EMAIL="slackware.wagnerm@arcor.de"
-APPROVED="rworkman"
+MAINTAINER="Grigorios Bouzakis"
+EMAIL="grbzks@xsmail.com"
+APPROVED="dsomero"
diff --git a/audio/moc/slack-desc b/audio/moc/slack-desc
index 1ff6be1104..77a6e737ef 100644
--- a/audio/moc/slack-desc
+++ b/audio/moc/slack-desc
@@ -5,13 +5,13 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
-moc: MOC (music on console)
+ |-----handy-ruler----------------------------------------------------------|
+moc: moc (console audio player)
moc:
-moc: MOC is a console audio player for LINUX/UNIX
-moc: designed to be powerful and easy to use.
+moc: MOC is a console audio player with a simple ncurses interface.
+moc:
+moc: Homepage: http://moc.daper.net/
moc:
-moc: Homepage: http://moc.daper.net
moc:
moc:
moc: