summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author David Woodfall <dave@unrealize.co.uk>2010-05-13 00:57:30 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 00:57:30 +0200
commit1f7e9927e4bb1567554f752684760d90d24d6222 (patch)
treeb1cf0afb194402d404c8c35020942ff91392d3c6 /audio
parent41112b2fe107bdbbb97f5935a20f7f73ebafea4d (diff)
downloadslackbuilds-1f7e9927e4bb1567554f752684760d90d24d6222.tar.gz
slackbuilds-1f7e9927e4bb1567554f752684760d90d24d6222.tar.xz
audio/portmidi: Added to 13.0 repository
Diffstat (limited to 'audio')
-rw-r--r--audio/portmidi/README5
-rw-r--r--audio/portmidi/fixup_java_path.diff12
-rw-r--r--audio/portmidi/portmidi.SlackBuild103
-rw-r--r--audio/portmidi/portmidi.info10
-rw-r--r--audio/portmidi/slack-desc19
5 files changed, 149 insertions, 0 deletions
diff --git a/audio/portmidi/README b/audio/portmidi/README
new file mode 100644
index 0000000000..adc8f5e020
--- /dev/null
+++ b/audio/portmidi/README
@@ -0,0 +1,5 @@
+PortMidi is a computer library for real time input and output of MIDI data.
+It is designed to be portable to many different operating systems.
+PortMidi is part of the PortMusic project.
+
+This requires the jdk package from /extra.
diff --git a/audio/portmidi/fixup_java_path.diff b/audio/portmidi/fixup_java_path.diff
new file mode 100644
index 0000000000..45bf16d7b2
--- /dev/null
+++ b/audio/portmidi/fixup_java_path.diff
@@ -0,0 +1,12 @@
+diff -ur portmidi-orig/pm_common/CMakeLists.txt portmidi/pm_common/CMakeLists.txt
+--- portmidi-orig/pm_common/CMakeLists.txt 2009-10-19 19:41:21.000000000 +0100
++++ portmidi/pm_common/CMakeLists.txt 2009-12-06 22:52:04.000000000 +0000
+@@ -69,7 +69,7 @@
+ CACHE STRING "where to find Java SDK include directory")
+ set(JAVA_INCLUDE_PATHS ${JAVA_INCLUDE_PATH} ${JAVA_INCLUDE_PATH}/linux)
+ # libjvm.so is found relative to JAVA_INCLUDE_PATH:
+- set(JAVAVM_LIB ${JAVA_INCLUDE_PATH}/../jre/lib/i386/client/libjvm.so)
++ set(JAVAVM_LIB @LIBDIR@/libjvm.so)
+
+ set(LINUXSRC pmlinuxalsa pmlinux finddefault)
+ prepend_path(LIBSRC ../pm_linux/ ${LINUXSRC})
diff --git a/audio/portmidi/portmidi.SlackBuild b/audio/portmidi/portmidi.SlackBuild
new file mode 100644
index 0000000000..22f51979ef
--- /dev/null
+++ b/audio/portmidi/portmidi.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# Slackware build script for portmidi
+
+# Copyright 2009 David Woodfall <dave@unrealize.co.uk>
+# aka dive in #slackware on freenode.net
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. FURTHERMORE I AM NOT LIABLE IF
+# YOUR DATA IS DESTROYED, YOUR HOUSE BURNS DOWN OR YOUR DOG RUNS OFF.
+
+# Thanks to Camarade_Tux, Fire|Bird, and Metrofox for their assistance in
+# getting the 64 bit build to work, and for putting up with constant cries
+# for help ;-)
+
+
+PRGNAM=portmidi
+VERSION=${VERSION:-184}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+unzip $CWD/$PRGNAM-src-$VERSION.zip
+cd $PRGNAM
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix the libjvm.so path. This is *really* only needed on x86_64, but fixing
+# it on both arches looks prettier :-) --rworkman
+sed "s%@LIBDIR@%/usr/lib${LIBDIRSUFFIX}%" $CWD/fixup_java_path.diff | patch -p1
+
+cmake . \
+ -DCMAKE_C_FLAGS="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX="/usr"
+
+make
+make install DESTDIR=$PKG
+
+# Apparently that PREFIX="/usr" above was ignored... no surprise, I guess,
+# considering the fact that pretty much everything else is hardcoded badly
+mv $PKG/usr/local/{bin,include,lib} $PKG/usr
+rm -rf $PKG/usr/local
+[ "$ARCH" = "x86_64" ] && mv $PKG/usr/lib $PKG/usr/lib64
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/portmidi/portmidi.info b/audio/portmidi/portmidi.info
new file mode 100644
index 0000000000..ff90ce0054
--- /dev/null
+++ b/audio/portmidi/portmidi.info
@@ -0,0 +1,10 @@
+PRGNAM="portmidi"
+VERSION="184"
+HOMEPAGE="http://portmedia.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/portmedia/portmidi/184/portmidi-src-184.zip"
+MD5SUM="6d242a5cfe802cace10af733c185d1b6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@unrealize.co.uk"
+APPROVED="rworkman"
diff --git a/audio/portmidi/slack-desc b/audio/portmidi/slack-desc
new file mode 100644
index 0000000000..af8b171e82
--- /dev/null
+++ b/audio/portmidi/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+portmidi: portmidi (Realtime IO MIDI library)
+portmidi:
+portmidi: PortMidi is a computer library for real time input and output
+portmidi: of MIDI data.
+portmidi:
+portmidi: PortMidi is part of the PortMusic project.
+portmidi:
+portmidi:
+portmidi:
+portmidi:
+portmidi: