summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2017-01-16 21:30:56 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-21 07:04:23 +0700
commit87acde30f87714e048ac6088beca9a496986374d (patch)
treeb4bb701393d8ea928ea7094a3008daa1d558e7bb /audio
parenta07ce5c323130b81698f16c4187789dd46762db7 (diff)
downloadslackbuilds-87acde30f87714e048ac6088beca9a496986374d.tar.gz
slackbuilds-87acde30f87714e048ac6088beca9a496986374d.tar.xz
audio/pianobar: Updated for version 2016.06.02 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/pianobar/Makefile.diff25
-rw-r--r--audio/pianobar/README44
-rw-r--r--audio/pianobar/pianobar.SlackBuild52
-rw-r--r--audio/pianobar/pianobar.info14
-rw-r--r--audio/pianobar/slack-desc2
5 files changed, 68 insertions, 69 deletions
diff --git a/audio/pianobar/Makefile.diff b/audio/pianobar/Makefile.diff
deleted file mode 100644
index 2756b57cfd..0000000000
--- a/audio/pianobar/Makefile.diff
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Naur pianobar-2013.09.15-orig/Makefile pianobar-2013.09.15/Makefile
---- pianobar-2013.09.15-orig/Makefile 2013-09-15 09:54:04.000000000 -0400
-+++ pianobar-2013.09.15/Makefile 2013-09-27 23:54:19.406220780 -0400
-@@ -7,20 +7,7 @@
- MANDIR:=${PREFIX}/share/man
- DYNLINK:=0
-
--# Respect environment variables set by user; does not work with :=
--ifeq (${CFLAGS},)
-- CFLAGS=-O2 -DNDEBUG
--endif
--ifeq (${CC},cc)
-- OS := $(shell uname)
-- ifeq (${OS},Darwin)
-- CC=gcc -std=c99
-- else ifeq (${OS},FreeBSD)
-- CC=cc -std=c99
-- else
-- CC=c99
-- endif
--endif
-+CFLAGS+=-std=c99 -O2 -DNDEBUG
-
- PIANOBAR_DIR:=src
- PIANOBAR_SRC:=\
diff --git a/audio/pianobar/README b/audio/pianobar/README
index edf5a37632..8127637653 100644
--- a/audio/pianobar/README
+++ b/audio/pianobar/README
@@ -1,30 +1,34 @@
pianobar is a console client for the personalized web radio pandora
(http://www.pandora.com).
-- play and manage (create, add more music, delete, rename, ...) your stations
-- rate played songs and let pandora explain why they have been selected
-- show upcoming songs/song history
-- configure keybindings and text output
-- remote control and eventcmd interface (send tracks to last.fm, for example)
-- proxy support for listeners outside the USA
-
-Included with this SlackBuild is a helper script called pianobarctl that
-allows the user to remotely control some pianobar functions. To use
+- Play and manage (create, add more music, delete, rename, ...) your stations
+- Rate played songs and let pandora explain why they have been selected
+- Show upcoming songs/song history
+- Configure keybindings and text output
+- Remote control and eventcmd interface (send tracks to last.fm, for example)
+- Proxy support for listeners outside the USA
+
+Included with this SlackBuild is a helper script called pianobarctl that
+allows the user to remotely control some pianobar functions. To use
this a FIFO must first be created by the user:
- mkfifo ~/.config/pianobar/ctl
-Please see man pianobar and pianobarctl --help for more information.
+ mkfifo ~/.config/pianobar/ctl
+
+Please see man pianobar and pianobarctl --help for more information. The
+documentation also includes a few example scripts you can use with pianobar.
NOTE:
-Around the end of last year Pandora changed their certificate, so pianobar
-will not work unless you give it the new fingerprint.
+If you are getting an error stating your TLS fingerpring is incorrect you need
+to configure pianobar so that it has the correct one.
+
+You can execute the following script to get a new TLS fingerprint:
+
+ sh /usr/doc/pianobar-$VERSION/example-scripts/tls_fingerprint.sh
-In your pianobar config file (~/.config/pianobar/config) you need to have
-the following line:
- tls_fingerprint = 13CC51AC0C31CD96C55015C76914360F7AC41A00
+Then open your pianobar configuration in your user's home directory
+(~/.config/pianobar/config) and add the following line:
-(By the way, an example config file is in /usr/doc/pianobar-$VERSION/)
+ tls_fingerprint = XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
-The next time Pandora updates their cert again, you can quickly find the
-value needed by executing:
- sh /usr/doc/pianobar-$VERSION/example-scripts/tls_fingerprint.sh
+If for some reason you receive an error about the TLS fingerprint again, just
+execute tls_fingerprint.sh again and ammend your user's configuration file.
diff --git a/audio/pianobar/pianobar.SlackBuild b/audio/pianobar/pianobar.SlackBuild
index 68f7ee6d12..e109370767 100644
--- a/audio/pianobar/pianobar.SlackBuild
+++ b/audio/pianobar/pianobar.SlackBuild
@@ -1,16 +1,36 @@
#!/bin/sh
# Slackware build script for pianobar
-# Written by Phillip Warner <pc_warner@yahoo.com>
+
+# Copyright 2010-2016, Phillip Warner <pc_warner@yahoo.com>
+# Copyright 2017, Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pianobar
-VERSION=${VERSION:-2013.09.15}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2016.06.02}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -21,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -45,16 +65,12 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix Makefile
-patch -p1 < $CWD/Makefile.diff
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
-force_arch="$ARCH" \
gmake
gmake install DESTDIR=$PKG PREFIX="/usr" MANDIR="/usr/man"
@@ -62,18 +78,22 @@ gmake install DESTDIR=$PKG PREFIX="/usr" MANDIR="/usr/man"
# Install helper script
install -m 0755 $CWD/pianobarctl $PKG/usr/bin/pianobarctl
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING README INSTALL ChangeLog contrib/config-example \
+cp -a COPYING README.md INSTALL ChangeLog contrib/config-example \
$PKG/usr/doc/$PRGNAM-$VERSION
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts
cp -a contrib/*.sh contrib/headless_pianobar contrib/eventcmd-examples/ \
$PKG/usr/doc/$PRGNAM-$VERSION/example-scripts
find $PKG/usr/doc/$PRGNAM-$VERSION/example-scripts/ -type f -exec chmod -x '{}' \;
+
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.SBo
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/audio/pianobar/pianobar.info b/audio/pianobar/pianobar.info
index f43b84a316..bd483e5781 100644
--- a/audio/pianobar/pianobar.info
+++ b/audio/pianobar/pianobar.info
@@ -1,10 +1,10 @@
PRGNAM="pianobar"
-VERSION="2013.09.15"
-HOMEPAGE="http://6xq.net/projects/pianobar/"
-DOWNLOAD="http://6xq.net/static/projects/pianobar/pianobar-2013.09.15.tar.bz2"
-MD5SUM="9b5cb5cc31739cfc4bc1851dcbab78b7"
+VERSION="2016.06.02"
+HOMEPAGE="http://6xq.net/pianobar/"
+DOWNLOAD="https://6xq.net/pianobar/pianobar-2016.06.02.tar.bz2"
+MD5SUM="0fc71e7cd3840db43943dde60a781227"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="faad2"
-MAINTAINER="Phillip Warner"
-EMAIL="pc_warner@yahoo.com"
+REQUIRES="ffmpeg"
+MAINTAINER="Brenton Earl"
+EMAIL="brent@exitstatusone.com"
diff --git a/audio/pianobar/slack-desc b/audio/pianobar/slack-desc
index 2eb7cac78f..71c343b126 100644
--- a/audio/pianobar/slack-desc
+++ b/audio/pianobar/slack-desc
@@ -11,7 +11,7 @@ pianobar:
pianobar: pianobar is a console client for the personalized web radio pandora
pianobar: (http://www.pandora.com).
pianobar:
-pianobar: http://6xq.net/html/00/17.html
+pianobar: Home Page: http://6xq.net/pianobar/
pianobar:
pianobar:
pianobar: