summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author dsomero <xgizzmo@slackbuilds.org>2012-09-02 10:22:26 -0400
committer dsomero <xgizzmo@slackbuilds.org>2012-09-02 10:34:41 -0400
commitdc1cdf835dc1689b0511bf3a5c186a17df40d42c (patch)
tree54fbea6f291fc39ba9312746d28e2ec33570ac61 /audio
parentb76395f3995a0733ef2e87078c816cb0d6e41028 (diff)
downloadslackbuilds-dc1cdf835dc1689b0511bf3a5c186a17df40d42c.tar.gz
slackbuilds-dc1cdf835dc1689b0511bf3a5c186a17df40d42c.tar.xz
audio/aeolus: Fixed a underlinking problem, misc cleanups.
Added .deskyop file and icon also added stops as most of the other distro seem to include this. Also added a default config. Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/aeolus/aeolus.SlackBuild37
-rw-r--r--audio/aeolus/aeolus.desktop8
-rw-r--r--audio/aeolus/aeolus.info6
-rw-r--r--audio/aeolus/aeolus.pngbin0 -> 2321 bytes
-rw-r--r--audio/aeolus/aeolus_64.xpm75
-rw-r--r--audio/aeolus/doinst.sh15
6 files changed, 57 insertions, 84 deletions
diff --git a/audio/aeolus/aeolus.SlackBuild b/audio/aeolus/aeolus.SlackBuild
index b6cf383f75..c6760f5b29 100644
--- a/audio/aeolus/aeolus.SlackBuild
+++ b/audio/aeolus/aeolus.SlackBuild
@@ -4,7 +4,7 @@
PRGNAM=aeolus
VERSION=${VERSION:-0.8.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -42,6 +42,7 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
+tar xvf $CWD/stops-0.3.0.tar.bz2
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -49,18 +50,40 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-sed -i -e 's+/usr/local+/usr+' -e '/ldconfig/d' $TMP/$PRGNAM-$VERSION/source/Makefile
+sed -i -e 's+/usr/local+/usr+' \
+ -e '/ldconfig/d' \
+ -e 's|$(LDFLAGS)|$(LDFLAGS) -ldl|g' \
+ $TMP/$PRGNAM-$VERSION/source/Makefile
+
cd $TMP/$PRGNAM-$VERSION/source/
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ make
+ make install DESTDIR=$PKG
+cd ..
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make
-make install DESTDIR=$PKG
+cd stops-0.3.0
+ mkdir -p $PKG/usr/share/aeolus/stops
+ mv * $PKG/usr/share/aeolus/stops/
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-cd $TMP/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/share/applications
+install -m0644 $CWD/aeolus.desktop $PKG/usr/share/applications/aeolus.desktop
+
+mkdir -p $PKG/usr/share/pixmaps
+install -m0644 $CWD/aeolus.png $PKG/usr/share/pixmaps/aeolus.png
+
+# set reasonable default startup options:
+# jack driver, point to stops, store presets in user home directory
+mkdir -p $PKG/etc/
+cat << EOF > $PKG/etc/aeolus.conf.new
+# Aeolus default options
+-u -J -S /usr/share/aeolus/stops
+EOF
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS COPYING INSTALL \
diff --git a/audio/aeolus/aeolus.desktop b/audio/aeolus/aeolus.desktop
new file mode 100644
index 0000000000..f4929aec78
--- /dev/null
+++ b/audio/aeolus/aeolus.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Aeolus
+Comment=Organ Emulator
+Exec=/usr/bin/aeolus
+Terminal=false
+Type=Application
+Icon=aeolus
+Categories=AudioVideo;Audio;
diff --git a/audio/aeolus/aeolus.info b/audio/aeolus/aeolus.info
index 215e3d39d7..cb84dce19e 100644
--- a/audio/aeolus/aeolus.info
+++ b/audio/aeolus/aeolus.info
@@ -1,8 +1,10 @@
PRGNAM="aeolus"
VERSION="0.8.4"
HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/aeolus/index.html"
-DOWNLOAD="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/aeolus-0.8.4.tar.bz2"
-MD5SUM="0dcbfb2ab386419f306e1d947815163a"
+DOWNLOAD="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/aeolus-0.8.4.tar.bz2
+ http://kokkinizita.linuxaudio.org/linuxaudio/downloads/stops-0.3.0.tar.bz2"
+MD5SUM="0dcbfb2ab386419f306e1d947815163a \
+ 2a7b1cae820408fa1cc655800d08d88f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="clalsadrv clxclient jack-audio-connection-kit"
diff --git a/audio/aeolus/aeolus.png b/audio/aeolus/aeolus.png
new file mode 100644
index 0000000000..3f3a76ed04
--- /dev/null
+++ b/audio/aeolus/aeolus.png
Binary files differ
diff --git a/audio/aeolus/aeolus_64.xpm b/audio/aeolus/aeolus_64.xpm
deleted file mode 100644
index 457f31b464..0000000000
--- a/audio/aeolus/aeolus_64.xpm
+++ /dev/null
@@ -1,75 +0,0 @@
-/* XPM */
-static char * aeolus_64_xpm[] = {
-"64 64 8 1",
-" c #272744",
-". c #3D3522",
-"+ c #4B4838",
-"@ c #4A4A5F",
-"# c #59595B",
-"$ c #666865",
-"% c #6F707F",
-"& c #9A9BA1",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$@@@@@@@@@@#@@@@@@@@@@@@@@@@@@@@#@@@@@@@@@@@@@@@@@@@@#",
-"$&&&&$$$$$$@%%%%%%%& #@%%&%&%%@@@ %%%%%% # @%%%&%% @ %&%%%&&% #",
-"$&&&$$$$$$$@ @@@@@ # @ @@@ @@ @@@@ @ # @@@ @@ @ @ @ #",
-"$$$$$$$$$$$@ @@ # @@ @@ @@@@ % # @@ @@ @ #",
-"$$$$$$$$$$$@ @@ # @@ @@ @%%%@% # @@ @@ @@ #",
-"$$$$#######@@@##################################################",
-"$$$#@ #+++..+.+++$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$@ @@@@ #$++$+$$+$+$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$@ %%%% #$$$&$$$$$+$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$@ #+..+...+.+$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$#@@@@@@@@@#++++++++++$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$########$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$@@@@@@@@ @#@# @@@@@@@@ @ @@#@@@@ @@@@@@@@@ @ @#",
-"$&&$$$$$$$$@%&&&%&&& #@&&%&&&&%@@ %%&&%% # &&&&&% @@@&&&%%&& #",
-"$&&$$$$$$$$@ # @@ # @@ #",
-"$$$$$$$$$$$@ @% # &%%%@% @@ %%%%@% # %@%% @@ @ #",
-"$$$$$$$$$$$@ # @@@@@@ @@ @@@@@@ # @@@@ @@ @ #",
-"$$$$$#####$##########$##########################################",
-"$$$$@ #+........++.........#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$@ @@@ @@ #$++++++++++..$++$+..#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$@ &&&&%&@ +$$&&&&&&&++.+&$&&+..#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$@ #+........++.........#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$@ #++++++++++#.........#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$####@##@#@#@%##@###@##@###@#@@@#@@###@#@@##@@###@#@@#",
-"$&$$$$$$$$$@@%@@@%@% # %@%@%%%@ @ @%%@@@ # %%@@@@ @@ %%%@@ #",
-"$&$$$$$$$$$@ @@@@%@% # @@@@@%%@@@ @@%@@ # @@@@@@ @@ @%@@@ #",
-"$$$$$$$$$$$@ @@ # @@ @@ @ # @@ @@@% #",
-"$$$$$$$$$$$@ @@ # @@ @@ @ # @ @@ @@@@ #",
-"$$$$#######@@@@@@@@@@#@@@@@@@@@@@@@@@@@@@@#@@@#@##@###@#####@@##",
-"$$$#@ @%%%@@ @@ @@@%%@% @@ @@@ @+.......++#+......",
-"$$$$@ %@@@ @ @@%%%%@ @ @@@@@ @ @@@@@ @ +..++++...+..+.#$+",
-"$$$$@ @ @ @@@ @ %%%%%@ @ @@%%%%% +..+$$$...+..$$$$$",
-"$$$$@ @@ @ @@% @ @ +.........+.......",
-"$$$$@ @ @@ @@ @@ @@ @#........+#+......",
-"$$$$$########$$$########$$########$$$########$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$#@@@@@@@@@#@#@@@@@@@##@@@@@@@@@#@#@@@@@@@##@@@@@@@@@#",
-"$&&$$$$$$$$@ %%%%@%@ # &@%@%%%@@ %%%@%%@% # &@%@%%%@ @ @%%@@@ #",
-"$&$$$$$$$$$@ @@@@%%@ # @@@%%%%@@@ @@%@%%% # @@@%%%%@@@ @@@%@@ #",
-"$$$$$$$$$$$@ @@ # @@ @@ @ # @@ @ #",
-"$$$$$$$$$$$@ @& # %% @@ @@ # @@ @@ @ #",
-"$$$$#######@ @@@ @@@@#@@@@ @@@@@@@@@@@@@@#@@@@@@@@@##@@@@@@@@@#",
-"$$$#@@@@@@@@@@@%@@@%@@%@@# @#++++++++++#+++++++++#+++++++",
-"$$$#@@%%%%%%%@@%%%%%%@%@ @ @ @@ @ #...+++....+..++++...+..+++++",
-"$$$$@ @@ @@ @@@ @ %%%%%%@ #...&$$....+..$$$$...+..$$$$$",
-"$$$$@ @@ @ %@ @ @@@ #.....+....+....++...+.....++",
-"$$$$@ @@@ @@@ @@@ @@ #+.+...++++#........+#+..+...",
-"$$$$##########################################$#########$#######",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$##$$$$$$$$###$$$$$$$##$$$$$$$$$",
-"$$&$&&$$$$$$$$$&$&$$$$$$$$$$$###$&$$######$$&$###$##$&&$###$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$##############################$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$#######$$$$$####$#$$#######$$$$$$$",
-"$$&&&&$$$$$$$$$&$&$$$$$$$$$$$###$$$$######$$$$###$##&&$$###$$$$$",
-"$$$$$$$$$$$$$$$$$$#$$$$$$$$$$##############################$$$$$",
-"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$"};
diff --git a/audio/aeolus/doinst.sh b/audio/aeolus/doinst.sh
new file mode 100644
index 0000000000..3ac9fdd75d
--- /dev/null
+++ b/audio/aeolus/doinst.sh
@@ -0,0 +1,15 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ rm $NEW
+ fi
+}
+
+config etc/aeolus.conf.new
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi