summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Johannes Schoepfer <slackbuilds[at]schoepfer[dot]info>2016-07-30 07:10:21 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-30 07:10:21 +0700
commit28054cced21add6a56396ee32412d7041a6a4f7c (patch)
tree8ec5efba04f1d2fc9290fe0042a89b0d27648e9b /audio
parent927b20a517168ddbf9863756263e3320e7c74a62 (diff)
downloadslackbuilds-28054cced21add6a56396ee32412d7041a6a4f7c.tar.gz
slackbuilds-28054cced21add6a56396ee32412d7041a6a4f7c.tar.xz
audio/audacious-ffmpeg: Added (ffmpeg Decoder Plugin).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/audacious-ffmpeg/README4
-rw-r--r--audio/audacious-ffmpeg/audacious-ffmpeg.SlackBuild106
-rw-r--r--audio/audacious-ffmpeg/audacious-ffmpeg.info10
-rw-r--r--audio/audacious-ffmpeg/patches/enable_only_ffmpeg_plugin.diff8
-rw-r--r--audio/audacious-ffmpeg/slack-desc19
5 files changed, 147 insertions, 0 deletions
diff --git a/audio/audacious-ffmpeg/README b/audio/audacious-ffmpeg/README
new file mode 100644
index 0000000000..04da987f9f
--- /dev/null
+++ b/audio/audacious-ffmpeg/README
@@ -0,0 +1,4 @@
+audacious-ffmpeg (ffmpeg Decoder Plugin used by the Audacious player)
+
+This plugin adds all audio ffmpeg decoders to the Audacious media
+player that comes with Slackware stock packages
diff --git a/audio/audacious-ffmpeg/audacious-ffmpeg.SlackBuild b/audio/audacious-ffmpeg/audacious-ffmpeg.SlackBuild
new file mode 100644
index 0000000000..f45b5c764f
--- /dev/null
+++ b/audio/audacious-ffmpeg/audacious-ffmpeg.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/sh
+
+# Slackware build script for audacious-ffmpeg
+
+# Copyright 2016 Johannes Schoepfer, Herrenberg, BW; Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=audacious-ffmpeg
+VERSION=${VERSION:-3.7.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=audacious-plugins
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+ ARCHOPTS="--disable-sse2"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+ ARCHOPTS="--disable-sse2"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+ ARCHOPTS=""
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+ ARCHOPTS=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Patch Makefile to build only aac plugin
+patch -p1 <$CWD/patches/enable_only_ffmpeg_plugin.diff || exit 1
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --disable-aac \
+ --program-prefix= \
+ --program-suffix= \
+ ${ARCHOPTS} \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/audacious-ffmpeg/audacious-ffmpeg.info b/audio/audacious-ffmpeg/audacious-ffmpeg.info
new file mode 100644
index 0000000000..5370644793
--- /dev/null
+++ b/audio/audacious-ffmpeg/audacious-ffmpeg.info
@@ -0,0 +1,10 @@
+PRGNAM="audacious-ffmpeg"
+VERSION="3.7.2"
+HOMEPAGE="http://audacious-media-player.org/"
+DOWNLOAD="http://distfiles.audacious-media-player.org/audacious-plugins-3.7.2.tar.bz2"
+MD5SUM="6ae2f17885897e717b8bbafc32858e2f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="ffmpeg"
+MAINTAINER="Johannes Schoepfer"
+EMAIL="slackbuilds[at]schoepfer[dot]info"
diff --git a/audio/audacious-ffmpeg/patches/enable_only_ffmpeg_plugin.diff b/audio/audacious-ffmpeg/patches/enable_only_ffmpeg_plugin.diff
new file mode 100644
index 0000000000..feb3fab813
--- /dev/null
+++ b/audio/audacious-ffmpeg/patches/enable_only_ffmpeg_plugin.diff
@@ -0,0 +1,8 @@
+--- audacious-plugins-3.6.1/Makefile.ORIG 2015-04-04 02:02:06.000000000 +0200
++++ audacious-plugins-3.6.1/Makefile 2015-04-23 19:59:48.072721987 +0200
+@@ -1,4 +1,4 @@
+-SUBDIRS = src po
++SUBDIRS = src/ffaudio
+
+ DISTCLEAN = buildsys.mk config.h config.log config.status extra.mk
+
diff --git a/audio/audacious-ffmpeg/slack-desc b/audio/audacious-ffmpeg/slack-desc
new file mode 100644
index 0000000000..1c73a4afc1
--- /dev/null
+++ b/audio/audacious-ffmpeg/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+audacious-ffmpeg: audacious-ffmpeg (ffmpeg Decoder Plugin)
+audacious-ffmpeg:
+audacious-ffmpeg: This plugin adds all audio ffmpeg decoders to the Audacious media
+audacious-ffmpeg: player that comes with Slackware stock packages
+audacious-ffmpeg:
+audacious-ffmpeg: Homepage: http://audacious-media-player.org/
+audacious-ffmpeg:
+audacious-ffmpeg:
+audacious-ffmpeg:
+audacious-ffmpeg:
+audacious-ffmpeg: