summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Steven Voges <svoges.sbo@gmail.com>2022-09-24 03:01:04 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-09-25 13:59:45 +0700
commit7554998944d0f169e5355dd5b132736b84fd2ae9 (patch)
tree023fb5b358fe58d4d9a1c325b7500ee4e932413f /audio
parent064f4df1ea0ce38a168cc8b6132b5bfd879e2fd6 (diff)
downloadslackbuilds-7554998944d0f169e5355dd5b132736b84fd2ae9.tar.gz
slackbuilds-7554998944d0f169e5355dd5b132736b84fd2ae9.tar.xz
audio/FAudio: Updated for version 22.08.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/FAudio/0001-cmake.patch45
-rw-r--r--audio/FAudio/FAudio.SlackBuild25
-rw-r--r--audio/FAudio/FAudio.info10
-rw-r--r--audio/FAudio/README3
-rw-r--r--audio/FAudio/slack-desc2
5 files changed, 13 insertions, 72 deletions
diff --git a/audio/FAudio/0001-cmake.patch b/audio/FAudio/0001-cmake.patch
deleted file mode 100644
index 37d5e01276..0000000000
--- a/audio/FAudio/0001-cmake.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 931b198dae23863dd2e5c205bd819991a7259d85 Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Wed, 11 Nov 2020 10:05:41 -0800
-Subject: [PATCH] cmake: Fix compatiblity with older cmake versions.
-
-IMPORTED_TARGET was only introduced in cmake 3.6 and FAudio
-does not build with GStremer versions older than 1.9.2.
-
-Fixes https://github.com/FNA-XNA/FAudio/issues/226
-
-v2: Use _LDFLAGS to ensure linking against the correct gstreamer.
----
- CMakeLists.txt | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index bb57a672..58da7f18 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -142,9 +142,9 @@ if(GSTREAMER)
-
- # Find GStreamer
- find_package(PkgConfig)
-- pkg_check_modules(GST REQUIRED IMPORTED_TARGET gstreamer-1.0)
-- pkg_check_modules(GSTAUDIO REQUIRED IMPORTED_TARGET gstreamer-audio-1.0)
-- pkg_check_modules(GSTAPP REQUIRED IMPORTED_TARGET gstreamer-app-1.0)
-+ pkg_check_modules(GST REQUIRED gstreamer-1.0>=1.9.2)
-+ pkg_check_modules(GSTAUDIO REQUIRED gstreamer-audio-1.0>=1.9.2)
-+ pkg_check_modules(GSTAPP REQUIRED gstreamer-app-1.0>=1.9.2)
-
- # Include/Link GStreamer...
- target_include_directories(FAudio PRIVATE
-@@ -153,9 +153,9 @@ if(GSTREAMER)
- ${GSTAPP_INCLUDE_DIRS}
- )
- target_link_libraries(FAudio PRIVATE
-- PkgConfig::GST
-- PkgConfig::GSTAUDIO
-- PkgConfig::GSTAPP
-+ ${GST_LDFLAGS}
-+ ${GSTAUDIO_LDFLAGS}
-+ ${GSTAPP_LDFLAGS}
- )
- endif(GSTREAMER)
-
diff --git a/audio/FAudio/FAudio.SlackBuild b/audio/FAudio/FAudio.SlackBuild
index 3a257a7e7a..cfa49835dc 100644
--- a/audio/FAudio/FAudio.SlackBuild
+++ b/audio/FAudio/FAudio.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for FAudio
+# Copyright 2022 Steven Voges <Oregon, USA>
# Copyright 2019-2020 Hunter Sezen California, USA
# All rights reserved.
#
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=FAudio
-VERSION=${VERSION:-20.11}
+VERSION=${VERSION:-22.08}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,28 +77,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# gstreamer and gst-plugins-base are too old in Slackware 14.2.
-if pkg-config --atleast-version 1.9.2 gstreamer-1.0 &&
- pkg-config --atleast-version 1.9.2 gstreamer-audio-1.0 &&
- pkg-config --atleast-version 1.9.2 gstreamer-app-1.0; then
- GST=ON
-else
- GST=OFF
-fi
-
-# cmake: Fix compatiblity with older cmake versions.
-# https://github.com/FNA-XNA/FAudio/commit/6a1b6b5d7bc237635d8cbc143b42418c16651a35
-# https://github.com/FNA-XNA/FAudio/pull/227
-# https://github.com/FNA-XNA/FAudio/issues/226
-patch -p1 < $CWD/0001-cmake.patch
-
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
- -DGSTREAMER=$GST \
-DCMAKE_SKIP_RPATH=TRUE \
-DCMAKE_BUILD_TYPE=Release ..
make
@@ -111,7 +93,8 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/audio/FAudio/FAudio.info b/audio/FAudio/FAudio.info
index 7fb7595387..3225a1ab26 100644
--- a/audio/FAudio/FAudio.info
+++ b/audio/FAudio/FAudio.info
@@ -1,10 +1,10 @@
PRGNAM="FAudio"
-VERSION="20.11"
+VERSION="22.08"
HOMEPAGE="https://fna-xna.github.io/"
-DOWNLOAD="https://github.com/FNA-XNA/FAudio/archive/20.11/FAudio-20.11.tar.gz"
-MD5SUM="412d42ddf06b26fbabf7fd78af549f6f"
+DOWNLOAD="https://github.com/FNA-XNA/FAudio/archive/22.08/FAudio-22.08.tar.gz"
+MD5SUM="fca9b2d43a1008d7975b8c71530ccc53"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Hunter Sezen"
-EMAIL="orbea@riseup.net"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/audio/FAudio/README b/audio/FAudio/README
index d208b174bb..9c1144e3c9 100644
--- a/audio/FAudio/README
+++ b/audio/FAudio/README
@@ -1,3 +1,6 @@
This is FAudio, an XAudio reimplementation that focuses solely on
developing fully accurate DirectX Audio runtime libraries for the
FNA project, including XAudio2, X3DAudio, XAPO, and XACT3.
+
+FAudio will be held at version 22.08 on Slackware 15.0 as 22.09
+and newer require SDL >=2.24.0 to be present on the system.
diff --git a/audio/FAudio/slack-desc b/audio/FAudio/slack-desc
index 47d8200713..7910d1d9c9 100644
--- a/audio/FAudio/slack-desc
+++ b/audio/FAudio/slack-desc
@@ -12,7 +12,7 @@ FAudio: This is FAudio, an XAudio reimplementation that focuses solely on
FAudio: developing fully accurate DirectX Audio runtime libraries for the FNA
FAudio: project, including XAudio2, X3DAudio, XAPO, and XACT3.
FAudio:
-FAudio: Homepage: https://fna-xna.github.io/
+FAudio: Homepage: https://fna-xna.github.io
FAudio:
FAudio:
FAudio: