summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Steve Kennedy <steve@gnomeslackbuild.org>2011-06-17 14:51:39 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-06-17 14:51:39 -0500
commit238e5e77691dbcf6e756e46edc6213c3c676307a (patch)
treeed2fdce3db02956760a94d427c0027aa234f7e2c /audio
parent528be4e5ea6cb9cf6173df61df716d835782ab85 (diff)
downloadslackbuilds-238e5e77691dbcf6e756e46edc6213c3c676307a.tar.gz
slackbuilds-238e5e77691dbcf6e756e46edc6213c3c676307a.tar.xz
audio/volti: Added (gtk+ alsa volume control applet)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/volti/README5
-rw-r--r--audio/volti/doinst.sh4
-rw-r--r--audio/volti/slack-desc19
-rw-r--r--audio/volti/volti.SlackBuild92
-rw-r--r--audio/volti/volti.info10
5 files changed, 130 insertions, 0 deletions
diff --git a/audio/volti/README b/audio/volti/README
new file mode 100644
index 0000000000..4d63d3a43e
--- /dev/null
+++ b/audio/volti/README
@@ -0,0 +1,5 @@
+Volti is a GTK+ application for controlling audio volume from the system
+tray/notification area. It supports ALSA, multimedia keys on the keyboard,
+and desktop notifications on keys events.
+
+This requires pyalsaaudio.
diff --git a/audio/volti/doinst.sh b/audio/volti/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/audio/volti/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/audio/volti/slack-desc b/audio/volti/slack-desc
new file mode 100644
index 0000000000..3b9b196d04
--- /dev/null
+++ b/audio/volti/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+volti: volti (gtk+ alsa volume control applet)
+volti:
+volti: Volti is a GTK+ application for controlling audio volume from the
+volti: system tray/notification area. It supports ALSA, multimedia keys
+volti: on the keyboard, and desktop notifications on keys events.
+volti:
+volti:
+volti:
+volti:
+volti:
+volti:
diff --git a/audio/volti/volti.SlackBuild b/audio/volti/volti.SlackBuild
new file mode 100644
index 0000000000..4ec3ec3a8a
--- /dev/null
+++ b/audio/volti/volti.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/bash
+
+# Slackware build script for volti
+
+# Copyright 2011 Steve Kennedy (steve@gnomeslackbuild.org)
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=volti
+VERSION=${VERSION:-0.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --prefix=/usr --root=$PKG
+
+# Fix bad location of man pages
+mv $PKG/usr/share/man $PKG/usr
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README AUTHORS COPYING ChangeLog PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/volti/volti.info b/audio/volti/volti.info
new file mode 100644
index 0000000000..a4beb9fc80
--- /dev/null
+++ b/audio/volti/volti.info
@@ -0,0 +1,10 @@
+PRGNAM="volti"
+VERSION="0.2.3"
+HOMEPAGE="http://code.google.com/p/volti/"
+DOWNLOAD="http://volti.googlecode.com/files/volti-0.2.3.tar.gz"
+MD5SUM="f6e934527a4838058ece4de28433a564"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Steve Kennedy"
+EMAIL="steve@gnomeslackbuild.org"
+APPROVED="rworkman"