summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2012-09-24 11:00:19 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-24 22:53:32 -0500
commit368131a2ce84798c09c511e65e0ee41b1834f925 (patch)
tree8f6dadfaa85cf31417919e8a03e1bb8c6b53d940 /audio
parent92da5a007571783016bf8c6fd2e595feaad06ba2 (diff)
downloadslackbuilds-368131a2ce84798c09c511e65e0ee41b1834f925.tar.gz
slackbuilds-368131a2ce84798c09c511e65e0ee41b1834f925.tar.xz
audio/SuperCollider: Updated for version 3.5.5.
Updated SwingOSC for version 0.70. Switched from scons to cmake, noted opt. dependencies, cleanups Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/SuperCollider/README3
-rw-r--r--audio/SuperCollider/SuperCollider.SlackBuild46
-rw-r--r--audio/SuperCollider/SuperCollider.info12
-rw-r--r--audio/SuperCollider/fixups_for_x86_64.diff215
4 files changed, 210 insertions, 66 deletions
diff --git a/audio/SuperCollider/README b/audio/SuperCollider/README
index 356280df3c..56c6fcdf26 100644
--- a/audio/SuperCollider/README
+++ b/audio/SuperCollider/README
@@ -11,3 +11,6 @@ To use scvim editor copy the contents of /usr/share/scvim/vim to ~/.vim/
This will perform setcap cap_ipc_lock,cap_sys_nice=ep to /usr/bin/sclang,
/usr/bin/scsynth and /usr/bin/scvim. If you don't want this behaviour pass
CAPS="no" to the script.
+
+avahi (enabled with the switch AVAHI=yes), cwiid and gedit are optional
+dependencies.
diff --git a/audio/SuperCollider/SuperCollider.SlackBuild b/audio/SuperCollider/SuperCollider.SlackBuild
index 95ad609e93..8d6fc9cbe3 100644
--- a/audio/SuperCollider/SuperCollider.SlackBuild
+++ b/audio/SuperCollider/SuperCollider.SlackBuild
@@ -6,7 +6,9 @@
# contact: pfeifer[dot]felix[at]googlemail[dot]com
PRGNAM=SuperCollider
-VERSION=${VERSION:-3.4.4}
+VERSION=${VERSION:-3.5.5}
+PRGNAM2=SwingOSC
+VERSION2=${VERSION2:-0.70}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -43,9 +45,9 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-Source
-tar xvf $CWD/$PRGNAM-$VERSION-Source-linux.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION-Source-linux.tar.?z*
cd $PRGNAM-Source
-unzip $CWD/SwingOSC-0.65.zip
+unzip $CWD/$PRGNAM2-$VERSION2-Linux.zip -d $PRGNAM2
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -57,12 +59,34 @@ if [ "$LIBDIRSUFFIX" = "64" ]; then
patch -p1 < $CWD/fixups_for_x86_64.diff
fi
-cd common
- scons PREFIX=/usr X11=yes SCEL=yes SCED=yes SCVIM=yes LID=yes READLINE=no
- scons install DESTDIR=$PKG
-cd -
+# Pass AVAHI=yes to the script to enable avahi support
+if [ "${AVAHI:-no}" = "yes" ]; then avahi="OFF"; else avahi="ON"; fi
-# Compile and install SwingOSC
+# cwiid support is "autodetected"
+if [ -h /usr/lib$LIBDIRSUFFIX/libcwiid.so ]; then
+ cwiid="ON"
+else
+ cwiid="OFF"
+fi
+
+# Readline support don't work
+sed -i "s|^find_package(Readline\ 5\.0)|unset(READLINE_FOUND)|" lang/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DNO_AVAHI="$avahi" \
+ -DSC_WII="$cwiid" \
+ -DSC_ED="2" \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+# Install SwingOSC
cd SwingOSC
chmod 0755 install_linux_system.sh
./install_linux_system.sh $PKG/usr
@@ -76,16 +100,14 @@ cd editors/scvim
cp -r indent $PKG/usr/share/scvim/vim # the vim runtimepath
cp -r syntax $PKG/usr/share/scvim/vim # any idea where this might be globally?
cp scvimrc $PKG/usr/share/scvim
- cp -r scclasses $PKG/usr/share/SuperCollider/Extensions/scvim
cd -
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mv $PKG/usr/share/doc $PKG/usr
mv $PKG/usr/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING "README LINUX" VERSION $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog COPYING README_LINUX.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/audio/SuperCollider/SuperCollider.info b/audio/SuperCollider/SuperCollider.info
index 26a632dfb3..7a61dff8c3 100644
--- a/audio/SuperCollider/SuperCollider.info
+++ b/audio/SuperCollider/SuperCollider.info
@@ -1,12 +1,12 @@
PRGNAM="SuperCollider"
-VERSION="3.4.4"
+VERSION="3.5.5"
HOMEPAGE="http://supercollider.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/supercollider/SuperCollider-3.4.4-Source-linux.tar.gz \
- http://downloads.sourceforge.net/swingosc/SwingOSC-0.65.zip"
-MD5SUM="0277d4a76268d2c534c68168bb2dedae \
- 6c284f505525dff8462267958479ed1a"
+DOWNLOAD="http://downloads.sourceforge.net/supercollider/SuperCollider-3.5.5-Source-linux.tar.bz2 \
+ http://downloads.sourceforge.net/swingosc/SwingOSC-0.70-Linux.zip"
+MD5SUM="55c08e1d3665346b85dbff4c27c1accc \
+ cb4476bc48a75cc952e27bad4b95e65d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="jack-audio-connection-kit scons"
+REQUIRES="jack-audio-connection-kit jdk scons"
MAINTAINER="Felix Pfeifer"
EMAIL="pfeifer[dot]felix[at]googlemail[dot]com"
diff --git a/audio/SuperCollider/fixups_for_x86_64.diff b/audio/SuperCollider/fixups_for_x86_64.diff
index 13cd28628b..0973385dea 100644
--- a/audio/SuperCollider/fixups_for_x86_64.diff
+++ b/audio/SuperCollider/fixups_for_x86_64.diff
@@ -1,48 +1,167 @@
-diff -Nur SuperCollider-Source.orig//common/SConstruct SuperCollider-Source/common/SConstruct
---- SuperCollider-Source.orig//common/SConstruct 2010-03-11 14:11:21.000000000 -0600
-+++ SuperCollider-Source/common/SConstruct 2010-09-12 03:10:12.839854106 -0500
-@@ -153,7 +153,7 @@
- out.writelines([
- 'prefix=%s\n' % env['PREFIX'],
- 'exec_prefix=${prefix}\n',
-- 'libdir=${exec_prefix}/lib\n',
-+ 'libdir=${exec_prefix}/lib64\n',
- 'includedir=${prefix}/include/%s\n' % env['PACKAGE'],
- '\n'])
- write_field(out, 'PKGCONFIG_NAME', 'Name: ')
-@@ -211,7 +211,7 @@
- def bin_dir(prefix):
- return os.path.join(prefix, 'bin')
- def lib_dir(prefix):
-- return os.path.join(prefix, 'lib')
-+ return os.path.join(prefix, 'lib64')
-
- def pkg_data_dir(prefix, *args):
- if PLATFORM == 'darwin':
-@@ -369,13 +369,13 @@
-
- # checks for DISTCC and CCACHE as used in modern linux-distros:
-
--if os.path.exists('/usr/lib/distcc/bin'):
-- os.environ['PATH'] = '/usr/lib/distcc/bin:' + os.environ['PATH']
-+if os.path.exists('/usr/lib64/distcc/bin'):
-+ os.environ['PATH'] = '/usr/lib64/distcc/bin:' + os.environ['PATH']
- #env['ENV']['DISTCC_HOSTS'] = os.environ['DISTCC_HOSTS']
- env['ENV']['DISTCC_HOSTS'] = os.environ.get('DISTCC_HOSTS')
-
--if os.path.exists('/usr/lib/ccache/bin'):
-- os.environ['PATH'] = '/usr/lib/ccache/bin:' + os.environ['PATH']
-+if os.path.exists('/usr/lib64/ccache/bin'):
-+ os.environ['PATH'] = '/usr/lib64/ccache/bin:' + os.environ['PATH']
- #env['ENV']['CCACHE_DIR'] = os.environ['CCACHE_DIR']
- env['ENV']['CCACHE_DIR'] = os.environ.get('CCACHE_DIR')
-
-@@ -1011,7 +1011,7 @@
- CPPPATH = ['#include/icu/unicode'])
- elif PLATFORM == 'linux':
- langEnv.Append(
-- LINKFLAGS = ['-Wl,-rpath,build', '-Wl,-rpath,' + FINAL_PREFIX + '/lib'])
-+ LINKFLAGS = ['-Wl,-rpath,build', '-Wl,-rpath,' + FINAL_PREFIX + '/lib64'])
-
-
- elif PLATFORM == 'freebsd':
+diff -Naur SuperCollider-Source.orig/cmake_modules/FindFFTW3f.cmake SuperCollider-Source/cmake_modules/FindFFTW3f.cmake
+--- SuperCollider-Source.orig/cmake_modules/FindFFTW3f.cmake 2012-01-23 15:05:09.000000000 +0100
++++ SuperCollider-Source/cmake_modules/FindFFTW3f.cmake 2012-09-24 10:05:11.828461684 +0200
+@@ -11,9 +11,9 @@
+ FIND_LIBRARY(
+ FFTW3F_LIBRARY
+ NAMES fftw3f libfftw3f
+- HINTS $ENV{FFTW3_DIR}/lib
++ HINTS $ENV{FFTW3_DIR}/lib64
+ PATHS /usr/local/lib
+- /usr/lib
++ /usr/lib64
+ )
+
+ SET(FFTW3F_FOUND "NO")
+diff -Naur SuperCollider-Source.orig/cmake_modules/FindJack.cmake SuperCollider-Source/cmake_modules/FindJack.cmake
+--- SuperCollider-Source.orig/cmake_modules/FindJack.cmake 2012-01-23 15:05:09.000000000 +0100
++++ SuperCollider-Source/cmake_modules/FindJack.cmake 2012-09-24 10:05:11.828461684 +0200
+@@ -45,7 +45,7 @@
+ jack
+ PATHS
+ ${_JACK_LIBDIR}
+- /usr/lib
++ /usr/lib64
+ /usr/local/lib
+ /opt/local/lib
+ /sw/lib
+diff -Naur SuperCollider-Source.orig/cmake_modules/FindPortaudio.cmake SuperCollider-Source/cmake_modules/FindPortaudio.cmake
+--- SuperCollider-Source.orig/cmake_modules/FindPortaudio.cmake 2012-01-04 00:09:36.000000000 +0100
++++ SuperCollider-Source/cmake_modules/FindPortaudio.cmake 2012-09-24 10:05:11.832459176 +0200
+@@ -53,7 +53,7 @@
+ NAMES
+ portaudio
+ PATHS
+- /usr/lib
++ /usr/lib64
+ /usr/local/lib
+ /opt/local/lib
+ /sw/lib
+@@ -63,7 +63,7 @@
+ NAMES
+ portaudio
+ PATHS
+- /usr/lib
++ /usr/lib64
+ /usr/local/lib
+ /opt/local/lib
+ /sw/lib
+diff -Naur SuperCollider-Source.orig/editors/sced/CMakeLists.txt SuperCollider-Source/editors/sced/CMakeLists.txt
+--- SuperCollider-Source.orig/editors/sced/CMakeLists.txt 2012-09-02 14:59:36.000000000 +0200
++++ SuperCollider-Source/editors/sced/CMakeLists.txt 2012-09-24 10:21:37.405264362 +0200
+@@ -17,10 +17,10 @@
+ DESTINATION share/mime/packages)
+
+ install(FILES data/sced.gedit-plugin
+- DESTINATION lib/gedit-2/plugins)
++ DESTINATION lib64/gedit-2/plugins)
+
+ install(DIRECTORY sced
+- DESTINATION lib/gedit-2/plugins)
++ DESTINATION lib64/gedit-2/plugins)
+
+ elseif(NOT WIN32 AND SC_ED EQUAL 3)
+
+@@ -35,7 +35,7 @@
+ DESTINATION share/mime/packages)
+
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/sced3/supercollider.plugin sced3/supercollider.py
+- DESTINATION lib/gedit/plugins)
++ DESTINATION lib64/gedit/plugins)
+
+ elseif(WIN32)
+
+diff -Naur SuperCollider-Source.orig/external_libraries/boost_lockfree/libs/lockfree/examples/Jamfile.v2 SuperCollider-Source/external_libraries/boost_lockfree/libs/lockfree/examples/Jamfile.v2
+--- SuperCollider-Source.orig/external_libraries/boost_lockfree/libs/lockfree/examples/Jamfile.v2 2012-08-12 16:43:59.000000000 +0200
++++ SuperCollider-Source/external_libraries/boost_lockfree/libs/lockfree/examples/Jamfile.v2 2012-09-24 10:05:11.832459176 +0200
+@@ -4,7 +4,7 @@
+
+ project boost/lockfree/example
+ : requirements
+- <library>/usr/lib/libboost_thread.so # temporary hack
++ <library>/usr/lib64/libboost_thread.so # temporary hack
+ ;
+
+ exe fifo : fifo.cpp ;
+diff -Naur SuperCollider-Source.orig/external_libraries/oscpack/Makefile SuperCollider-Source/external_libraries/oscpack/Makefile
+--- SuperCollider-Source.orig/external_libraries/oscpack/Makefile 2012-01-04 00:09:36.000000000 +0100
++++ SuperCollider-Source/external_libraries/oscpack/Makefile 2012-09-24 10:05:11.832459175 +0200
+@@ -71,12 +71,12 @@
+
+ #Installs the library on a system global location
+ install: lib
+- @$(INSTALL) -m 755 $(LIBFILENAME) $(PREFIX)/lib/$(LIBFILENAME)
+- @ln -s -f $(PREFIX)/lib/$(LIBFILENAME) $(PREFIX)/lib/$(LIBSONAME)
++ @$(INSTALL) -m 755 $(LIBFILENAME) $(PREFIX)/lib64/$(LIBFILENAME)
++ @ln -s -f $(PREFIX)/lib64/$(LIBFILENAME) $(PREFIX)/lib64/$(LIBSONAME)
+ @mkdir -p $(PREFIX)/include/oscpack/ip $(PREFIX)/include/oscpack/osc
+ @$(INSTALL) -m 644 ip/*.h $(PREFIX)/include/oscpack/ip
+ @$(INSTALL) -m 644 osc/*.h $(PREFIX)/include/oscpack/osc
+- @echo "SUCCESS! oscpack has been installed in $(PREFIX)/lib and $(PREFIX)/include/ospack/"
++ @echo "SUCCESS! oscpack has been installed in $(PREFIX)/lib64 and $(PREFIX)/include/ospack/"
+ @echo "now doing ldconfig..."
+ @ldconfig
+
+diff -Naur SuperCollider-Source.orig/lang/CMakeLists.txt SuperCollider-Source/lang/CMakeLists.txt
+--- SuperCollider-Source.orig/lang/CMakeLists.txt 2012-09-02 14:59:36.000000000 +0200
++++ SuperCollider-Source/lang/CMakeLists.txt 2012-09-24 10:06:58.587243029 +0200
+@@ -307,7 +307,7 @@
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+ else()
+ install(TARGETS sclang
+- LIBRARY DESTINATION "lib"
++ LIBRARY DESTINATION "lib64"
+ RUNTIME DESTINATION "bin"
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+ endif()
+diff -Naur SuperCollider-Source.orig/server/plugins/CMakeLists.txt SuperCollider-Source/server/plugins/CMakeLists.txt
+--- SuperCollider-Source.orig/server/plugins/CMakeLists.txt 2012-09-02 14:59:36.000000000 +0200
++++ SuperCollider-Source/server/plugins/CMakeLists.txt 2012-09-24 10:05:54.339310317 +0200
+@@ -259,12 +259,12 @@
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+ else()
+ install(TARGETS ${plugins}
+- DESTINATION "lib/SuperCollider/plugins"
++ DESTINATION "lib64/SuperCollider/plugins"
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+
+ if (SUPERNOVA)
+ install(TARGETS ${supernova_plugins}
+- DESTINATION "lib/supernova/plugins"
++ DESTINATION "lib64/supernova/plugins"
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+ endif()
+ endif()
+diff -Naur SuperCollider-Source.orig/server/scsynth/CMakeLists.txt SuperCollider-Source/server/scsynth/CMakeLists.txt
+--- SuperCollider-Source.orig/server/scsynth/CMakeLists.txt 2012-09-02 14:59:36.000000000 +0200
++++ SuperCollider-Source/server/scsynth/CMakeLists.txt 2012-09-24 10:07:21.145304431 +0200
+@@ -160,7 +160,7 @@
+ endif(SNDFILE_FOUND)
+
+ if(CMAKE_SYSTEM_NAME MATCHES "Linux" OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+- add_definitions(-DSC_PLUGIN_DIR="${CMAKE_INSTALL_PREFIX}/lib/SuperCollider/plugins")
++ add_definitions(-DSC_PLUGIN_DIR="${CMAKE_INSTALL_PREFIX}/lib64/SuperCollider/plugins")
+ endif()
+
+ if (AUDIOAPI STREQUAL jack)
+@@ -229,7 +229,7 @@
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+ else()
+ install(TARGETS libscsynth scsynth
+- LIBRARY DESTINATION "lib"
++ LIBRARY DESTINATION "lib64"
+ RUNTIME DESTINATION "bin"
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+ endif()
+diff -Naur SuperCollider-Source.orig/server/supernova/server/main.cpp SuperCollider-Source/server/supernova/server/main.cpp
+--- SuperCollider-Source.orig/server/supernova/server/main.cpp 2012-09-02 14:59:36.000000000 +0200
++++ SuperCollider-Source/server/supernova/server/main.cpp 2012-09-24 10:05:11.833458554 +0200
+@@ -190,7 +190,7 @@
+
+ #ifdef __linux__
+ sc_factory->load_plugin_folder("/usr/local/lib/supernova/plugins");
+- sc_factory->load_plugin_folder("/usr/lib/supernova/plugins");
++ sc_factory->load_plugin_folder("/usr/lib64/supernova/plugins");
+ sc_factory->load_plugin_folder(home / "/.local/share/SuperCollider/supernova_plugins");
+ sc_factory->load_plugin_folder(home / "share/SuperCollider/supernova_plugins");
+ #elif defined(__APPLE__)