summaryrefslogtreecommitdiffstats
path: root/business/ledger
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-03-01 14:24:48 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-03 15:56:42 +0700
commit80e9be6722d64a2d8ebe8e29b98d2056c552a721 (patch)
tree916fadbffdf31281f68f95202670b49949e2627f /business/ledger
parent9b1f8da2b01b5a201fd8a2320455ba8ba574c1b6 (diff)
downloadslackbuilds-80e9be6722d64a2d8ebe8e29b98d2056c552a721.tar.gz
slackbuilds-80e9be6722d64a2d8ebe8e29b98d2056c552a721.tar.xz
business/ledger: Fix conflict with utfcpp.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'business/ledger')
-rw-r--r--business/ledger/README5
-rw-r--r--business/ledger/ledger.SlackBuild39
2 files changed, 21 insertions, 23 deletions
diff --git a/business/ledger/README b/business/ledger/README
index 33dbe598d7..18141c655e 100644
--- a/business/ledger/README
+++ b/business/ledger/README
@@ -1,7 +1,2 @@
Ledger is a powerful, double-entry accounting system that is accessed
from the UNIX command-line.
-
-* IMPORTANT NOTE *
-seems like utfcpp actually breaks compilation in current so be sure
-to remove that package if you have installed before trying to build
-ledger
diff --git a/business/ledger/ledger.SlackBuild b/business/ledger/ledger.SlackBuild
index d48a189ec0..5c473f3502 100644
--- a/business/ledger/ledger.SlackBuild
+++ b/business/ledger/ledger.SlackBuild
@@ -3,11 +3,17 @@
# Written by Lionel Young (redtricycle at gmail dot com)
# Updated by simotrone (simotrone at gmail dot com)
+# 20220301 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix conflict with utfcpp.
+# - don't include tools/ in the doc dir, it's upstream dev stuff.
+# - don't include empty /usr/share in package.
+# - include GLOSSARY.md in package, it looks useful.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ledger
VERSION=${VERSION:-3.2.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -19,14 +25,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
+# 20220301 bkw: no SLKCFLAGS here. cmake defaults to -O3 -fPIC, which is fine.
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -42,36 +47,34 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
patch -p1 < $CWD/CMakeLists.txt.patch
patch -p1 < $CWD/boost-176.patch
+# 20220301 bkw: do not look for utfcpp's headers in /usr/include, use
+# only the bundled copy (otherwise the build breaks if utfcpp is installed).
+sed -i '/find_path(/s,$, NO_DEFAULT_PATH,' cmake/FindUtfcpp.cmake
+
mkdir -p build
cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
..
- make
- make install DESTDIR=$PKG
+ make # VERBOSE=1 # uncomment if needed
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+rmdir $PKG/usr/share
+gzip -9 $PKG/usr/man/man*/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cp -a README.md doc/NEWS.md $PKG/usr/doc/$PRGNAM-$VERSION/
-
-cp -ra contrib $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ra test/input/* $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ra tools $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md doc/*.md contrib test/input/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION/
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc