summaryrefslogtreecommitdiffstats
path: root/business/ledger
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2021-05-22 19:42:38 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-26 08:07:33 +0700
commitb30c7869d97a7d86d141455b79f178894c48a2bc (patch)
tree142bf2d7345f635035a58a35c76d9ced2f018ed6 /business/ledger
parent02b04f8a67b011db32e529da2b74b97b9230b4ee (diff)
downloadslackbuilds-b30c7869d97a7d86d141455b79f178894c48a2bc.tar.gz
slackbuilds-b30c7869d97a7d86d141455b79f178894c48a2bc.tar.xz
business/ledger: Fix for boost >= 1.76.0.
Patch from alpinelinux Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'business/ledger')
-rw-r--r--business/ledger/boost-176.patch35
-rw-r--r--business/ledger/ledger.SlackBuild1
2 files changed, 36 insertions, 0 deletions
diff --git a/business/ledger/boost-176.patch b/business/ledger/boost-176.patch
new file mode 100644
index 0000000000..8032625b24
--- /dev/null
+++ b/business/ledger/boost-176.patch
@@ -0,0 +1,35 @@
+diff --git a/src/expr.cc b/src/expr.cc
+index c8945d3..ad2589a 100644
+--- a/src/expr.cc
++++ b/src/expr.cc
+@@ -278,7 +278,7 @@ value_t expr_value(expr_t::ptr_op_t op)
+ value_t source_command(call_scope_t& args)
+ {
+ std::istream * in = NULL;
+- scoped_ptr<ifstream> stream;
++ std::unique_ptr<ifstream> stream;
+ string pathname;
+
+ if (args.has(0)) {
+diff --git a/src/format.h b/src/format.h
+index 15431cf..57f3650 100644
+--- a/src/format.h
++++ b/src/format.h
+@@ -65,7 +65,7 @@ class format_t : public expr_base_t<string>, public noncopyable
+ std::size_t min_width;
+ std::size_t max_width;
+ variant<string, expr_t> data;
+- scoped_ptr<struct element_t> next;
++ std::unique_ptr<struct element_t> next;
+
+ element_t() throw()
+ : supports_flags<>(), type(STRING), min_width(0), max_width(0) {
+@@ -103,7 +103,7 @@ class format_t : public expr_base_t<string>, public noncopyable
+ void dump(std::ostream& out) const;
+ };
+
+- scoped_ptr<element_t> elements;
++ std::unique_ptr<element_t> elements;
+
+ public:
+ static enum elision_style_t {
diff --git a/business/ledger/ledger.SlackBuild b/business/ledger/ledger.SlackBuild
index 89b8bc095e..9cb3d59aeb 100644
--- a/business/ledger/ledger.SlackBuild
+++ b/business/ledger/ledger.SlackBuild
@@ -37,6 +37,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/CMakeLists.txt.patch
+patch -p1 < $CWD/boost-176.patch
mkdir -p build
cd build