summaryrefslogtreecommitdiffstats
path: root/business/tryton
diff options
context:
space:
mode:
author Ken Roberts <alisonken1@juno.com>2014-04-12 15:28:44 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-12 15:28:44 +0700
commit09d7ae6e029fa66f3d27223f23659812a7f0dbc8 (patch)
tree81fcfb74bfaa8dd7d3075d70d41c72638b9ea2db /business/tryton
parentffe3265036d01d67f32027b0ce45297fa87d90f1 (diff)
downloadslackbuilds-09d7ae6e029fa66f3d27223f23659812a7f0dbc8.tar.gz
slackbuilds-09d7ae6e029fa66f3d27223f23659812a7f0dbc8.tar.xz
business/tryton: Added (Tryton ERP -client part).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'business/tryton')
-rw-r--r--business/tryton/README14
-rw-r--r--business/tryton/slack-desc19
-rw-r--r--business/tryton/tryton.SlackBuild101
-rw-r--r--business/tryton/tryton.info10
4 files changed, 144 insertions, 0 deletions
diff --git a/business/tryton/README b/business/tryton/README
new file mode 100644
index 0000000000..e03ef204af
--- /dev/null
+++ b/business/tryton/README
@@ -0,0 +1,14 @@
+Tryton is a complete ERP. The main features are accounting
+(analytic and financial), stock management, sales and purchases management,
+POS, etc. Technical features include a distributed server, flexible workflows,
+an object database, a dynamic GUI, customizable reports, and SOAP and XML-RPC
+interfaces.
+
+This is the pygtk client for Tryton. Requires trytond available on either
+the same host or available via the network.
+
+If you want to integrate Google Calendar, then install
+GooCalendar (http://code.google.com/p/goocalendar/) - Not available on SBo.
+
+If you want to install the documentation, optional dependency is Sphinx
+documentation program (development/Sphinx).
diff --git a/business/tryton/slack-desc b/business/tryton/slack-desc
new file mode 100644
index 0000000000..66c4a91a66
--- /dev/null
+++ b/business/tryton/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tryton: tryton (Tryton ERP -client part)
+tryton:
+tryton: Tryton is a complete ERP written in Python.
+tryton:
+tryton: This package is for the client only - trytond (server) package must
+tryton: be installed somewhere that the client can reach.
+tryton:
+tryton: Homepage: http://www.tryton.org
+tryton:
+tryton:
+tryton:
diff --git a/business/tryton/tryton.SlackBuild b/business/tryton/tryton.SlackBuild
new file mode 100644
index 0000000000..4bf638475b
--- /dev/null
+++ b/business/tryton/tryton.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackware build script for Tryton client
+
+# Copyright 2014, Ken Roberts, California, USA"
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=tryton
+VERSION=${VERSION:-3.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYRIGHT INSTALL CHANGELOG LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/usr/share/applications
+cat $TMP/$PRGNAM-$VERSION/$PRGNAM.desktop >$PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Make documentation
+if [ -x /usr/bin/sphinx ] ; then
+ ( cd doc
+ make html
+ make pickle
+ make json
+ make htmlhelp
+ make qthelp
+ PAPER=letter make latex
+ mv ./_build/* $PKG/usr/doc/$PRGNAM-$VERSION/
+ )
+else
+ echo "Sphinx documenation program not found"
+ echo "Skipping document building"
+fi
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/business/tryton/tryton.info b/business/tryton/tryton.info
new file mode 100644
index 0000000000..829ad1c780
--- /dev/null
+++ b/business/tryton/tryton.info
@@ -0,0 +1,10 @@
+PRGNAM="tryton"
+VERSION="3.0.2"
+HOMEPAGE="http://www.tryton.org"
+DOWNLOAD="http://downloads.tryton.org/3.0/tryton-3.0.2.tar.gz"
+MD5SUM="0d3f2bd8662b222226676afcc23f38c7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-dateutil pytz simplejson"
+MAINTAINER="Ken Roberts"
+EMAIL="alisonken1@juno.com"