summaryrefslogtreecommitdiffstats
path: root/business
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2021-04-22 16:26:06 +0200
committer Robby Workman <rworkman@slackbuilds.org>2021-04-22 20:17:41 -0500
commitcc5785abba9cfa463b8cc9edfcb96cb9db0241ba (patch)
treebb5be8d6cc00a7de52d74bda6e5e623b3a2f0a94 /business
parent924d5fde3900620e07bdf96328419869bf49cc33 (diff)
downloadslackbuilds-cc5785abba9cfa463b8cc9edfcb96cb9db0241ba.tar.gz
slackbuilds-cc5785abba9cfa463b8cc9edfcb96cb9db0241ba.tar.xz
business/openerp-client: Removed.
Superceded by python/odoo Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'business')
-rw-r--r--business/openerp-client/README7
-rw-r--r--business/openerp-client/doinst.sh3
-rw-r--r--business/openerp-client/openerp-client.SlackBuild81
-rw-r--r--business/openerp-client/openerp-client.desktop10
-rw-r--r--business/openerp-client/openerp-client.info10
-rw-r--r--business/openerp-client/slack-desc19
6 files changed, 0 insertions, 130 deletions
diff --git a/business/openerp-client/README b/business/openerp-client/README
deleted file mode 100644
index e15ce427b2..0000000000
--- a/business/openerp-client/README
+++ /dev/null
@@ -1,7 +0,0 @@
-OpenERP is a free enterprise management software package. It covers all
-domains for small to medium businesses; accounting, stock management,
-sales, customer relationship, purchases, project management, etcetera.
-This is the client application.
-
-Note that you will get an error on startup if matplotlib is not
-installed, but the only functionality lost is presenting graphs.
diff --git a/business/openerp-client/doinst.sh b/business/openerp-client/doinst.sh
deleted file mode 100644
index 140e332222..0000000000
--- a/business/openerp-client/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications
-fi
diff --git a/business/openerp-client/openerp-client.SlackBuild b/business/openerp-client/openerp-client.SlackBuild
deleted file mode 100644
index 226918f09a..0000000000
--- a/business/openerp-client/openerp-client.SlackBuild
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for openerp-client
-
-# Copyright 2008-2009 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=openerp-client
-VERSION=${VERSION:-5.0.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-# the setup.py includes the build path, even if you add --prefix=/usr flag :\
-sed -i "s|$PKG||g" $PKG/usr/bin/openerp-client
-
-mkdir -p $PKG/usr/share/applications
-cp -f $CWD/openerp-client.desktop $PKG/usr/share/applications/
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/share/man $PKG/usr
-rm -rf $PKG/usr/share/man
-gzip -9 $PKG/usr/man/man?/*.?
-
-mv $PKG/usr/share/doc $PKG/usr
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/business/openerp-client/openerp-client.desktop b/business/openerp-client/openerp-client.desktop
deleted file mode 100644
index 46e3cd8d6d..0000000000
--- a/business/openerp-client/openerp-client.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Name=OpenERP
-GenericName=Enterprise Resource Planning
-Comment=Basic ERP & CRM
-Exec=openerp-client
-Icon=/usr/share/pixmaps/openerp-client/openerp-icon.png
-Terminal=false
-Type=Application
-Categories=Office;
-StartupNotify=true
diff --git a/business/openerp-client/openerp-client.info b/business/openerp-client/openerp-client.info
deleted file mode 100644
index 725d7e0e86..0000000000
--- a/business/openerp-client/openerp-client.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="openerp-client"
-VERSION="5.0.4"
-HOMEPAGE="http://www.openerp.com"
-DOWNLOAD="http://downloads.sourceforge.net/project/salix-sbo/13.37/openerp-client/openerp-client-5.0.4.tar.gz"
-MD5SUM="39657590a8d61f39cd8c55229e4643a6"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="openerp-server"
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@liwjatan.at"
diff --git a/business/openerp-client/slack-desc b/business/openerp-client/slack-desc
deleted file mode 100644
index 52ac17beae..0000000000
--- a/business/openerp-client/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-openerp-client: openerp-client (Complete ERP and CRM - client part)
-openerp-client:
-openerp-client: OpenERP is a free enterprise management software package. It
-openerp-client: covers all domains for small to medium businesses; accounting,
-openerp-client: stock management, sales, customer relationship, purchases,
-openerp-client: project management, et cetera.
-openerp-client: This is the client part.
-openerp-client:
-openerp-client: Homepage: http://www.openerp.com
-openerp-client:
-openerp-client: