summaryrefslogtreecommitdiffstats
path: root/desktop/CurseTheWeather
diff options
context:
space:
mode:
author Martin Lefebvre <dadexter@sekurity.com>2010-05-11 20:00:02 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-11 20:00:02 +0200
commitf00e8f73e090f921a8802b6b38101d459a8042b9 (patch)
tree67487db74f21e499e78fbb980d09e60411a629db /desktop/CurseTheWeather
parentfc8edb20b756fad5d427f82942f8f2a7ff0d7709 (diff)
downloadslackbuilds-f00e8f73e090f921a8802b6b38101d459a8042b9.tar.gz
slackbuilds-f00e8f73e090f921a8802b6b38101d459a8042b9.tar.xz
desktop/CurseTheWeather: Added to 12.0 repository
Diffstat (limited to 'desktop/CurseTheWeather')
-rw-r--r--desktop/CurseTheWeather/CurseTheWeather.SlackBuild57
-rw-r--r--desktop/CurseTheWeather/CurseTheWeather.info8
-rw-r--r--desktop/CurseTheWeather/README16
-rw-r--r--desktop/CurseTheWeather/slack-desc19
4 files changed, 100 insertions, 0 deletions
diff --git a/desktop/CurseTheWeather/CurseTheWeather.SlackBuild b/desktop/CurseTheWeather/CurseTheWeather.SlackBuild
new file mode 100644
index 0000000000..2820875b76
--- /dev/null
+++ b/desktop/CurseTheWeather/CurseTheWeather.SlackBuild
@@ -0,0 +1,57 @@
+#!/bin/sh
+
+# Slackware build script for CurseTheWeather
+
+# Copyright 2007 Martin Lefebvre <dadexter@sekurity.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by the SlackBuils.org project.
+
+PRGNAM=CurseTheWeather
+VERSION=0.3
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install --prefix $PKG/usr
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+zcat GPL.gz > $PKG/usr/doc/$PRGNAM-$VERSION/GPL
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/desktop/CurseTheWeather/CurseTheWeather.info b/desktop/CurseTheWeather/CurseTheWeather.info
new file mode 100644
index 0000000000..9668c6b7ab
--- /dev/null
+++ b/desktop/CurseTheWeather/CurseTheWeather.info
@@ -0,0 +1,8 @@
+PRGNAM="CurseTheWeather"
+VERSION="0.3"
+HOMEPAGE="http://opensource.hld.ca/trac.cgi/wiki/CurseTheWeather"
+DOWNLOAD="http://opensource.hld.ca/trac.cgi/browser/trunk/ctw/dist/CurseTheWeather-0.3.tar.gz?format=raw"
+MD5SUM="a391be3eca4d312951f3ecc923d1911f"
+MAINTAINER="Martin Lefebvre"
+EMAIL="dadexter@sekurity.com"
+APPROVED="BP{k}"
diff --git a/desktop/CurseTheWeather/README b/desktop/CurseTheWeather/README
new file mode 100644
index 0000000000..64f4305c01
--- /dev/null
+++ b/desktop/CurseTheWeather/README
@@ -0,0 +1,16 @@
+CurseTheWeather v0.3
+
+CurseTheWeather is a curses application which displays the
+weather in a terminal. It can give the current weather as
+well as forcast for up to 10 days.
+
+weatherfeed.py is a module that it uses and it can be used
+by other frontends to get weather information. Each time it
+is instantiated, it grabs the weather from weather.com
+
+Due to the fact that the CurseTheWeather website uses trac the
+download is somewhat misformed when using wget. If you use FF or another
+browser this problem should not occur.
+
+The following commandshould solve this:
+mv CurseTheWeather-0.3.tar.gz\?format\=raw CurseTheWeather-0.3.tar.gz
diff --git a/desktop/CurseTheWeather/slack-desc b/desktop/CurseTheWeather/slack-desc
new file mode 100644
index 0000000000..71aba06ee7
--- /dev/null
+++ b/desktop/CurseTheWeather/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+CurseTheWeather: CurseTheWeather (curses application which displays the weather)
+CurseTheWeather:
+CurseTheWeather: CurseTheWeather is a curses application which displays the
+CurseTheWeather: weather in a terminal. It can give the current weather as
+CurseTheWeather: well as forcast for up to 10 days.
+CurseTheWeather:
+CurseTheWeather: weatherfeei.py is a module that it uses and it can be used
+CurseTheWeather: by other frontends to get weather information. Each time it
+CurseTheWeather: is instantiated, it grabs the weather from weather.com
+CurseTheWeather:
+CurseTheWeather: