summaryrefslogtreecommitdiffstats
path: root/desktop/avant-window-navigator
diff options
context:
space:
mode:
author Roberto Metere <roberto{at}metere{dot}it>2011-07-17 19:10:39 -0400
committer Robby Workman <rworkman@slackbuilds.org>2011-07-21 22:51:49 -0500
commita49a9a9ef9af29c1121f639ce0d7cd89cc1243bd (patch)
treebac04e9f0005478e7bc31bbfd44070a5655b5d94 /desktop/avant-window-navigator
parentc80bb4f0354368d673ae2f572f9918987fe03974 (diff)
downloadslackbuilds-a49a9a9ef9af29c1121f639ce0d7cd89cc1243bd.tar.gz
slackbuilds-a49a9a9ef9af29c1121f639ce0d7cd89cc1243bd.tar.xz
desktop/avant-window-navigator: Added (Awn is a dock-like bar)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'desktop/avant-window-navigator')
-rw-r--r--desktop/avant-window-navigator/README12
-rw-r--r--desktop/avant-window-navigator/avant-window-navigator.SlackBuild116
-rw-r--r--desktop/avant-window-navigator/avant-window-navigator.info10
-rw-r--r--desktop/avant-window-navigator/doinst.sh10
-rw-r--r--desktop/avant-window-navigator/slack-desc23
5 files changed, 171 insertions, 0 deletions
diff --git a/desktop/avant-window-navigator/README b/desktop/avant-window-navigator/README
new file mode 100644
index 0000000000..d8dcf51ed6
--- /dev/null
+++ b/desktop/avant-window-navigator/README
@@ -0,0 +1,12 @@
+Avant Window Navigator (Awn)
+
+Avant Window Navigator is a dock-like bar which sits at the bottom of
+the screen. It has support for launchers, task lists, and third party
+applets.
+
+Requires libgtop, libdesktop-agnostic, GConf, ORBit2, and pyxdg.
+
+In order to handle transparencies that this application makes use of,
+you MUST use a composite desktop manager and, of course, enable
+compositing. Both KDE and XFCE from Slackware distro are composite
+capable.
diff --git a/desktop/avant-window-navigator/avant-window-navigator.SlackBuild b/desktop/avant-window-navigator/avant-window-navigator.SlackBuild
new file mode 100644
index 0000000000..9293dfa7d0
--- /dev/null
+++ b/desktop/avant-window-navigator/avant-window-navigator.SlackBuild
@@ -0,0 +1,116 @@
+#!/bin/sh
+
+# Slackware build script for avant-window-navigator
+
+# Copyright (c) 2010 Roberto Metere. All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=avant-window-navigator
+VERSION=0.4.0
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Configure
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-static=yes \
+ --enable-gtk-doc \
+ --docdir=/usr/doc/$PKGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+# Some error on 64 bit system which I cannot handle in other way
+if [ "$ARCH" = "x86_64" ]; then
+ MAKEFILES=$(ls -1 */*/Makefile */Makefile Makefile)
+ for i in $MAKEFILES
+ do
+ printf "Fixing \"$i\"... "
+ cat $i | sed "s/\/lib\ /\/lib${LIBDIRSUFFIX}\ /g" > $i.new
+ mv $i.new $i
+ printf "done.\n"
+ done
+fi
+
+# Build and install
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+( cd $PKG/usr/doc/$PRGNAM-$VERSION
+ ln -s ../../share/gtk-doc/html/libawn html
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/avant-window-navigator/avant-window-navigator.info b/desktop/avant-window-navigator/avant-window-navigator.info
new file mode 100644
index 0000000000..b40240357a
--- /dev/null
+++ b/desktop/avant-window-navigator/avant-window-navigator.info
@@ -0,0 +1,10 @@
+PRGNAM="avant-window-navigator"
+VERSION="0.4.0"
+HOMEPAGE="https://launchpad.net/awn"
+DOWNLOAD="http://launchpad.net/awn/0.4/0.4.0/+download/avant-window-navigator-0.4.0.tar.gz"
+MD5SUM="03654b45dd95cbb83fa7e112bd00523c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Roberto Metere"
+EMAIL="roberto{at}metere{dot}it"
+APPROVED="dsomero"
diff --git a/desktop/avant-window-navigator/doinst.sh b/desktop/avant-window-navigator/doinst.sh
new file mode 100644
index 0000000000..1f8ff67ded
--- /dev/null
+++ b/desktop/avant-window-navigator/doinst.sh
@@ -0,0 +1,10 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/desktop/avant-window-navigator/slack-desc b/desktop/avant-window-navigator/slack-desc
new file mode 100644
index 0000000000..14ed962d92
--- /dev/null
+++ b/desktop/avant-window-navigator/slack-desc
@@ -0,0 +1,23 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+avant-window-navigator: Avant Window Navigator (Awn is a dock-like bar)
+avant-window-navigator:
+avant-window-navigator: Avant Window Navigator is a dock-like bar which sits at the bottom
+avant-window-navigator: of the screen. It has support for launchers, task lists, and thirdy
+avant-window-navigator: party applets.
+avant-window-navigator:
+avant-window-navigator: Homepage: https://launchpad.net/awn
+avant-window-navigator:
+avant-window-navigator:
+avant-window-navigator:
+avant-window-navigator:
+
+
+
+