summaryrefslogtreecommitdiffstats
path: root/desktop/fusion-icon/fusion-icon.SlackBuild
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2016-07-30 06:44:14 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-30 06:44:14 +0700
commite4c19e3038779039d716c7cf66ac4c8218cf67c2 (patch)
treed210205553f043be125f18c540be606505226e1b /desktop/fusion-icon/fusion-icon.SlackBuild
parent7e4a0077cd132ae6f096dc303132c0ea3430e720 (diff)
downloadslackbuilds-e4c19e3038779039d716c7cf66ac4c8218cf67c2.tar.gz
slackbuilds-e4c19e3038779039d716c7cf66ac4c8218cf67c2.tar.xz
desktop/fusion-icon: Updated for version 0.2.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/fusion-icon/fusion-icon.SlackBuild')
-rw-r--r--desktop/fusion-icon/fusion-icon.SlackBuild38
1 files changed, 30 insertions, 8 deletions
diff --git a/desktop/fusion-icon/fusion-icon.SlackBuild b/desktop/fusion-icon/fusion-icon.SlackBuild
index 6249ecfaff..d6c31893d4 100644
--- a/desktop/fusion-icon/fusion-icon.SlackBuild
+++ b/desktop/fusion-icon/fusion-icon.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for fusion-icon
-# Written by M.Dinslage (daedra1980@gmail.com)
+# Copyright 2016 Matt Dinslage, Springfield, MO
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fusion-icon
-VERSION=${VERSION:-20080213}
+VERSION=${VERSION:-0.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -42,20 +60,24 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --prefix=/usr --root=$PKG
+python setup.py build install --prefix=/usr --with-qt=4.0 --with-gtk=2.0 --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Fix desktop icon to launch qt interface instead of gtk+ which is not supported
+# due to lack of dependencies.
+sed -i 's,Exec=fusion-icon,Exec=/usr/bin/fusion-icon -i qt,g' $TMP/package-fusion-icon/usr/share/applications/fusion-icon.desktop
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION