summaryrefslogtreecommitdiffstats
path: root/desktop/ion/ion.SlackBuild
diff options
context:
space:
mode:
author Vasilis Papavasileiou <el03020@mail.ntua.gr>2010-05-11 20:00:07 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:07 +0200
commit982d7e9e5261460e33beb7e3fcba5f34ee6fbe7e (patch)
tree9dc84342c93ce5274840480116fc22a1a2309ea2 /desktop/ion/ion.SlackBuild
parent1df084bbcab9fde8772b41852172310994405aec (diff)
downloadslackbuilds-982d7e9e5261460e33beb7e3fcba5f34ee6fbe7e.tar.gz
slackbuilds-982d7e9e5261460e33beb7e3fcba5f34ee6fbe7e.tar.xz
desktop/ion: Added to 12.0 repository
Diffstat (limited to 'desktop/ion/ion.SlackBuild')
-rw-r--r--desktop/ion/ion.SlackBuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/desktop/ion/ion.SlackBuild b/desktop/ion/ion.SlackBuild
new file mode 100644
index 0000000000..4be2348594
--- /dev/null
+++ b/desktop/ion/ion.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for ion
+# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
+# Modified by the SlackBuilds.org project
+# (assumed to be in public domain per our submission policy)
+
+PRGNAM=ion
+VERSION=3_20080207
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+SRC_VERSION=$(echo $VERSION | tr _ -)
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$SRC_VERSION
+tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz || exit 1
+cd $PRGNAM-$SRC_VERSION || exit 1
+#chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# If you have installed lua on your own, the binary might be stored under
+# /usr/local/bin or any other destination you have specified.
+# However, if lua is not located under /usr/bin, change the following
+# variable or run this script with the following command:
+# LUABINDIR="PATH_TO_BIN_DIRECTORY" ./ion.SlackBuild
+LUABINDIR=${LUABINDIR:-/usr}
+sed -i "s#+LUA_DIR=.*#+LUA_DIR=$LUABINDIR#" $CWD/system.mk.diff || exit 1
+
+# Patch system.mk (mainly path fixes)
+patch -p0 < $CWD/system.mk.diff || exit 1
+
+SLKCFLAGS=$SLKCFLAGS make || exit 1
+
+# DOCVER is used to get the proper version number for $DOCDIR
+make install DESTDIR=$PKG DOCVER="-$VERSION" || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
+)
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Install an xinitrc file so that ion will show up in xwmconfig
+install -D -m 0755 $CWD/xinitrc.ion $PKG/etc/X11/xinit/xinitrc.ion
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz