summaryrefslogtreecommitdiffstats
path: root/desktop/lxde-common
diff options
context:
space:
mode:
author ponce <matteo.bernardini@gmail.com>2011-03-31 15:32:34 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-03-31 15:32:34 -0500
commit757fa8f5b7affddbc7743bec9a01029ceed5d2c9 (patch)
tree921d72455e4e51c49e69ccbde8702ef504c3f647 /desktop/lxde-common
parentbf7f85f056f254d10f6574b26e7721a62c9e857e (diff)
downloadslackbuilds-757fa8f5b7affddbc7743bec9a01029ceed5d2c9.tar.gz
slackbuilds-757fa8f5b7affddbc7743bec9a01029ceed5d2c9.tar.xz
desktop/lxde-common: Updated for version 20110313_736ded3
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'desktop/lxde-common')
-rw-r--r--desktop/lxde-common/config/default-main.lxde3
-rw-r--r--desktop/lxde-common/config/default-pcmanfm.conf3
-rw-r--r--desktop/lxde-common/lxde-common.SlackBuild31
-rw-r--r--desktop/lxde-common/lxde-common.info8
4 files changed, 18 insertions, 27 deletions
diff --git a/desktop/lxde-common/config/default-main.lxde b/desktop/lxde-common/config/default-main.lxde
deleted file mode 100644
index 64ea8d0846..0000000000
--- a/desktop/lxde-common/config/default-main.lxde
+++ /dev/null
@@ -1,3 +0,0 @@
-[Desktop]
-show_wallpaper=1
-wallpaper=/usr/share/lxde/wallpapers/lxde_blue.jpg
diff --git a/desktop/lxde-common/config/default-pcmanfm.conf b/desktop/lxde-common/config/default-pcmanfm.conf
deleted file mode 100644
index eb917ff8ca..0000000000
--- a/desktop/lxde-common/config/default-pcmanfm.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-[desktop]
-wallpaper_mode=2
-wallpaper=/usr/share/lxde/wallpapers/lxde_blue.jpg
diff --git a/desktop/lxde-common/lxde-common.SlackBuild b/desktop/lxde-common/lxde-common.SlackBuild
index 2cf9ba96f8..62e9f73e27 100644
--- a/desktop/lxde-common/lxde-common.SlackBuild
+++ b/desktop/lxde-common/lxde-common.SlackBuild
@@ -37,6 +37,8 @@
# 0.5.0-1: 13/sep/2010 by ponce <matteo.bernardini@gmail.com>
# * Adapted to slackbuilds.org's autotools template.
# * fixed lxpanel and xinitrc
+# 20110313_736ded3: 29/mar/2011 by ponce <matteo.bernardini@gmail.com>
+# * updated to git version.
#
# Run 'sh lxde-common.SlackBuild' to build a Slackware package.
# The package is created in /tmp .
@@ -45,21 +47,19 @@
# -----------------------------------------------------------------------------
PRGNAM=lxde-common
-VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-20110313_736ded3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
-DOCS="AUTHORS COPYING ChangeLog NEWS README"
+DOCS="AUTHORS COPYING INSTALL ChangeLog NEWS README"
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
@@ -96,9 +96,14 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# patch panel config to use slackware applications and slightly modify default config
+# Patch panel config to use slackware applications and slightly modify default config
patch -p1 < $CWD/config/panel.patch
+# Look for a renamed file
+sed -i -e 's|lxde\.conf|LXDE.conf|' Makefile.am
+
+sh autogen.sh
+
CXXFLAGS="$SLKCFLAGS" \
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -116,7 +121,7 @@ make
make DESTDIR=$PKG install
mkdir -p $PKG/usr/share/applications
-cp lxde-logout.desktop $PKG/usr/share/applications
+cp lxde-logout.desktop $PKG/usr/share/applications/
# Add a xinitrc file for xwmconfig:
mkdir -p $PKG/etc/X11/xinit
@@ -129,20 +134,12 @@ mkdir -p $PKG/usr/share/apps/kdm/sessions
for i in $(ls ../../../xsessions/*.desktop) ; do ln -sf $i ; done
)
-# patch desktop.conf for Tango icon theme
+# Patch desktop.conf to use the Tango icon theme
sed -i -e 's#nuoveXT2#Tango#' $PKG/etc/xdg/lxsession/LXDE/desktop.conf
-# patch autostart for the new pcmanfm
-sed -i -e 's#pcmanfm#pcmanfm --desktop#' $PKG/etc/xdg/lxsession/LXDE/autostart
-
-# set a default config for pcmanfm
-mkdir -p $PKG/etc/xdg/pcmanfm
-cp $CWD/config/default-pcmanfm.conf $PKG/etc/xdg/pcmanfm/pcmanfm.conf
-cp $CWD/config/default-main.lxde $PKG/etc/xdg/pcmanfm/main.lxde
-
# Add documentation:
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION || true
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc -type f -exec chmod 644 {} \;
diff --git a/desktop/lxde-common/lxde-common.info b/desktop/lxde-common/lxde-common.info
index 94149c71e6..e52fda5ce7 100644
--- a/desktop/lxde-common/lxde-common.info
+++ b/desktop/lxde-common/lxde-common.info
@@ -1,10 +1,10 @@
PRGNAM="lxde-common"
-VERSION="0.5.0"
+VERSION="20110313_736ded3"
HOMEPAGE="http://www.lxde.org/"
-DOWNLOAD="http://downloads.sourceforge.net/lxde/lxde-common-0.5.0.tar.gz"
-MD5SUM="23606ab3d6e1039386d62a4b68b4ffc6"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/lxde/lxde-common-20110313_736ded3.tar.xz"
+MD5SUM="60a8b2049d02ff31bfb0de35a980c17b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="ponce"
EMAIL="matteo.bernardini@gmail.com"
-APPROVED="dsomero"
+APPROVED="rworkman"