summaryrefslogtreecommitdiffstats
path: root/desktop/simple-ccsm
diff options
context:
space:
mode:
author David Somero <dsomero@hotmail.com>2010-05-11 22:53:23 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 22:53:23 +0200
commitf6cd919609f18b0588bb728a4ad5c2f30c03cfe5 (patch)
tree78381652dbc423f7271b043b61aa11b62ee1224e /desktop/simple-ccsm
parent5ecc018472a9985ea15d7301c90862ae616b2be2 (diff)
downloadslackbuilds-f6cd919609f18b0588bb728a4ad5c2f30c03cfe5.tar.gz
slackbuilds-f6cd919609f18b0588bb728a4ad5c2f30c03cfe5.tar.xz
desktop/simple-ccsm: Added to 12.1 repository
Diffstat (limited to 'desktop/simple-ccsm')
-rw-r--r--desktop/simple-ccsm/README20
-rw-r--r--desktop/simple-ccsm/simple-ccsm.SlackBuild82
-rw-r--r--desktop/simple-ccsm/simple-ccsm.info8
-rw-r--r--desktop/simple-ccsm/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/desktop/simple-ccsm/README b/desktop/simple-ccsm/README
new file mode 100644
index 0000000000..eaa3369af8
--- /dev/null
+++ b/desktop/simple-ccsm/README
@@ -0,0 +1,20 @@
+CCSM, short for CompizConfig Settings Manager, is a configuration tool for
+Compiz Fusion. It is used to configure the many plugins included in Compiz and
+Compiz Fusion, as well as the use of various profiles and intergrating better
+with existing desktop settings. CCSM uses the CompizConfig compiz configuration
+system.
+
+Suggested build order:
+ 1. compiz-bcop
+ 2. libcompizconfig
+ 3. compizconfig-backend-kconfig (optional)
+ 4. compizconfig-backend-gconf (optional)
+ 5. compizconfig-python
+ 6. ccsm
+ 7. simple-ccsm (optional)
+ 8. compiz-fusion-plugins-main
+ 9. compiz-fusion-plugins-extra (optional)
+10. compiz-fusion-plugins-unsupported (optional)
+11. emerald (optional)
+12. emerald-themes (optional)
+13. fusion-icon (optional)
diff --git a/desktop/simple-ccsm/simple-ccsm.SlackBuild b/desktop/simple-ccsm/simple-ccsm.SlackBuild
new file mode 100644
index 0000000000..ccc9d2e85b
--- /dev/null
+++ b/desktop/simple-ccsm/simple-ccsm.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+
+# Slackware build script for simple-ccsm
+
+# Copyright 2008 David Somero <dsomero@hotmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=simple-ccsm
+VERSION=0.7.4
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --prefix=/usr --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+if [ -d $PKG/usr/man ]; then
+ ( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
+ )
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING* ChangeLog INSTALL NEWS README* TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/desktop/simple-ccsm/simple-ccsm.info b/desktop/simple-ccsm/simple-ccsm.info
new file mode 100644
index 0000000000..186df37aa5
--- /dev/null
+++ b/desktop/simple-ccsm/simple-ccsm.info
@@ -0,0 +1,8 @@
+PRGNAM="simple-ccsm"
+VERSION="0.7.4"
+HOMEPAGE="http://compiz-fusion.org/"
+DOWNLOAD="http://releases.compiz-fusion.org/0.7.4/simple-ccsm-0.7.4.tar.gz"
+MD5SUM="37acf8a34ece3f332972f5db9812cd7d"
+MAINTAINER="David Somero"
+EMAIL="dsomero@hotmail.com"
+APPROVED="rworkman"
diff --git a/desktop/simple-ccsm/slack-desc b/desktop/simple-ccsm/slack-desc
new file mode 100644
index 0000000000..c780a0a87d
--- /dev/null
+++ b/desktop/simple-ccsm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------|
+simple-ccsm: simple-ccsm (CompizConfig Settings Manager simple version)
+simple-ccsm:
+simple-ccsm: CCSM, short for CompizConfig Settings Manager, is a configuration
+simple-ccsm: tool for Compiz Fusion. It is used to configure the many plugins
+simple-ccsm: included in Compiz and Compiz Fusion, as well as the use of
+simple-ccsm: various profiles and intergrating better with existing desktop
+simple-ccsm: settings.
+simple-ccsm:
+simple-ccsm: CCSM uses the CompizConfig compiz configuration system.
+simple-ccsm:
+simple-ccsm: