summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2016-06-09 08:16:50 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-10 08:02:42 +0700
commit69f2751109f476b8b6824755b0d664f300bf2247 (patch)
tree33889a006219d756b7beb216653290d737281f37 /desktop
parent5f11f6bcd4d1ccc3f63828ef9b03e68921fd08da (diff)
downloadslackbuilds-69f2751109f476b8b6824755b0d664f300bf2247.tar.gz
slackbuilds-69f2751109f476b8b6824755b0d664f300bf2247.tar.xz
gis/qmapshack: Moved from desktop/ category.
Signed-off-by: David Spencer <baildon.research@googlemail.com>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/qmapshack/CMakeVersion.patch8
-rw-r--r--desktop/qmapshack/README5
-rw-r--r--desktop/qmapshack/doinst.sh3
-rw-r--r--desktop/qmapshack/qmapshack.SlackBuild90
-rw-r--r--desktop/qmapshack/qmapshack.info10
-rw-r--r--desktop/qmapshack/slack-desc19
6 files changed, 0 insertions, 135 deletions
diff --git a/desktop/qmapshack/CMakeVersion.patch b/desktop/qmapshack/CMakeVersion.patch
deleted file mode 100644
index 625dd819c3..0000000000
--- a/desktop/qmapshack/CMakeVersion.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- qmapshack-1.0.beta1/CMakeLists.txt 2015-02-23 22:57:29.010838124 +0100
-+++ qmapshack-1.0.beta1-A/CMakeLists.txt 2015-02-22 16:29:06.757835259 +0100
-@@ -1,4 +1,4 @@
--cmake_minimum_required(VERSION 3.0.0)
-+cmake_minimum_required(VERSION 2.8.12)
-
- project(QMapShack)
-
diff --git a/desktop/qmapshack/README b/desktop/qmapshack/README
deleted file mode 100644
index 5f510d8dce..0000000000
--- a/desktop/qmapshack/README
+++ /dev/null
@@ -1,5 +0,0 @@
-QMapShack provides a versatile tool for GPS maps in GeoTiff format
-as well as Garmin's img vector map format. You can also view and
-edit your GPX tracks.
-
-QMapShack is the successor of QLandkarteGT.
diff --git a/desktop/qmapshack/doinst.sh b/desktop/qmapshack/doinst.sh
deleted file mode 100644
index 140e332222..0000000000
--- a/desktop/qmapshack/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications
-fi
diff --git a/desktop/qmapshack/qmapshack.SlackBuild b/desktop/qmapshack/qmapshack.SlackBuild
deleted file mode 100644
index e496e0d7d6..0000000000
--- a/desktop/qmapshack/qmapshack.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for qmapshack
-# Copyright 2015 Daniel Stolarski <daniel.stolarski@gmail.com>
-#
-# This program is free software. It comes without any warranty, to
-# the extent permitted by applicable law. You can redistribute it
-# and/or modify it under the terms of the Do What The Fuck You Want
-# To Public License, Version 2, as published by Sam Hocevar. See
-# http://sam.zoy.org/wtfpl/COPYING for more details.
-
-PRGNAM=qmapshack
-VERSION=${VERSION:-1.3.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-patch -p1 < $CWD/CMakeVersion.patch
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DMAN_INSTALL_DIR=/usr/man \
- -DSYSCONF_INSTALL_DIR=/etc \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Move and compress man pages
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md changelog.txt LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/qmapshack/qmapshack.info b/desktop/qmapshack/qmapshack.info
deleted file mode 100644
index 892dbca855..0000000000
--- a/desktop/qmapshack/qmapshack.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="qmapshack"
-VERSION="1.3.0"
-HOMEPAGE="https://bitbucket.org/maproom/qmapshack/wiki/Home"
-DOWNLOAD="https://bitbucket.org/maproom/qmapshack/downloads/qmapshack-1.3.0.tar.gz"
-MD5SUM="f1d16bf227108edd6219341ea1352d1d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="gdal qt5"
-MAINTAINER="Daniel Stolarski"
-EMAIL="daniel.stolarski@gmail.com"
diff --git a/desktop/qmapshack/slack-desc b/desktop/qmapshack/slack-desc
deleted file mode 100644
index a618391083..0000000000
--- a/desktop/qmapshack/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-qmapshack: qmapshack (GPS mapping and GPSr management)
-qmapshack:
-qmapshack: QMapShack provides a versatile tool for GPS maps in GeoTiff format
-qmapshack: as well as Garmin's img vector map format. You can also view and
-qmapshack: edit your GPX tracks.
-qmapshack:
-qmapshack: QMapShack is the successor of QLandkarteGT.
-qmapshack:
-qmapshack:
-qmapshack:
-qmapshack: