summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Eugene Wissner <belka.ew@gmail.com>2010-05-13 00:57:42 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 00:57:42 +0200
commit6b837eb4ee747a5aadd004bb61bd613470612774 (patch)
tree53b14a3edfbbd5e8019fa64544b60a36c841b467 /desktop
parentf99a832fb44d23f1b9b708253b394bed85d6fa1c (diff)
downloadslackbuilds-6b837eb4ee747a5aadd004bb61bd613470612774.tar.gz
slackbuilds-6b837eb4ee747a5aadd004bb61bd613470612774.tar.xz
desktop/trayer: Added to 13.0 repository
Diffstat (limited to 'desktop')
-rw-r--r--desktop/trayer/README5
-rw-r--r--desktop/trayer/slack-desc19
-rw-r--r--desktop/trayer/trayer-1.0-good_deb_patches.diff263
-rw-r--r--desktop/trayer/trayer.SlackBuild79
-rw-r--r--desktop/trayer/trayer.info10
5 files changed, 376 insertions, 0 deletions
diff --git a/desktop/trayer/README b/desktop/trayer/README
new file mode 100644
index 0000000000..0cfa9d2867
--- /dev/null
+++ b/desktop/trayer/README
@@ -0,0 +1,5 @@
+trayer is a small program designed to provide systray functionality
+present in GNOME/KDE desktop environments for window managers which
+do not support that function. System tray is a place, where various
+applications put their icons, so they are always visible presenting
+status of applications and allowing user to control programs.
diff --git a/desktop/trayer/slack-desc b/desktop/trayer/slack-desc
new file mode 100644
index 0000000000..6d6bc363e5
--- /dev/null
+++ b/desktop/trayer/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-------handy-ruler----------------------------------------------------|
+trayer: trayer (GTK2-based systray for UNIX desktop)
+trayer:
+trayer: trayer is a small program designed to provide systray functionality
+trayer: present in GNOME/KDE desktop environments for window managers which
+trayer: do not support that function. System tray is a place, where various
+trayer: applications put their icons, so they are always visible presenting
+trayer: status of applications and allowing user to control programs.
+trayer: trayer code was extracted from fbpanel application.
+trayer:
+trayer: Homepage: http://gna.org/projects/fvwm-crystal/
+trayer:
diff --git a/desktop/trayer/trayer-1.0-good_deb_patches.diff b/desktop/trayer/trayer-1.0-good_deb_patches.diff
new file mode 100644
index 0000000000..500ebc071a
--- /dev/null
+++ b/desktop/trayer/trayer-1.0-good_deb_patches.diff
@@ -0,0 +1,263 @@
+diff -Nur trayer-1.0.orig/Makefile trayer-1.0/Makefile
+--- trayer-1.0.orig/Makefile 2005-01-14 16:46:19.000000000 -0600
++++ trayer-1.0/Makefile 2009-11-29 02:57:11.623693883 -0600
+@@ -19,6 +19,7 @@
+ SRC = panel.c misc.c plugin.c gtkbar.c bg.c
+ OBJ = $(SRC:%.c=%.o)
+ DEP = $(SRC:%.c=%.dep)
++MAN = trayer.1
+
+ SYSTRAYOBJ = systray/systray.o
+ SYSTRAYOBJ: systray
+@@ -36,25 +37,26 @@
+ TARGET = trayer
+ $(TARGET): $(OBJ) $(SYSTRAYOBJ)
+ $(CC) $(LDFLAGS) $(LIBS) $(OBJ) $(SYSTRAYOBJ) -o $@
+-ifeq (,$(DEVEL))
+- strip $@
+-endif
+
+-all: $(TARGET)
++TARGETMAN = $(TARGET).1.gz
++$(TARGETMAN): $(MAN)
++ gzip -9 -c $(MAN) >$@
+
++all: $(TARGET) $(TARGETMAN)
+
+-clean:
+- $(RM) $(TARGET) $(OBJ) $(DEP) *~
+
+-distclean:
+- rm -f Makefile.config config.h
++clean:
++ $(RM) $(TARGET) $(OBJ) $(DEP) *~ $(TARGETMAN)
+
+ install:
+ install -d $(PREFIX)/bin
++ install -d $(PREFIX)/bin $(PREFIX)/man/man1
+ install -m 755 $(TARGET) $(PREFIX)/bin
++ install -m 0644 $(TARGETMAN) $(PREFIX)/man/man1
+
+ uninstall:
+ rm -f $(PREFIX)/bin/$(TARGET)
++ rm -f $(PREFIX)/man/man1/$(TARGETMAN)
+
+ .PHONY: tar
+
+diff -Nur trayer-1.0.orig/Makefile.common trayer-1.0/Makefile.common
+--- trayer-1.0.orig/Makefile.common 2004-06-02 01:15:37.000000000 -0500
++++ trayer-1.0/Makefile.common 2009-11-29 02:53:51.301710924 -0600
+@@ -25,7 +25,7 @@
+ endif
+
+ # -DGTK_DISABLE_DEPRECATED does not work yet
+-CFLAGS += -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED
++CFLAGS += -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(INCS) -c $<
+diff -Nur trayer-1.0.orig/panel.c trayer-1.0/panel.c
+--- trayer-1.0.orig/panel.c 2005-02-11 12:27:03.000000000 -0600
++++ trayer-1.0/panel.c 2009-11-29 02:57:24.362673978 -0600
+@@ -588,7 +588,6 @@
+ printf(" --height <number>\n");
+ printf(" --SetDockType <true|false>\n");
+ printf(" --SetPartialStrut <true|false>\n");
+- printf(" --RoundCorners <true|false>\n");
+ printf(" --transparent <true|false>\n");
+ printf(" --alpha <number>\n");
+ printf(" --tint <int>\n");
+diff -Nur trayer-1.0.orig/trayer.1 trayer-1.0/trayer.1
+--- trayer-1.0.orig/trayer.1 1969-12-31 18:00:00.000000000 -0600
++++ trayer-1.0/trayer.1 2009-11-29 02:57:24.363674536 -0600
+@@ -0,0 +1,190 @@
++.TH TRAYER 1 "Feb 14, 2005" "FVWM\-Crystal"
++.SH NAME
++trayer \- a lightweight GTK2\-based systray for UNIX desktop
++.SH SYNOPSIS
++.B trayer \-h
++.br
++.B trayer \-v
++.br
++.B trayer
++.\"
++.RB [\| \-\-edge
++.RI \| left \||\| right \||\| top \||\| bottom \||\| none \|]
++.\"
++.RB [\| \-\-align
++.RI \| left \||\| right \||\| center \|]
++.\"
++.RB [\| \-\-margin
++.RI \| <size> \|]
++.\"
++.RB [\| \-\-widthtype
++.RI \| request \||\| pixel \||\| percent
++.RI \|]
++.\"
++.RB [\| \-\-width
++.RI \| <size> \|]
++.\"
++.RB [\| \-\-heighttype
++.RI \| <pixel> \|]
++.\"
++.RB [\| \-\-height
++.RI \| <size> \|]
++.\"
++.RB [\| \-\-SetDockType
++.RI \| true \||\| false \|]
++.\"
++.RB [\| \-\-SetPartialStrut
++.RI \| true \||\| false \|]
++.\"
++.RB [\| \-\-transparent
++.RI \| true \||\| false \|]
++.\"
++.RB [\| \-\-alpha
++.RI \| <value> \|]
++.\"
++.RB [\| \-\-tint
++.RI \| <color> \|]
++.\"
++.RB [\| \-\-distance
++.RI \| <length> \|]
++.\"
++.RB [\| \-\-expand
++.RI \| true \||\| false \|]
++.\"
++.RB [\| \-\-padding
++.RI \| <size> \|]
++.\"
++.SH DESCRIPTION
++.B trayer
++is a small program designed to provide system tray similar to these in
++.B GNOME
++/
++.B KDE
++desktop environments for window managers which does not
++support that function. It is similar to other applications such as
++.B peksystray
++and \fBdocker\fP.
++.PP
++System tray is a place, where many applications put their icons, so they are
++always visible. Such icons may present status of an application and allow user
++to control the program.
++.PP
++\fBtrayer\fP's code was extracted from \fBfbpanel\fP application, you can find more
++about it on its homepage: http://fbpanel.sourceforge.net/.
++.SH OPTIONS
++This programs follow the usual GNU command line syntax, with long
++options starting with two dashes (`-').
++A summary of options is included below.
++.TP
++.B \-\-help
++.TP
++.B \-h
++Show summary of options and exit.
++
++.TP
++.B \-\-version
++.TP
++.B \-v
++Show version of program and exit.
++
++.TP
++\fB\-\-edge\fP \fIleft\fP\||\|\fIright\fP\||\|\fItop\fP\||\|\fIbottom\fP\||\|\fInone\fP
++Specifies a screen edge to use.
++
++.TP
++\fB\-\-align\fP \fIleft\fP\||\|\fIcenter\fP\||\|\fIright\fP
++Specifies an align of the icons.
++
++.TP
++\fB\-\-margin\fP \fI<size>\fP
++Specifies length of margin (in pixels)
++
++.TP
++\fB\-\-widthtype\fB \fIrequest\fP\||\|\fIpixel\fP\||\|\fIpercent\fP
++Specifies method of calculating trayer's window width:
++.RS
++.TP
++\fIrequest\fP
++Follow application icons' size, so trayer may shrink or expand dynamically.
++
++.TP
++\fIpixel\fP
++Set a fixed size, given with \fB\-\-width\fP option in pixels.
++
++.TP
++\fIpercent\fP
++Set a fixed size, given with \fB\-\-width\fP option in percentage of a lenght of screen edge.
++.RE
++
++.TP
++\fB\-\-width\fP \fI<size>\fP
++Width of trayer's window. Ignored when \fB\-\-widthtype\fP is set to \fIrequest\fP.
++
++.TP
++\fB\-\-heighttype\fP \fIrequest\fP\||\|\fIpixel\fP\||\|\fIpercent\fP
++Specifies method of calculating trayer's window height:
++.RS
++.TP
++\fIrequest\fP
++Follow application icons' size, so trayer may shrink or expand dynamically.
++
++.TP
++\fIpixel\fP
++Set a fixed size, given with \fB\-\-height\fP option in pixels.
++
++.TP
++\fIpercent\fP
++Set a fixed size, given with \fB\-\-height\fP option in percentage of a lenght of screen edge.
++.RE
++
++.TP
++\fB\-\-height\fP \fI<size>\fP
++Height of trayer's window. Ignored when \fB\-\-heighttype\fP is set to \fIrequest\fP.
++
++.TP
++\fB\-\-SetDockType\fP \fItrue\fP\||\|\fIfalse\fP
++Identify panel window type as dock.
++
++.TP
++\fB\-\-SetPartialStrut\fP \fItrue\fP\||\|\fIfalse\fP
++Reserve panel space so that it will not be covered by maximized windows.
++
++.TP
++\fB\-\-transparent\fP \fItrue\fP\||\|\fIfalse\fP
++Use transparency.
++
++.TP
++\fB\-\-alpha\fP \fI<value>\fP
++Percentage of transparency (0 \- nontransparent, 255 \- fully transparent)
++
++.TP
++\fB\-\-tint\fP \fI<color>\fP
++Color used to tint transparent background. Color is given as a 24-bit C hexadecimal integer, for example: 0xff0000 is red, 0xff8800 is orange and 0x00ff00 is green.
++
++.TP
++\fB\-\-distance\fP \fI<length>\fP
++Specifies distance between trayer's window and screen edge (in pixels)
++
++.TP
++\fB\-\-expand\fP \fItrue\fP\||\|\fIfalse\fP
++Specifies whether trayer may accomodate extra space when there is too much
++icons.
++
++.TP
++\fB\-\-padding\fP \fI<size>\fP
++Extra space between icons and trayer window's border.
++
++.SH SEE ALSO
++.BR fbpanel (1)
++.SH AUTHORS
++Anatoly Asviyan <aanatoly@users.sf.net> \- fbpanel
++.br
++Rafal Bisingier <ravbc@man.poznan.pl>
++.br
++Maciej Delmanowski <harnir@users.berlios.de>
++.br
++Grzegorz Nieweglowski <hoppke@dobremiasto.net>
++.br
++Thomas Rydzynski
++.PP
++This manual page was written by Tomasz Melcer <liori@interia.pl>.
diff --git a/desktop/trayer/trayer.SlackBuild b/desktop/trayer/trayer.SlackBuild
new file mode 100644
index 0000000000..9530f40052
--- /dev/null
+++ b/desktop/trayer/trayer.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/sh
+
+# Slackware build script for trayer
+
+# Written by Eugene Wissner <belka.ew@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=trayer
+VERSION=${VERSION:-1.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Apply a patch based on the one from http://packages.ubuntu.com
+patch -p1 < $CWD/trayer-1.0-good_deb_patches.diff
+
+make PREFIX=/usr CFLAGS="$SLKCFLAGS"
+make install PREFIX=$PKG/usr
+strip --strip-unneeded $PKG/usr/bin/trayer
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING INSTALL README CHANGELOG \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/trayer/trayer.info b/desktop/trayer/trayer.info
new file mode 100644
index 0000000000..8ed8c545c4
--- /dev/null
+++ b/desktop/trayer/trayer.info
@@ -0,0 +1,10 @@
+PRGNAM="trayer"
+VERSION="1.0"
+HOMEPAGE="http://gna.org/projects/fvwm-crystal/"
+DOWNLOAD="http://download.gna.org/fvwm-crystal/trayer/1.0/trayer-1.0.tar.gz"
+MD5SUM="e1b0b6464f991f2c296561e377585867"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Eugene Wissner"
+EMAIL="belka.ew@gmail.com"
+APPROVED="rworkman"