summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Jorge Gajon <gajon@gajon.org>2010-05-13 00:22:46 +0200
committer Erik Hanson <erik@slackbuilds.org>2010-05-13 00:22:46 +0200
commitbb88211f5a75e24d4ffc895959ff677241f1f94f (patch)
treed27dc5c39e7dfb18c5d708fb79e782ca4c5ddc57 /desktop
parent04ebf629461708cda9a115849754e5169ffee4ea (diff)
downloadslackbuilds-bb88211f5a75e24d4ffc895959ff677241f1f94f.tar.gz
slackbuilds-bb88211f5a75e24d4ffc895959ff677241f1f94f.tar.xz
desktop/ion: Updated for version 3-20090110
Diffstat (limited to 'desktop')
-rw-r--r--desktop/ion/README8
-rw-r--r--desktop/ion/ion.SlackBuild58
-rw-r--r--desktop/ion/ion.info4
-rw-r--r--desktop/ion/slack-desc2
-rw-r--r--desktop/ion/system.mk.diff50
-rw-r--r--desktop/ion/xinitrc.ion4
6 files changed, 66 insertions, 60 deletions
diff --git a/desktop/ion/README b/desktop/ion/README
index f24b4997e0..4add64e8ea 100644
--- a/desktop/ion/README
+++ b/desktop/ion/README
@@ -8,10 +8,4 @@ This is the latest stable release of Ion (3). A pwm3 binary is built
too, which starts Ion with floating workspaces as the default, thus replacing
the PWM window manager.
-ion-3 needs lua, which is also available from SlackBuilds.org. If you have
-installed lua on your own, the binary might be stored under /usr/local/bin
-or any other destination you have specified.
-However, if lua is not located under /usr/bin, either change the LUABINDIR
-variable in the SlackBuild script or run the SlackBuild script with
-the following command:
- LUABINDIR="PATH_TO_BIN_DIRECTORY" ./ion.SlackBuild
+This requires lua.
diff --git a/desktop/ion/ion.SlackBuild b/desktop/ion/ion.SlackBuild
index d8aab1590a..1e1aafdf5c 100644
--- a/desktop/ion/ion.SlackBuild
+++ b/desktop/ion/ion.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for ion
# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
+# Updated by Jorge Gajon <gajon@gajon.org> for Slackware64 compatibility
# Modified by the SlackBuilds.org project
# (assumed to be in public domain per our submission policy)
@@ -20,38 +21,54 @@ SRC_VERSION=$(echo $VERSION | tr _ -)
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
+cd $TMP
rm -rf $PRGNAM-$SRC_VERSION
-tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz || exit 1
-cd $PRGNAM-$SRC_VERSION || exit 1
-#chown -R root:root .
+tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
+cd $PRGNAM-$SRC_VERSION
+chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# If you have installed lua on your own, the binary might be stored under
-# /usr/local/bin or any other destination you have specified.
-# However, if lua is not located under /usr/bin, change the following
-# variable or run this script with the following command:
-# LUABINDIR="PATH_TO_BIN_DIRECTORY" ./ion.SlackBuild
-LUABINDIR=${LUABINDIR:-/usr}
-sed -i "s#+LUA_DIR=.*#+LUA_DIR=$LUABINDIR#" $CWD/system.mk.diff || exit 1
+# Patch system.mk after filtering it through sed to replace a few path issues,
+# x86_64-specific things, and add optimization flags
+sed -e "s%@VERSION@%$VERSION%g" -e "s%@LIBDIRSUFFIX@%$LIBDIRSUFFIX%g" \
+ $CWD/system.mk.diff | patch -p1
-# Patch system.mk (mainly path fixes)
-patch -p0 < $CWD/system.mk.diff || exit 1
+make OPTS="$SLKCFLAGS" -j1
-SLKCFLAGS=$SLKCFLAGS make || exit 1
+# The Makefile doesn't support DESTDIR :/
+make install \
+ BINDIR=$PKG/usr/bin \
+ ETCDIR=$PKG/etc/ion3 \
+ SHAREDIR=$PKG/usr/share/ion3 \
+ MANDIR=$PKG/usr/man \
+ DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION \
+ INCDIR=$PKG/usr/include/ion3 \
+ LIBDIR=$PKG/usr/lib${LIBDIRSUFFIX} \
+ LOCALEDIR=$PKG/usr/share/locale
-# DOCVER is used to get the proper version number for $DOCDIR
-make install DESTDIR=$PKG DOCVER="-$VERSION" || exit 1
+# Install an xinitrc file so that ion will show up in xwmconfig
+# We also need to patch the reference to the X11 lib directory when
+# running on x86_64.
+install -D -m 0755 $CWD/xinitrc.ion $PKG/etc/X11/xinit/xinitrc.ion
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
@@ -61,11 +78,8 @@ make install DESTDIR=$PKG DOCVER="-$VERSION" || exit 1
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-# Install an xinitrc file so that ion will show up in xwmconfig
-install -D -m 0755 $CWD/xinitrc.ion $PKG/etc/X11/xinit/xinitrc.ion
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/ion/ion.info b/desktop/ion/ion.info
index 10ccca5cb8..f4e1e9dff7 100644
--- a/desktop/ion/ion.info
+++ b/desktop/ion/ion.info
@@ -3,6 +3,8 @@ VERSION="3-20090110"
HOMEPAGE="http://iki.fi/tuomov/ion/"
DOWNLOAD="http://iki.fi/tuomov/dl/ion-3-20090110.tar.gz"
MD5SUM="1f17be1e87187b4af7de047187cc4930"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="Jorge Gajon"
EMAIL="gajon@gajon.org"
-APPROVED="dsomero"
+APPROVED="Erik Hanson"
diff --git a/desktop/ion/slack-desc b/desktop/ion/slack-desc
index 1543e187ce..ea44f8e02f 100644
--- a/desktop/ion/slack-desc
+++ b/desktop/ion/slack-desc
@@ -7,7 +7,7 @@
|-----handy-ruler---------------------------------------------------------|
ion: ion (tiling tabbed window manager)
-ion:
+ion:
ion: Ion is a tiling (no overlapping windows) window manager that also has
ion: PWM-style tabbed frames which can contain multiple client windows.
ion: these features help to keep windows organized and to switch quickly
diff --git a/desktop/ion/system.mk.diff b/desktop/ion/system.mk.diff
index 7a2f09c308..d559ca17a5 100644
--- a/desktop/ion/system.mk.diff
+++ b/desktop/ion/system.mk.diff
@@ -1,6 +1,7 @@
---- system.mk.orig 2008-02-07 09:21:04.000000000 -0600
-+++ system.mk 2008-02-07 09:21:28.000000000 -0600
-@@ -8,25 +8,25 @@
+diff -Nur ion-3-20090110.orig/system.mk ion-3-20090110/system.mk
+--- ion-3-20090110.orig/system.mk 2009-01-09 16:20:27.000000000 -0600
++++ ion-3-20090110/system.mk 2009-09-28 09:47:40.062672371 -0500
+@@ -8,7 +8,7 @@
# Installation path prefix. Unless you know what you're doing, the default
# of /usr/local is likely the correct choice.
@@ -9,50 +10,40 @@
# Unless you are creating a package conforming to some OS's standards, you
# probably do not want to modify the following directories:
-
+@@ -16,17 +16,17 @@
# Main binaries
--BINDIR=$(PREFIX)/bin
-+BINDIR=$(DESTDIR)$(PREFIX)/bin
+ BINDIR=$(PREFIX)/bin
# Configuration .lua files
-ETCDIR=$(PREFIX)/etc/ion3
-+ETCDIR=$(DESTDIR)/etc/X11/ion3
++ETCDIR=/etc/ion3
# Some .lua files and ion-* shell scripts
--SHAREDIR=$(PREFIX)/share/ion3
-+SHAREDIR=$(DESTDIR)$(PREFIX)/share/ion3
+ SHAREDIR=$(PREFIX)/share/ion3
# Manual pages
-MANDIR=$(PREFIX)/share/man
-+MANDIR=$(DESTDIR)$(PREFIX)/man
++MANDIR=$(PREFIX)/man
# Some documents
-DOCDIR=$(PREFIX)/share/doc/ion3
-+DOCDIR=$(DESTDIR)$(PREFIX)/doc/ion$(DOCVER)
++DOCDIR=$(PREFIX)/doc/ion3-@VERSION@
# Nothing at the moment
--INCDIR=$(PREFIX)/include/ion3
-+INCDIR=$(DESTDIR)$(PREFIX)/include/ion3
+ INCDIR=$(PREFIX)/include/ion3
# Nothing at the moment
-LIBDIR=$(PREFIX)/lib
-+LIBDIR=$(DESTDIR)$(PREFIX)/lib
++LIBDIR=$(PREFIX)/lib@LIBDIRSUFFIX@
# Modules
MODULEDIR=$(LIBDIR)/ion3/mod
# Compiled Lua source code
-@@ -36,7 +36,7 @@
- # For ion-completeman system-wide cache
- VARDIR=/var/cache/ion3
- # Message catalogs
--LOCALEDIR=$(PREFIX)/share/locale
-+LOCALEDIR=$(DESTDIR)$(PREFIX)/share/locale
-
- # Executable suffix (for Cygwin).
- #BIN_SUFFIX = .exe
-@@ -62,7 +62,7 @@
+@@ -62,8 +62,8 @@
# If you have installed Lua 5.1 from the official tarball without changing
# paths, this should do it.
-LUA_DIR=/usr/local
+-LUA_LIBS = -L$(LUA_DIR)/lib -llua
+LUA_DIR=/usr
- LUA_LIBS = -L$(LUA_DIR)/lib -llua
++LUA_LIBS = -L$(LUA_DIR)/lib@LIBDIRSUFFIX@ -llua
LUA_INCLUDES = -I$(LUA_DIR)/include
LUA=$(LUA_DIR)/bin/lua
-@@ -81,7 +81,7 @@
+ LUAC=$(LUA_DIR)/bin/luac
+@@ -81,11 +81,11 @@
##
# Paths
@@ -61,12 +52,17 @@
# SunOS/Solaris
#X11_PREFIX=/usr/openwin
+-X11_LIBS=-L$(X11_PREFIX)/lib -lX11 -lXext
++X11_LIBS=-L$(X11_PREFIX)/lib@LIBDIRSUFFIX@/X11 -lX11 -lXext
+ X11_INCLUDES=-I$(X11_PREFIX)/include
+
+ # XFree86 libraries up to 4.3.0 have a bug that can cause a segfault.
@@ -157,7 +157,7 @@
-Wtrigraphs -Wformat -Wchar-subscripts \
-Wparentheses -pedantic -Wuninitialized
-CFLAGS=-Os $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
-+CFLAGS=-g $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES) $(SLKCFLAGS)
++CFLAGS= $(OPTS) $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
LDFLAGS=$(LIBS) $(EXTRA_LIBS)
EXPORT_DYNAMIC=-Xlinker --export-dynamic
diff --git a/desktop/ion/xinitrc.ion b/desktop/ion/xinitrc.ion
index 5579c7e48a..8fde6918aa 100644
--- a/desktop/ion/xinitrc.ion
+++ b/desktop/ion/xinitrc.ion
@@ -2,8 +2,8 @@
userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
-sysresources=/usr/lib/X11/xinit/.Xresources
-sysmodmap=/usr/lib/X11/xinit/.Xmodmap
+sysresources=/etc/X11/xinit/.Xresources
+sysmodmap=/etc/X11/xinit/.Xmodmap
# Merge in defaults and keymaps
test -f $sysresources && xrdb -merge $sysresources