summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Aaditya Bagga <aaditya_gnulinux@zoho.com>2014-04-15 23:20:09 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-23 07:51:26 +0700
commiteae1759fd2d81fdfa442e2692c92e9f085647027 (patch)
tree3cbc9b6b264d42f32ea54010568a616984a5051a /desktop
parenta56822128b587b18b333c4c55c24262f5fdd6b1a (diff)
downloadslackbuilds-eae1759fd2d81fdfa442e2692c92e9f085647027.tar.gz
slackbuilds-eae1759fd2d81fdfa442e2692c92e9f085647027.tar.xz
desktop/gtkhash: Added (utility to compute message digests).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/gtkhash/README4
-rw-r--r--desktop/gtkhash/README.Slackware32
-rw-r--r--desktop/gtkhash/doinst.sh5
-rw-r--r--desktop/gtkhash/gtkhash.SlackBuild105
-rw-r--r--desktop/gtkhash/gtkhash.info10
-rw-r--r--desktop/gtkhash/slack-desc19
6 files changed, 175 insertions, 0 deletions
diff --git a/desktop/gtkhash/README b/desktop/gtkhash/README
new file mode 100644
index 0000000000..d90d199e28
--- /dev/null
+++ b/desktop/gtkhash/README
@@ -0,0 +1,4 @@
+GtkHash is a GTK+ utility for computing message digests or checksums.
+
+Currently supported hash functions include MD5, MD6, SHA1, SHA256,
+SHA512, RIPEMD, TIGER and WHIRLPOOL.
diff --git a/desktop/gtkhash/README.Slackware b/desktop/gtkhash/README.Slackware
new file mode 100644
index 0000000000..af8ffb53cc
--- /dev/null
+++ b/desktop/gtkhash/README.Slackware
@@ -0,0 +1,32 @@
+Configure Options:
+
+Many configure options are given in the configure.ac file in the source,
+some of which are:
+--enable-debug
+--enable-linux-crypto
+--enable-gcrypt
+--enable-libcrypto
+--enable-polarssl
+--enable-nettle
+--enable-nss
+--enable-mhash
+--enable-nautilus
+--enable-nemo
+--enable-thunar
+
+The above configuration options are present in the SlackBuild and
+commented out; users can enable them according to their needs.
+
+Using with Thunar:
+
+Thunar's Custom Action feature can be used (Thunar -> Edit -> Configure Custom Action) to create a custom action in the menu for checking the md5sum.
+
+I used the following values:
+
+(Basic Tab)
+Name: Check md5sum
+Command: gtkhash %f
+
+(Appearence Tab)
+File Pattern: *.*z*
+Appears if: Other Files
diff --git a/desktop/gtkhash/doinst.sh b/desktop/gtkhash/doinst.sh
new file mode 100644
index 0000000000..6922dbb756
--- /dev/null
+++ b/desktop/gtkhash/doinst.sh
@@ -0,0 +1,5 @@
+if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/gtkhash/gtkhash.SlackBuild b/desktop/gtkhash/gtkhash.SlackBuild
new file mode 100644
index 0000000000..9cd41179ff
--- /dev/null
+++ b/desktop/gtkhash/gtkhash.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for gtkhash
+
+# Copyright 2014 Aaditya Bagga <aaditya_gnulinux@zoho.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gtkhash
+VERSION=${VERSION:-0.7.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux \
+# --enable-linux-crypto \
+# --enable-libcrypto \
+# --enable-thunar \
+# --enable-gcrypt \
+# --enable-debug \
+# --enable-nautilus \
+# --enable-nemo \
+# --enable-polarssl \
+# --enable-nettle \
+# --enable-nss \
+# --enable-mhash
+
+make
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/gtkhash/gtkhash.info b/desktop/gtkhash/gtkhash.info
new file mode 100644
index 0000000000..194d4fce01
--- /dev/null
+++ b/desktop/gtkhash/gtkhash.info
@@ -0,0 +1,10 @@
+PRGNAM="gtkhash"
+VERSION="0.7.0"
+HOMEPAGE="http://gtkhash.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/gtkhash/gtkhash/0.7.0/gtkhash-0.7.0.tar.gz"
+MD5SUM="5c48c5e55a6ee308bcc909bfb3e35752"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Aaditya Bagga"
+EMAIL="aaditya_gnulinux@zoho.com"
diff --git a/desktop/gtkhash/slack-desc b/desktop/gtkhash/slack-desc
new file mode 100644
index 0000000000..848aaaec0c
--- /dev/null
+++ b/desktop/gtkhash/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gtkhash: gtkhash (utility to compute message digests)
+gtkhash:
+gtkhash: GtkHash is a GTK+ utility for computing message digests
+gtkhash: or checksums.
+gtkhash:
+gtkhash: Currently supported hash functions include MD5, MD6,
+gtkhash: SHA1, SHA256, SHA512, RIPEMD, TIGER and WHIRLPOOL.
+gtkhash:
+gtkhash: Homepage: http://gtkhash.sourceforge.net/
+gtkhash:
+gtkhash: