summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2012-04-29 20:48:00 -0400
committer Erik Hanson <erik@slackbuilds.org>2012-04-30 00:40:06 -0500
commitee069898b81f8a4267d74c7b335ce9736325b4f7 (patch)
tree92b635564438a7194e5e5404948d118d7b3acc90 /desktop
parent994336ded25a60f271f4517771e4c22cabb28667 (diff)
downloadslackbuilds-ee069898b81f8a4267d74c7b335ce9736325b4f7.tar.gz
slackbuilds-ee069898b81f8a4267d74c7b335ce9736325b4f7.tar.xz
desktop/plasmaxplanet: Added (use Xplanet as KDE desktop wallpaper)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/plasmaxplanet/README4
-rw-r--r--desktop/plasmaxplanet/plasmaxplanet.SlackBuild82
-rw-r--r--desktop/plasmaxplanet/plasmaxplanet.info10
-rw-r--r--desktop/plasmaxplanet/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/desktop/plasmaxplanet/README b/desktop/plasmaxplanet/README
new file mode 100644
index 0000000000..13a718e176
--- /dev/null
+++ b/desktop/plasmaxplanet/README
@@ -0,0 +1,4 @@
+PlasmaXPlanet is a plugin for the plasma desktop which allows the use of
+Xplanet as the desktop wallpaper.
+
+Xplanet is required to use PlasmaXPlanet.
diff --git a/desktop/plasmaxplanet/plasmaxplanet.SlackBuild b/desktop/plasmaxplanet/plasmaxplanet.SlackBuild
new file mode 100644
index 0000000000..d86e1fff56
--- /dev/null
+++ b/desktop/plasmaxplanet/plasmaxplanet.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+# Written by Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
+# Based on http://slackbuilds.org/template.SlackBuild
+
+PRGNAM=plasmaxplanet
+VERSION=${VERSION:-0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=123336-plasmaxplanet
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+unzip -o $CWD/$SRCNAM.zip
+cd $PRGNAM
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# The default CMakeLists installs to the current user's home directory. The calls to sed redirect
+# output to the default KDE share and lib{,64} directories.
+sed s/\\/home\\/\$ENV{USER}\\/.kde\\/lib/\\/usr\\/lib$LIBDIRSUFFIX/ < CMakeLists.txt > CMakeLists.txt.tmp
+sed s/\\/home\\/\$ENV{USER}\\/.kde\\/share/\\/usr\\/share/ < CMakeLists.txt.tmp > CMakeLists.txt
+
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" ..
+
+make
+make install DESTDIR=$PKG
+cd ..
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README CHANGELOG \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/plasmaxplanet/plasmaxplanet.info b/desktop/plasmaxplanet/plasmaxplanet.info
new file mode 100644
index 0000000000..6e06f071a7
--- /dev/null
+++ b/desktop/plasmaxplanet/plasmaxplanet.info
@@ -0,0 +1,10 @@
+PRGNAM="plasmaxplanet"
+VERSION="0.1"
+HOMEPAGE="http://kde-look.org/content/show.php/PlasmaXPlanet?content=123336"
+DOWNLOAD="http://kde-look.org/CONTENT/content-files/123336-plasmaxplanet.zip"
+MD5SUM="4abb09d1bf9647eed17ec10a15d253e8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="bosth@alumni.sfu.ca"
+APPROVED="dsomero"
diff --git a/desktop/plasmaxplanet/slack-desc b/desktop/plasmaxplanet/slack-desc
new file mode 100644
index 0000000000..cbc42755e5
--- /dev/null
+++ b/desktop/plasmaxplanet/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+plasmaxplanet: plasmaxplanet (use Xplanet as KDE desktop wallpaper)
+plasmaxplanet:
+plasmaxplanet: PlasmaXPlanet is a plugin for the plasma desktop which allows
+plasmaxplanet: the use of Xplanet output as the desktop wallpaper.
+plasmaxplanet:
+plasmaxplanet:
+plasmaxplanet:
+plasmaxplanet:
+plasmaxplanet:
+plasmaxplanet:
+plasmaxplanet: