summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-07 11:49:37 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-09 15:45:07 +0700
commitfa62bdac86522126f89ef3468f67df268f4e271e (patch)
tree5a23f16f53fe2ac4eae09796e994ebab28a9a82c /desktop
parent158565bee2f99b837d3a32fc20dbbfedfdd88575 (diff)
downloadslackbuilds-fa62bdac86522126f89ef3468f67df268f4e271e.tar.gz
slackbuilds-fa62bdac86522126f89ef3468f67df268f4e271e.tar.xz
desktop/afterstep: Fix minor conflict with dpkg.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/afterstep/afterstep.SlackBuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/desktop/afterstep/afterstep.SlackBuild b/desktop/afterstep/afterstep.SlackBuild
index 8e0448d109..0eefdeeb3a 100644
--- a/desktop/afterstep/afterstep.SlackBuild
+++ b/desktop/afterstep/afterstep.SlackBuild
@@ -23,11 +23,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220407 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - remove broken symlink /usr/bin/x-window-manager (if dpkg is installed).
+# - remove useless INSTALL in doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=afterstep
VERSION=${VERSION:-20201113_f6da4b7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -71,18 +72,22 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Thanks debian!
patch -p1 < $CWD/binutils-2.36.patch
+# 20220407 bkw: if dpkg is installed, 'make install' writes to
+# /etc/alternatives (not inside $PKG). Stop it.
+sed -i '/^install:/s, *install\.alternative,,' src/afterstep/Makefile.in
+
CFLAGS="$SLKCFLAGS -fgnu89-inline" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -103,16 +108,16 @@ make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man*/*
install -D -m 0755 $CWD/xinitrc.afterstep $PKG/etc/X11/xinit/xinitrc.afterstep
mkdir -p $PKG/usr/doc
mv $PKG/usr/share/afterstep/doc/ $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYRIGHT ChangeLog INSTALL NEW README TEAM \
+cp -a COPYRIGHT ChangeLog NEW README TEAM \
doc/licences doc/languages doc/code $PKG/usr/doc/$PRGNAM-$VERSION
( cd $PKG/usr/share/afterstep ; ln -s ../../doc/$PRGNAM-$VERSION doc )
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc