summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2022-12-17 17:29:54 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-23 10:11:54 +0700
commit06bb1c782a19780ca2f527a6e90c4d17fb682996 (patch)
tree9644ce51558a57cb2c3bea52816e31c09ce12301 /desktop
parent672809fdef5233f0ce254cff7f12b817c9cc5009 (diff)
downloadslackbuilds-06bb1c782a19780ca2f527a6e90c4d17fb682996.tar.gz
slackbuilds-06bb1c782a19780ca2f527a6e90c4d17fb682996.tar.xz
desktop/xpra: Fix paths in 55_server_x11.conf.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/xpra/xpra.SlackBuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/desktop/xpra/xpra.SlackBuild b/desktop/xpra/xpra.SlackBuild
index 69eafd497b..5635d9f4a4 100644
--- a/desktop/xpra/xpra.SlackBuild
+++ b/desktop/xpra/xpra.SlackBuild
@@ -6,11 +6,14 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20221217 bkw: BUILD=2.
+# - fix paths in config file (do not include $PKG).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xpra
VERSION=${VERSION:-4.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -59,6 +62,9 @@ python3 setup.py install \
--without-strict \
--without-debug
+# 20221217 bkw: grrr. $PKG getting hardcoded in config file.
+sed -i "s,$PKG,,g" $PKG/etc/xpra/conf.d/55_server_x11.conf
+
# This is *much* faster than using 'file' to classify them.
find $PKG/usr/lib* -name '*.so' | xargs strip --strip-unneeded