summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:06:35 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:06:35 +0200
commit1d9c3e0bc5f30d302ee5edf6795c31130fccbb3e (patch)
tree8804aa0f18ab06c5d5904205ae4d37a1bf9dec45 /desktop
parent37ac434c4fa0aae7304a5c885daeec9744b14800 (diff)
downloadslackbuilds-1d9c3e0bc5f30d302ee5edf6795c31130fccbb3e.tar.gz
slackbuilds-1d9c3e0bc5f30d302ee5edf6795c31130fccbb3e.tar.xz
desktop/pypanel: Removed from 13.0 repository
Diffstat (limited to 'desktop')
-rw-r--r--desktop/pypanel/README11
-rw-r--r--desktop/pypanel/loaddelay.patch46
-rw-r--r--desktop/pypanel/pypanel.SlackBuild64
-rw-r--r--desktop/pypanel/pypanel.info8
-rw-r--r--desktop/pypanel/slack-desc19
5 files changed, 0 insertions, 148 deletions
diff --git a/desktop/pypanel/README b/desktop/pypanel/README
deleted file mode 100644
index 1cc5f674da..0000000000
--- a/desktop/pypanel/README
+++ /dev/null
@@ -1,11 +0,0 @@
-PyPanel is a lightweight panel/taskbar written in Python and C for X11
-window managers. It can be easily customized to match any desktop
-theme or taste. It works with WindowMaker and EWMH-compliant WMs
-(Kahakai, Openbox, FVWM, PekWM, etc).
-
-NOTE: The pypanel.SlackBuild has support for an optional third-party
-patch which introduces a STARTUP_DELAY variable that makes pypanel
-load after an interval of time. This is useful in case the window
-manager is slow to load up before pypanel starts.
-
-Pypanel requires python-xlib and imlib2.
diff --git a/desktop/pypanel/loaddelay.patch b/desktop/pypanel/loaddelay.patch
deleted file mode 100644
index 07ab8814b7..0000000000
--- a/desktop/pypanel/loaddelay.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- pypanel 2005-06-27 02:24:43.000000000 +0300
-+++ pypanel.new 2007-06-23 21:47:56.000000000 +0300
-@@ -95,6 +95,7 @@
- self.root.change_attributes(event_mask=(X.PropertyChangeMask))
- self.window.map()
- self.display.flush()
-+ self.updatePanel(self.root, self.window, self.panel)
- self.loop(self.display, self.root, self.window, self.panel)
-
- #------------------------------------
-@@ -944,6 +945,9 @@
- main = 2.4
- config = globals().get("VERSION", None)
-
-+ # Get the startup delay
-+ delay = globals().get("STARTUP_DELAY", None)
-+
- # Set locale to user's default
- locale.setlocale(locale.LC_ALL, "")
-
-@@ -953,5 +957,9 @@
- sys.stderr.write("\nA current pypanelrc example can be found here -\n")
- sys.stderr.write("%s/pypanel/pypanelrc\n\n" % sysconfig.get_python_lib())
- del main, config
--
-+
-+ # If delay is set, pause, and let windowmanager load
-+ if delay:
-+ time.sleep(delay)
-+
- PyPanel(display.Display())
---- pypanelrc 2005-06-27 02:27:37.000000000 +0300
-+++ pypanelrc.new 2007-06-23 21:46:01.000000000 +0300
-@@ -9,6 +9,12 @@
- VERSION = 2.4 # Config file version
-
- #------------------------------------------------------------------------------
-+# Startup delay: The time to wait before painting the pypanel window. This lets
-+# the background load up so that pypanel will be displayed correctly.
-+#------------------------------------------------------------------------------
-+STARTUP_DELAY = 2
-+
-+#------------------------------------------------------------------------------
- # Colors: Format is hex triplet - 0xrrggbb
- #------------------------------------------------------------------------------
- BG_COLOR = "0xd6d6d6" # Panel background and tinting color
diff --git a/desktop/pypanel/pypanel.SlackBuild b/desktop/pypanel/pypanel.SlackBuild
deleted file mode 100644
index 3e7de35a31..0000000000
--- a/desktop/pypanel/pypanel.SlackBuild
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pypanel
-# Originally written by Vasilis Papavasileiou
-# <el03020 at mail dot ntua dot gr>
-
-# Modified by the SlackBuilds.org project
-# and Chess Griffin <chess@chessgriffin.com>
-
-PRGNAM=pypanel
-VERSION=2.4
-ARCH=i486 # See note below
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-# Re ARCH, this will use whatever CFLAGS python was compiled with, so...
-# Since this contains some C code, you will get an i486 package when
-# building on official Slackware. Adjust as appropriate.
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-ORIG_PRGNAM=PyPanel
-DOCS="COPYING PKG-INFO README pypanelrc"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $ORIG_PRGNAM-$VERSION
-tar xvf $CWD/$ORIG_PRGNAM-$VERSION.tar.gz
-cd $ORIG_PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Uncomment the patch line below if you want the STARTUP_DELAY
-# variable. This introduces a new configuration file variable called
-# STARTUP_DELAY which will make pypanel load after an interval of
-# time. This is useful in case the window manager is slow to load up
-# before pypanel starts.
-#patch < $CWD/loaddelay.patch
-
-python setup.py install --root $PKG || exit 1
-
-( cd $PKG
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Remove docs from site-packages
-rm $PKG/usr/lib/python?.?/site-packages/${PRGNAM}/{COPYING,README}
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/desktop/pypanel/pypanel.info b/desktop/pypanel/pypanel.info
deleted file mode 100644
index 6ec231fc99..0000000000
--- a/desktop/pypanel/pypanel.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="pypanel"
-VERSION="2.4"
-HOMEPAGE="http://pypanel.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/pypanel/PyPanel-2.4.tar.gz"
-MD5SUM="f1f9a2ed80be72ab36e748833618daba"
-MAINTAINER="Chess Griffin"
-EMAIL="chess@chessgriffin.com"
-APPROVED="rworkman"
diff --git a/desktop/pypanel/slack-desc b/desktop/pypanel/slack-desc
deleted file mode 100644
index 8ef6358798..0000000000
--- a/desktop/pypanel/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pypanel: pypanel (A panel/taskbar for X11 window managers)
-pypanel:
-pypanel: PyPanel is a lightweight panel/taskbar written in Python and C for
-pypanel: X11 window managers. It can be easily customized to match any
-pypanel: desktop theme or taste. It works with WindowMaker and EWMH-compliant
-pypanel: WMs (Kahakai, Openbox, FVWM, PekWM, etc).
-pypanel:
-pypanel: Homepage: http://pypanel.sourceforge.net
-pypanel:
-pypanel:
-pypanel: