summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Tonus <tonus1@gmail.com>2020-12-26 15:25:27 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-12-26 15:25:27 +0700
commit3a59ef022d48a4992a40cc788e008bd9b627193a (patch)
tree347dab06ce9ea9468c07aa406311711ad23fd62e /desktop
parent440d68e5adec2f96e5e4193a2408346605cf0244 (diff)
downloadslackbuilds-3a59ef022d48a4992a40cc788e008bd9b627193a.tar.gz
slackbuilds-3a59ef022d48a4992a40cc788e008bd9b627193a.tar.xz
desktop/bumblebee-status: Added (status line generator).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/bumblebee-status/README20
-rw-r--r--desktop/bumblebee-status/bumblebee-status.SlackBuild80
-rw-r--r--desktop/bumblebee-status/bumblebee-status.info11
-rw-r--r--desktop/bumblebee-status/commit_7b1659a1b594cc49f8207a2858b499086cda27a8.patch10
-rw-r--r--desktop/bumblebee-status/slack-desc19
5 files changed, 140 insertions, 0 deletions
diff --git a/desktop/bumblebee-status/README b/desktop/bumblebee-status/README
new file mode 100644
index 0000000000..2b6483e3b2
--- /dev/null
+++ b/desktop/bumblebee-status/README
@@ -0,0 +1,20 @@
+bumblebee-status - a modular, theme-able status line generator for the i3 window manager.
+
+Focus is on:
+
+ease of use, sane defaults (no mandatory configuration file)
+easy creation of custom themes
+easy creation of custom modules
+
+Required i3wm version: 4.12+ (in earlier versions, blocks won't have background colors)
+
+Supported Python versions: 3.4, 3.5, 3.6, 3.7, 3.8, 3.9
+
+Supported FontAwesome version: 4 (free version of 5 doesn't include some of the icons)
+
+Available modules lists the dependencies (Python modules and external executables) for each module.
+If you are not using a module, you don't need the dependencies.
+
+To get a list, do :
+$ bumblebee-status -l themes
+$ bumblebee-status -l modules
diff --git a/desktop/bumblebee-status/bumblebee-status.SlackBuild b/desktop/bumblebee-status/bumblebee-status.SlackBuild
new file mode 100644
index 0000000000..d629fc7ee2
--- /dev/null
+++ b/desktop/bumblebee-status/bumblebee-status.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# Slackware build script for bumblebee-status
+
+# Copyright 2020 Tonus, France
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=bumblebee-status
+VERSION=${VERSION:-2.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) export ARCH=i586 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-02 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-02 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-02"
+ LIBDIRSUFFIX=""
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-${PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+patch -p0 < $CWD/commit_7b1659a1b594cc49f8207a2858b499086cda27a8.patch
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE *.md docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/bumblebee-status/bumblebee-status.info b/desktop/bumblebee-status/bumblebee-status.info
new file mode 100644
index 0000000000..52b4308a2b
--- /dev/null
+++ b/desktop/bumblebee-status/bumblebee-status.info
@@ -0,0 +1,11 @@
+PRGNAM="bumblebee-status"
+VERSION="2.1.1"
+HOMEPAGE="https://github.com/tobi-wan-kenobi/bumblebee-status/"
+DOWNLOAD="https://github.com/tobi-wan-kenobi/bumblebee-status/archive/v2.1.1/bumblebee-status-2.1.1.tar.gz"
+MD5SUM="afe2f15135f6b5f44cd3ab99eebd6c21"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="i3 python3"
+MAINTAINER="Tonus"
+EMAIL="tonus1@gmail.com"
+
diff --git a/desktop/bumblebee-status/commit_7b1659a1b594cc49f8207a2858b499086cda27a8.patch b/desktop/bumblebee-status/commit_7b1659a1b594cc49f8207a2858b499086cda27a8.patch
new file mode 100644
index 0000000000..579c7a03fe
--- /dev/null
+++ b/desktop/bumblebee-status/commit_7b1659a1b594cc49f8207a2858b499086cda27a8.patch
@@ -0,0 +1,10 @@
+--- bumblebee-status-2.1.1/bumblebee_status/core/theme.py 2020-12-07 10:00:20.000000000 +0100
++++ bumblebee-status-2.1.1/bumblebee_status/core/theme.py.patched 2020-12-20 21:12:27.216695638 +0100
+@@ -17,6 +17,7 @@
+ os.path.join(THEME_BASE_DIR, "../../themes"),
+ os.path.expanduser("~/.config/bumblebee-status/themes"),
+ os.path.expanduser("~/.local/share/bumblebee-status/themes"), # PIP
++ "/usr/share/bumblebee-status/themes",
+ ]
+
+
diff --git a/desktop/bumblebee-status/slack-desc b/desktop/bumblebee-status/slack-desc
new file mode 100644
index 0000000000..1f08f88138
--- /dev/null
+++ b/desktop/bumblebee-status/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bumblebee-status: bumblebee-status (status line generator)
+bumblebee-status:
+bumblebee-status: bumblebee-status is a modular, theme-able status line generator
+bumblebee-status:
+bumblebee-status: for the i3 window manager
+bumblebee-status:
+bumblebee-status:
+bumblebee-status:
+bumblebee-status:
+bumblebee-status:
+bumblebee-status: