summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author K. Eugene Carlson <kvngncrlsn@gmail.com>2022-04-03 00:26:41 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-09 15:45:40 +0700
commit4ac6d2d616539a61d8316da7d1071604442911a4 (patch)
tree9984fb6950d5ed3c5da397fe9b610a198b17a637 /desktop
parent484671ab2e6490018e827c9b885dc155c0bdf37f (diff)
downloadslackbuilds-4ac6d2d616539a61d8316da7d1071604442911a4.tar.gz
slackbuilds-4ac6d2d616539a61d8316da7d1071604442911a4.tar.xz
desktop/xss-lock: fix cmake policy obsoloscence warning
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/xss-lock/policy.diff19
-rw-r--r--desktop/xss-lock/xss-lock.SlackBuild5
2 files changed, 23 insertions, 1 deletions
diff --git a/desktop/xss-lock/policy.diff b/desktop/xss-lock/policy.diff
new file mode 100644
index 0000000000..0af3144eb4
--- /dev/null
+++ b/desktop/xss-lock/policy.diff
@@ -0,0 +1,19 @@
+--- xss-lock-0.3.0/CMakeLists.txt 2013-11-05 02:10:10.000000000 +0900
++++ xss-lock-0.3.0/CMakeLists.txt.new 2021-04-08 08:03:28.349195750 +0900
+@@ -1,4 +1,4 @@
+-cmake_minimum_required(VERSION 2.8)
++cmake_minimum_required(VERSION 2.8.12)
+ project(xss-lock C)
+ set(PROJECT_VERSION 0.3.0)
+
+--- xss-lock-0.3.0/src/CMakeLists.txt 2013-11-05 02:10:10.000000000 +0900
++++ xss-lock-0.3.0/src/CMakeLists.txt.new 2021-04-08 08:25:15.923235654 +0900
+@@ -17,7 +17,7 @@
+ xss-lock.c
+ xcb_utils.c
+ xcb_utils.h
+- config.h
++ config.h.in
+ )
+
+ target_link_libraries(xss-lock ${GLIB2_LIBRARIES} ${XCB_LIBRARIES})
diff --git a/desktop/xss-lock/xss-lock.SlackBuild b/desktop/xss-lock/xss-lock.SlackBuild
index 2bd76d2740..c38a6a19fb 100644
--- a/desktop/xss-lock/xss-lock.SlackBuild
+++ b/desktop/xss-lock/xss-lock.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for xss-lock
-# Copyright 2021 K. Eugene Carlson Tsukuba, Japan
+# Copyright 2021-2022 K. Eugene Carlson Tsukuba, Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -76,6 +76,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Prevent obsolesence/policy cmake warnings
+patch -p1 < $CWD/policy.diff
+
mkdir -p build
cd build
cmake \