summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2021-04-21 20:18:24 -0500
committer Robby Workman <rworkman@slackbuilds.org>2021-04-21 20:18:24 -0500
commit7e4cc1817361d7d0ec35e03eda021d956dbc03a9 (patch)
tree3b7fe80a33158d43484fec1f2936872fb04fb841 /desktop
parente5e45af2f74b892fce703017f63d7da17695bb26 (diff)
downloadslackbuilds-7e4cc1817361d7d0ec35e03eda021d956dbc03a9.tar.gz
slackbuilds-7e4cc1817361d7d0ec35e03eda021d956dbc03a9.tar.xz
desktop/awesome-extra: Removed (no maintainer)
Diffstat (limited to 'desktop')
-rw-r--r--desktop/awesome-extra/README20
-rw-r--r--desktop/awesome-extra/awesome-extra.SlackBuild84
-rw-r--r--desktop/awesome-extra/awesome-extra.info10
-rw-r--r--desktop/awesome-extra/slack-desc19
4 files changed, 0 insertions, 133 deletions
diff --git a/desktop/awesome-extra/README b/desktop/awesome-extra/README
deleted file mode 100644
index 244916fd46..0000000000
--- a/desktop/awesome-extra/README
+++ /dev/null
@@ -1,20 +0,0 @@
-awesome-extra (modules for the awesome window manager)
-
-awesome-extra is additional modules for the awesome window manager.
-
-awesome is a highly configurable, next generation framework window
-manager for X. It is very fast, extensible and licensed under the
-GNU GPLv2 license.
-
-This package provide:
-
- * wicked, a widget manager which can fill them with various system
- information (CPU or memory usage, network bandwidth, etc);
- * shifty, an extension implementing dynamic tagging;
- * obvious, a set of several widgets (WiFi link quality, battery
- usage, etc), superseding wicked;
- * vicious, a widget manager;
- * revelation, expose like functionality;
- * bashets, use your shell scripts as content providers for widgets;
- * flaw, object oriented library providing a thin abstraction layer
- above awesome widgets.
diff --git a/desktop/awesome-extra/awesome-extra.SlackBuild b/desktop/awesome-extra/awesome-extra.SlackBuild
deleted file mode 100644
index 7ba8d19617..0000000000
--- a/desktop/awesome-extra/awesome-extra.SlackBuild
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for awesome-extra.
-#
-# Copyright 2015-2020 Edinaldo P. Silva, Rio de Janeiro, Brazil.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=awesome-extra
-VERSION=${VERSION:-2019021001}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-ARCH=noarch
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_${VERSION}.tar.xz
-mv $PRGNAM $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-EXTRAS="bashets cyclefocus flaw freedesktop obvious revelation tyrannical vicious"
-
-mkdir -p $PKG/usr/share/awesome/lib
-cp -r $EXTRAS $PKG/usr/share/awesome/lib/
-
-mkdir -p $PKG/usr/man/man7
-cp flaw/flaw.7 $PKG/usr/man/man7/flaw.7
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-DOCS="debian/changelog debian/copyright"
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/share/awesome/lib/cyclefocus/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-cyclefocus
-mv $PKG/usr/share/awesome/lib/tyrannical/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-tyrannical
-mv $PKG/usr/share/awesome/lib/vicious/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-vicious
-mv $PKG/usr/share/awesome/lib/vicious/contrib/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-vicious-contrib
-mv $PKG/usr/share/awesome/lib/flaw/README $PKG/usr/doc/$PRGNAM-$VERSION/README-flaw
-mv $PKG/usr/share/awesome/lib/obvious/README $PKG/usr/doc/$PRGNAM-$VERSION/README-obvious
-mv $PKG/usr/share/awesome/lib/revelation/README.md $PKG/usr/doc/$PRGNAM-$VERSION/README-revelation
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/awesome-extra/awesome-extra.info b/desktop/awesome-extra/awesome-extra.info
deleted file mode 100644
index c8437cb4b8..0000000000
--- a/desktop/awesome-extra/awesome-extra.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="awesome-extra"
-VERSION="2019021001"
-HOMEPAGE="http://http.debian.net/debian/pool/main/a/awesome-extra/"
-DOWNLOAD="http://cdn-fastly.deb.debian.org/debian/pool/main/a/awesome-extra/awesome-extra_2019021001.tar.xz"
-MD5SUM="6c8339c809c98aadfdc55d486c47014f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="awesome"
-MAINTAINER="orphaned - no maintainer"
-EMAIL="nobody@nowhere"
diff --git a/desktop/awesome-extra/slack-desc b/desktop/awesome-extra/slack-desc
deleted file mode 100644
index 85d759483e..0000000000
--- a/desktop/awesome-extra/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-awesome-extra: awesome-extra (modules for the awesome window manager)
-awesome-extra:
-awesome-extra: awesome-extra is additional modules for the awesome window manager.
-awesome-extra:
-awesome-extra: awesome is a highly configurable, next generation framework window
-awesome-extra: manager for X. It is very fast, extensible and licensed under the
-awesome-extra: GNU GPLv2 license.
-awesome-extra:
-awesome-extra:
-awesome-extra:
-awesome-extra: