summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:06:35 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:06:35 +0200
commita8f5232de6ef51a2383c8c0ec23d1bc3f5119e14 (patch)
tree258a8cf8e0895abf3373d2a9d5bbea9b92a7dbdf /desktop
parentf64bfe7ba3a6679c8540f53a5040f0460bd981b4 (diff)
downloadslackbuilds-a8f5232de6ef51a2383c8c0ec23d1bc3f5119e14.tar.gz
slackbuilds-a8f5232de6ef51a2383c8c0ec23d1bc3f5119e14.tar.xz
desktop/simple-ccsm: Removed from 13.0 repository
Diffstat (limited to 'desktop')
-rw-r--r--desktop/simple-ccsm/README20
-rw-r--r--desktop/simple-ccsm/simple-ccsm.SlackBuild82
-rw-r--r--desktop/simple-ccsm/simple-ccsm.info8
-rw-r--r--desktop/simple-ccsm/slack-desc19
4 files changed, 0 insertions, 129 deletions
diff --git a/desktop/simple-ccsm/README b/desktop/simple-ccsm/README
deleted file mode 100644
index eaa3369af8..0000000000
--- a/desktop/simple-ccsm/README
+++ /dev/null
@@ -1,20 +0,0 @@
-CCSM, short for CompizConfig Settings Manager, is a configuration tool for
-Compiz Fusion. It is used to configure the many plugins included in Compiz and
-Compiz Fusion, as well as the use of various profiles and intergrating better
-with existing desktop settings. CCSM uses the CompizConfig compiz configuration
-system.
-
-Suggested build order:
- 1. compiz-bcop
- 2. libcompizconfig
- 3. compizconfig-backend-kconfig (optional)
- 4. compizconfig-backend-gconf (optional)
- 5. compizconfig-python
- 6. ccsm
- 7. simple-ccsm (optional)
- 8. compiz-fusion-plugins-main
- 9. compiz-fusion-plugins-extra (optional)
-10. compiz-fusion-plugins-unsupported (optional)
-11. emerald (optional)
-12. emerald-themes (optional)
-13. fusion-icon (optional)
diff --git a/desktop/simple-ccsm/simple-ccsm.SlackBuild b/desktop/simple-ccsm/simple-ccsm.SlackBuild
deleted file mode 100644
index ae2d35363b..0000000000
--- a/desktop/simple-ccsm/simple-ccsm.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for simple-ccsm
-
-# Copyright 2008 David Somero <dsomero@hotmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=simple-ccsm
-VERSION=0.7.8
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --prefix=/usr --root=$PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-if [ -d $PKG/usr/man ]; then
- ( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
- )
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING* ChangeLog INSTALL NEWS README* TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/desktop/simple-ccsm/simple-ccsm.info b/desktop/simple-ccsm/simple-ccsm.info
deleted file mode 100644
index 5ff45b10f4..0000000000
--- a/desktop/simple-ccsm/simple-ccsm.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="simple-ccsm"
-VERSION="0.7.8"
-HOMEPAGE="http://compiz-fusion.org/"
-DOWNLOAD="http://releases.compiz-fusion.org/0.7.8/simple-ccsm-0.7.8.tar.gz"
-MD5SUM="688a7f78da7734662c4f4860a96a6058"
-MAINTAINER="David Somero"
-EMAIL="dsomero@hotmail.com"
-APPROVED="rworkman"
diff --git a/desktop/simple-ccsm/slack-desc b/desktop/simple-ccsm/slack-desc
deleted file mode 100644
index c780a0a87d..0000000000
--- a/desktop/simple-ccsm/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-------------------------------------------------|
-simple-ccsm: simple-ccsm (CompizConfig Settings Manager simple version)
-simple-ccsm:
-simple-ccsm: CCSM, short for CompizConfig Settings Manager, is a configuration
-simple-ccsm: tool for Compiz Fusion. It is used to configure the many plugins
-simple-ccsm: included in Compiz and Compiz Fusion, as well as the use of
-simple-ccsm: various profiles and intergrating better with existing desktop
-simple-ccsm: settings.
-simple-ccsm:
-simple-ccsm: CCSM uses the CompizConfig compiz configuration system.
-simple-ccsm:
-simple-ccsm: