summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:06:30 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:06:30 +0200
commitc85bb080b48ba74bf15d76b70e8ab98081b3b6a7 (patch)
tree83dd74f29de2e0ed9ce34ef42114d5702bb0386e /desktop
parent107809f21f2f451d71ac61a4bbcbe26277e11698 (diff)
downloadslackbuilds-c85bb080b48ba74bf15d76b70e8ab98081b3b6a7.tar.gz
slackbuilds-c85bb080b48ba74bf15d76b70e8ab98081b3b6a7.tar.xz
desktop/fusion-icon: Removed from 13.0 repository
Diffstat (limited to 'desktop')
-rw-r--r--desktop/fusion-icon/README26
-rw-r--r--desktop/fusion-icon/doinst.sh7
-rw-r--r--desktop/fusion-icon/fusion-icon.SlackBuild82
-rw-r--r--desktop/fusion-icon/fusion-icon.info8
-rw-r--r--desktop/fusion-icon/slack-desc19
5 files changed, 0 insertions, 142 deletions
diff --git a/desktop/fusion-icon/README b/desktop/fusion-icon/README
deleted file mode 100644
index 84f59dd892..0000000000
--- a/desktop/fusion-icon/README
+++ /dev/null
@@ -1,26 +0,0 @@
-The Compiz Fusion Icon is a simple panel applet for starting and controlling
-Compiz Fusion. Upon launch, it will attempt to start Compiz Fusion
-automatically. You may need to select a window decorator if one does not
-appear.
-
-In most cases, you can find Compiz Fusion under Applications -> System Tools ->
-Compiz Fusion Icon, or the equivalent in your desktop environment's menu. You
-can also run "fusion-icon &" from a console.
-
-Fusion-icon is only available as a snapshot from git repo at this time, but
-as a convenience, we offer a tarball on our server.
-
-Suggested build order:
- 1. compiz-bcop
- 2. libcompizconfig
- 3. compizconfig-backend-kconfig (optional)
- 4. compizconfig-backend-gconf (optional)
- 5. compizconfig-python
- 6. ccsm
- 7. simple-ccsm (optional)
- 8. compiz-fusion-plugins-main
- 9. compiz-fusion-plugins-extra (optional)
-10. compiz-fusion-plugins-unsupported (optional)
-11. emerald (optional)
-12. emerald-themes (optional)
-13. fusion-icon (optional)
diff --git a/desktop/fusion-icon/doinst.sh b/desktop/fusion-icon/doinst.sh
deleted file mode 100644
index a61bc59590..0000000000
--- a/desktop/fusion-icon/doinst.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f -t usr/share/icons/hicolor >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
-fi
diff --git a/desktop/fusion-icon/fusion-icon.SlackBuild b/desktop/fusion-icon/fusion-icon.SlackBuild
deleted file mode 100644
index e31263dfd6..0000000000
--- a/desktop/fusion-icon/fusion-icon.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for fusion-icon
-
-# Copyright 2008 David Somero <dsomero@hotmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=fusion-icon
-VERSION=0.01
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --prefix=/usr --root=$PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-if [ -d $PKG/usr/man ]; then
- ( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
- )
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING MANIFEST VERSION $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/desktop/fusion-icon/fusion-icon.info b/desktop/fusion-icon/fusion-icon.info
deleted file mode 100644
index 8a05dc9812..0000000000
--- a/desktop/fusion-icon/fusion-icon.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="fusion-icon"
-VERSION="0.01"
-HOMEPAGE="http://wiki.compiz-fusion.org/CompizFusionIcon"
-DOWNLOAD="http://slackbuilds.org/sources/12.2/fusion-icon-0.01.tar.gz"
-MD5SUM="a8a4d96b4e495869f6dbd5bbff75d16d"
-MAINTAINER="David Somero"
-EMAIL="dsomero@hotmail.com"
-APPROVED="rworkman"
diff --git a/desktop/fusion-icon/slack-desc b/desktop/fusion-icon/slack-desc
deleted file mode 100644
index ca8b6c1d6b..0000000000
--- a/desktop/fusion-icon/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler-------------------------------------------------|
-fusion-icon: fusion-icon (fusion icon system tray tool)
-fusion-icon:
-fusion-icon: fusion icon is a system tray tool to manage compiz fusion
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon:
-fusion-icon: