summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2011-06-12 14:54:04 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-06-13 01:34:35 -0400
commiteacec2d795f190bc10f3f664295bdef75225809e (patch)
tree701fd53303a52455d56922cc8483336508235da3 /desktop
parent01ea0f920a8c83f26ff5fd9be01520457309a69b (diff)
downloadslackbuilds-eacec2d795f190bc10f3f664295bdef75225809e.tar.gz
slackbuilds-eacec2d795f190bc10f3f664295bdef75225809e.tar.xz
desktop/fusion-icon: Added (A system tray tool for Compiz Fusion)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/fusion-icon/README18
-rw-r--r--desktop/fusion-icon/README.POST_INSTALL10
-rw-r--r--desktop/fusion-icon/doinst.sh7
-rw-r--r--desktop/fusion-icon/fusion-icon.SlackBuild69
-rw-r--r--desktop/fusion-icon/fusion-icon.info10
-rw-r--r--desktop/fusion-icon/slack-desc19
6 files changed, 133 insertions, 0 deletions
diff --git a/desktop/fusion-icon/README b/desktop/fusion-icon/README
new file mode 100644
index 0000000000..e0b8a06a31
--- /dev/null
+++ b/desktop/fusion-icon/README
@@ -0,0 +1,18 @@
+Fusion Icon is a simple system tray applet for starting and controlling
+Compiz Fusion. Upon launch, it will attempt to start Compiz Fusion
+automatically. You may need to select a window decorator if one does not
+appear.
+
+For correct installation, build in this order:
+ 1. compiz-bcop
+ 2. protobuf (optional but recommended)
+ 3. libcompizconfig
+ 4. compizconfig-python
+ 5. compizconfig-backend-kconfig4 (optional)
+ 6. ccsm
+ 7. compiz-plugins-main
+ 8. compiz-plugins-extra (optional)
+ 9. compiz-plugins-unsupported (optional)
+10. emerald (optional)
+11. emerald-themes (optional)
+12. fusion-icon (optional)
diff --git a/desktop/fusion-icon/README.POST_INSTALL b/desktop/fusion-icon/README.POST_INSTALL
new file mode 100644
index 0000000000..3c8f207a68
--- /dev/null
+++ b/desktop/fusion-icon/README.POST_INSTALL
@@ -0,0 +1,10 @@
+After you've installed the compiz-fusion packages you need to enable
+a few key features before you launch compiz.
+Launch "ccsm" and enable the following options:
+
+ * Window Decorations
+ * Move Window
+ * Rezise Window
+
+These options will allow you to manage your windows.
+After enabled, you can launch compiz and customize to your liking.
diff --git a/desktop/fusion-icon/doinst.sh b/desktop/fusion-icon/doinst.sh
new file mode 100644
index 0000000000..a61bc59590
--- /dev/null
+++ b/desktop/fusion-icon/doinst.sh
@@ -0,0 +1,7 @@
+if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f -t usr/share/icons/hicolor >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/fusion-icon/fusion-icon.SlackBuild b/desktop/fusion-icon/fusion-icon.SlackBuild
new file mode 100644
index 0000000000..78bcecdb57
--- /dev/null
+++ b/desktop/fusion-icon/fusion-icon.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for fusion-icon
+
+# Written by M.Dinslage (daedra1980@gmail.com)
+
+PRGNAM=fusion-icon
+VERSION=${VERSION:-20100612}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ SLKLDFLAGS="-L/usr/lib64"; LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ SLKLDFLAGS=""; LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM.tar.gz
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --prefix=/usr --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING VERSION \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/fusion-icon/fusion-icon.info b/desktop/fusion-icon/fusion-icon.info
new file mode 100644
index 0000000000..d74e248e6d
--- /dev/null
+++ b/desktop/fusion-icon/fusion-icon.info
@@ -0,0 +1,10 @@
+PRGNAM="fusion-icon"
+VERSION="20100612"
+HOMEPAGE="http://www.compiz.org"
+DOWNLOAD="http://www.mostlyslack.com/slackstuff/sources/fusion-icon.tar.gz"
+MD5SUM="df69969a8e55627ea1ccebc63ec64f95"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="M.Dinslage"
+EMAIL="daedra1980@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/desktop/fusion-icon/slack-desc b/desktop/fusion-icon/slack-desc
new file mode 100644
index 0000000000..77d12320ee
--- /dev/null
+++ b/desktop/fusion-icon/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fusion-icon: fusion-icon (A system tray tool for Compiz Fusion)
+fusion-icon:
+fusion-icon: Fusion Icon is a system tray tool to manage Compiz Fusion.
+fusion-icon:
+fusion-icon:
+fusion-icon:
+fusion-icon:
+fusion-icon:
+fusion-icon:
+fusion-icon:
+fusion-icon: