summaryrefslogtreecommitdiffstats
path: root/development/PyOpenGL
diff options
context:
space:
mode:
author hollywoodb <hollywoodb@fastmail.fm>2010-05-11 19:44:11 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 19:44:11 +0200
commit0746f5ee03bcb033e731c9e1956e51ac368f7b4f (patch)
tree808fa7a37a25dd86fffd4c0b762427641f8fc703 /development/PyOpenGL
parent4a2754743bd5f6e5f5899cbf4953dcf5f33b0c4b (diff)
downloadslackbuilds-0746f5ee03bcb033e731c9e1956e51ac368f7b4f.tar.gz
slackbuilds-0746f5ee03bcb033e731c9e1956e51ac368f7b4f.tar.xz
development/PyOpenGL: Updated for version 3.0.0a5
Diffstat (limited to 'development/PyOpenGL')
-rw-r--r--development/PyOpenGL/PyOpenGL.SlackBuild15
-rw-r--r--development/PyOpenGL/PyOpenGL.info2
-rw-r--r--development/PyOpenGL/README3
-rw-r--r--development/PyOpenGL/slack-desc14
4 files changed, 19 insertions, 15 deletions
diff --git a/development/PyOpenGL/PyOpenGL.SlackBuild b/development/PyOpenGL/PyOpenGL.SlackBuild
index 88f4c88fa5..b44e39bf77 100644
--- a/development/PyOpenGL/PyOpenGL.SlackBuild
+++ b/development/PyOpenGL/PyOpenGL.SlackBuild
@@ -7,19 +7,14 @@
## so that I don't recieve emails about a script I
## did not write. Thanks.
-# Modified slightly by the SlackBuilds.org project
-
-if [ "$(id -u)" != "0" ]; then
- echo "This script must be run as root!"
- exit
-fi
+# Modified by the SlackBuilds.org project
NAME=PyOpenGL
VERSION=3.0.0a5
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=${PKG:-$TMP/package-$NAME}
OUTPUT=${OUTPUT:-/tmp}
@@ -36,8 +31,10 @@ chmod -R u+w,go+r-w,a-s .
python setup.py bdist || exit 1
tar -C $PKG -zxvf $TMP/$NAME-$VERSION/dist/$NAME-$VERSION.linux-i686.tar.gz
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
mkdir -p $PKG/usr/doc/$NAME-$VERSION
install -m 0644 PKG-INFO documentation/{development,using}.html \
diff --git a/development/PyOpenGL/PyOpenGL.info b/development/PyOpenGL/PyOpenGL.info
index 2fdb74ffc6..fdb91f9939 100644
--- a/development/PyOpenGL/PyOpenGL.info
+++ b/development/PyOpenGL/PyOpenGL.info
@@ -5,4 +5,4 @@ DOWNLOAD="http://dl.sourceforge.net/pyopengl/PyOpenGL-3.0.0a5.tar.gz"
MD5SUM="943c4d7d3d1d97cc7592e61d28918fd2"
MAINTAINER="hollywoodb"
EMAIL="hollywoodb@fastmail.fm"
-APPROVED="robw810"
+APPROVED="rworkman"
diff --git a/development/PyOpenGL/README b/development/PyOpenGL/README
index fefb631013..cd3fdd2a74 100644
--- a/development/PyOpenGL/README
+++ b/development/PyOpenGL/README
@@ -9,5 +9,4 @@ extensions (where supported in the underlying implementation).
PyOpenGL is interoperable with a large number of external GUI libraries
for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
-Requirements: >=pysetuptool-0.6 (setuptools) -- build requirement only
-
+Requirements: pysetuptools (setuptools) -- build requirement only
diff --git a/development/PyOpenGL/slack-desc b/development/PyOpenGL/slack-desc
index 713b1c4ebf..2761fff9c7 100644
--- a/development/PyOpenGL/slack-desc
+++ b/development/PyOpenGL/slack-desc
@@ -1,11 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
PyOpenGL: PyOpenGL (cross-platform Python<->OpenGL bindings)
PyOpenGL:
PyOpenGL: PyOpenGL is the cross platform Python binding to OpenGL and related
-PyOpenGL: APIs. The binding is created using the SWIG wrapper generator, and is
+PyOpenGL: APIs. The binding is created using the SWIG wrapper generator, and is
PyOpenGL: provided under an extremely liberal BSD-style Open-Source license.
PyOpenGL: PyOpenGL includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3,
PyOpenGL: WGL 4, and Togl (Tk OpenGL widget) 1.6. It also includes support for
-PyOpenGL: dozens of extensions (where supported in the underlying implementation).
-PyOpenGL:
+PyOpenGL: dozens of extensions (where supported in the underlying implementa-
+PyOpenGL: tion).
PyOpenGL:
PyOpenGL: