summaryrefslogtreecommitdiffstats
path: root/development/chameleon
diff options
context:
space:
mode:
author William PC <w_calandrini[at]hotmail[dot]com>2022-10-22 16:03:04 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-29 10:28:33 +0700
commit9fca7fe86499f1edea9a49b7582be88b7eb7ae03 (patch)
tree0d3200cc8b876987cbfe1227a59274c2ecb7bdd4 /development/chameleon
parent7c937029e44be6d49af35f6554b817051a5e0b1b (diff)
downloadslackbuilds-9fca7fe86499f1edea9a49b7582be88b7eb7ae03.tar.gz
slackbuilds-9fca7fe86499f1edea9a49b7582be88b7eb7ae03.tar.xz
development/chameleon: Added (solve dense linear equations)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/chameleon')
-rw-r--r--development/chameleon/README23
-rw-r--r--development/chameleon/chameleon.SlackBuild158
-rw-r--r--development/chameleon/chameleon.info10
-rw-r--r--development/chameleon/slack-desc19
4 files changed, 210 insertions, 0 deletions
diff --git a/development/chameleon/README b/development/chameleon/README
new file mode 100644
index 0000000000..848e7b26ed
--- /dev/null
+++ b/development/chameleon/README
@@ -0,0 +1,23 @@
+ Chameleon is a framework written in C which provides routines to
+solve dense general systems of linear equations, symmetric positive
+definite systems of linear equations and linear least squares
+problems, using LU, Cholesky, QR and LQ factorizations. Real
+arithmetic and complex arithmetic are supported in both single
+precision and double precision.
+
+ Chameleon is based on the PLASMA source code but is not limited
+to shared-memory environment and can exploit multiple GPUs.
+Chameleon is interfaced in a generic way with StarPU, PaRSEC,
+QUARK, OpenMP runtime systems. This feature allows to analyze in
+a unified framework how sequential task-based algorithms behave
+regarding different runtime systems implementations. Using Chameleon
+with StarPU or PaRSEC runtime systems allows to exploit GPUs through
+kernels provided by cuBLAS and clusters of interconnected nodes with
+distributed memory (using MPI).
+
+
+The default scheduler is set to OpenMP, if you want to use the StarPU
+you should set the environment variable STARPU=yes and install StarPU.
+
+For enabling MPI set the environment variable MPI=yes, this require
+a MPI implementation (openmpi or mpich).
diff --git a/development/chameleon/chameleon.SlackBuild b/development/chameleon/chameleon.SlackBuild
new file mode 100644
index 0000000000..83d7aa314a
--- /dev/null
+++ b/development/chameleon/chameleon.SlackBuild
@@ -0,0 +1,158 @@
+#!/bin/bash
+
+# Slackware build script for chameleon
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=chameleon
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+if [ "${STARPU:-no}" == "yes" ]; then
+ OPT_BUILD="-DCHAMELEON_SCHED=STARPU"
+else
+ OPT_BUILD="-DCHAMELEON_SCHED=OPENMP"
+fi
+
+if [ "${MPI:-no}" == "yes" ]; then
+ OPT_BUILD="$OPT_BUILD -DCHAMELEON_USE_MPI=ON"
+fi
+
+###########
+# runtime fixes
+###########
+
+# fix for the pkgconfig files and "hqr_env.sh" to use
+# the right library path
+sed -i 's#/lib#/lib'${LIBDIRSUFFIX}'#' \
+ lib/pkgconfig/{chameleon,coreblas,cudablas}.pc.in \
+ hqr/lib/pkgconfig/hqr.pc.in hqr/hqr_env.sh.in
+
+###########
+# installation fixes
+###########
+
+# fix the installation of some files that was
+# been installed to /usr/bin
+sed -i 's# bin # share/libexec/chameleon #' hqr/testings/CMakeLists.txt
+sed -i 's# DESTINATION bin/chameleon# DESTINATION share/chameleon/examples#' example/lapack_to_chameleon/CMakeLists.txt
+sed -i 's# DESTINATION bin# DESTINATION share/libexec/chameleon#' hqr/cmake_modules/GenHQRPkgConfig.cmake
+
+# fix lib installation path
+sed -i 's#DESTINATION lib#&'${LIBDIRSUFFIX}'#' \
+ runtime/{openmp,starpu,parsec,quark}/CMakeLists.txt \
+ compute/CMakeLists.txt \
+ {coreblas,cudablas}/compute/CMakeLists.txt \
+ hqr/src/CMakeLists.txt
+
+# fix installation of pkgfiles to lib${LIBDIRSUFFIX}
+sed -i 's#DESTINATION lib#&'${LIBDIRSUFFIX}'#' \
+ cmake_modules/GenPkgConfig.cmake \
+ hqr/cmake_modules/GenHQRPkgConfig.cmake
+
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
+ -DBIN_INSTALL_DIR=libexec/$PRGNAM \
+ -DBUILD_SHARED_LIBS=ON \
+ $OPT_BUILD \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CONTRIBUTING.org LICENCE.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/chameleon/chameleon.info b/development/chameleon/chameleon.info
new file mode 100644
index 0000000000..0de2eb2a36
--- /dev/null
+++ b/development/chameleon/chameleon.info
@@ -0,0 +1,10 @@
+PRGNAM="chameleon"
+VERSION="1.1.0"
+HOMEPAGE="https://solverstack.gitlabpages.inria.fr/chameleon"
+DOWNLOAD="https://gitlab.inria.fr/solverstack/chameleon/uploads/b299d6037d7636c6be16108c89bc2aab/chameleon-1.1.0.tar.gz"
+MD5SUM="a67a7f472d0e537cb984813e28a933f7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="blas cblas lapack lapacke"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/development/chameleon/slack-desc b/development/chameleon/slack-desc
new file mode 100644
index 0000000000..5a93891f49
--- /dev/null
+++ b/development/chameleon/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+chameleon: chameleon (framework for solving dense linear equations)
+chameleon:
+chameleon:
+chameleon: Chameleon is a framework written in C which provides routines to
+chameleon: solve dense general systems of linear equations, symmetric positive
+chameleon: definite systems of linear equations and linear least squares
+chameleon: problems, using LU, Cholesky, QR and LQ factorizations. Real
+chameleon: arithmetic and complex arithmetic are supported in both single
+chameleon: precision and double precision.
+chameleon:
+chameleon: