summaryrefslogtreecommitdiffstats
path: root/development/conan
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-01 19:59:32 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-01 19:59:32 +0700
commit074855f9e7b66ab815827c433f4e3a28b550aa24 (patch)
tree7c690ea7264f8c81c63247871ae773edd6d9550a /development/conan
parent6e9299b9bd63428c4376776adf4853a5394cd605 (diff)
downloadslackbuilds-074855f9e7b66ab815827c433f4e3a28b550aa24.tar.gz
slackbuilds-074855f9e7b66ab815827c433f4e3a28b550aa24.tar.xz
development/conan: Removed (Due to boto removal).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/conan')
-rw-r--r--development/conan/README6
-rw-r--r--development/conan/conan.SlackBuild84
-rw-r--r--development/conan/conan.info10
-rw-r--r--development/conan/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/development/conan/README b/development/conan/README
deleted file mode 100644
index ddcd2704d4..0000000000
--- a/development/conan/README
+++ /dev/null
@@ -1,6 +0,0 @@
-A distributed, open source, package manager.
-
-Conan is a portable package manager, intended for C and C++ developers,
-but it is able to manage builds from source, dependencies, and
-precompiled binaries for any language.
-
diff --git a/development/conan/conan.SlackBuild b/development/conan/conan.SlackBuild
deleted file mode 100644
index d072df5150..0000000000
--- a/development/conan/conan.SlackBuild
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for conan
-
-# Copyright 2016 Andre Barboza, Belo Horizonte - Brazil
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=conan
-VERSION=${VERSION:-0.21.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/conan/conan.info b/development/conan/conan.info
deleted file mode 100644
index c0b83c9b01..0000000000
--- a/development/conan/conan.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="conan"
-VERSION="0.21.1"
-HOMEPAGE="https://conan.io/"
-DOWNLOAD="https://github.com/conan-io/conan/archive/0.21.1/conan-0.21.1.tar.gz"
-MD5SUM="70093441ca250ff825bc4fd8e4661046"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="boto python2-passlib colorama cfgparse pyjwt python2-patch fasteners bottle node-semver pluginbase"
-MAINTAINER="Andre Barboza"
-EMAIL="bmg.andre@gmail.com"
diff --git a/development/conan/slack-desc b/development/conan/slack-desc
deleted file mode 100644
index c7b9f39299..0000000000
--- a/development/conan/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-conan: conan (A distributed, open source, package manager)
-conan:
-conan: Conan is a portable package manager, intended for C and C++
-conan: developers, but it is able to manage builds from source,
-conan: dependencies, and precompiled binaries for any language.
-conan:
-conan:
-conan:
-conan:
-conan: https://conan.io/
-conan: