summaryrefslogtreecommitdiffstats
path: root/development/django
diff options
context:
space:
mode:
author Daniel de Kok <danieldk@pobox.com>2010-05-11 14:05:51 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 14:05:51 +0200
commitef4b7d281739882893d1b4092445fdc6da0dc258 (patch)
treecd48cd8ca76e2560423bf80388d615e43cc4c8ea /development/django
parent5105316945172c07e54c8c606eda57da9563ec97 (diff)
downloadslackbuilds-ef4b7d281739882893d1b4092445fdc6da0dc258.tar.gz
slackbuilds-ef4b7d281739882893d1b4092445fdc6da0dc258.tar.xz
development/django: Initial import
Diffstat (limited to 'development/django')
-rw-r--r--development/django/README14
-rw-r--r--development/django/django.SlackBuild67
-rw-r--r--development/django/django.info8
-rw-r--r--development/django/slack-desc11
4 files changed, 100 insertions, 0 deletions
diff --git a/development/django/README b/development/django/README
new file mode 100644
index 0000000000..87c1ab1209
--- /dev/null
+++ b/development/django/README
@@ -0,0 +1,14 @@
+Django is a high-level Python web framework that encourages rapid
+development and clean, pragmatic design. It includes a template
+engine, and an object-relational mapper.
+
+This SlackBuild requires the pysetuptools package to compile; a
+SlackBuild for this package is available from SlackBuilds.org.
+
+Although Django can be used without database functionality, it is
+especially useful with database support. Various databases are
+supported through Python database bindings. For example, sqlite3
+databases are supported when the pysqlite2 package is installed.
+Due to the dynamic nature of Python software, database bindings
+are not required when Django is built and can be installed later.
+
diff --git a/development/django/django.SlackBuild b/development/django/django.SlackBuild
new file mode 100644
index 0000000000..d02147e5e6
--- /dev/null
+++ b/development/django/django.SlackBuild
@@ -0,0 +1,67 @@
+#!/bin/sh
+
+# Slackware build script for Django
+
+# Copyright (c) 2007 Daniel de Kok <moc.mikciat@leinad>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Exit on most errors
+set -e
+
+PRGNAM=django
+DISTNAM=Django
+VERSION=0.95.1
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xzvf $CWD/$DISTNAM-$VERSION.tar.gz
+cd $DISTNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py bdist
+
+tar -C $PKG -zxvf dist/$DISTNAM-$VERSION.linux-i686.tar.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS INSTALL LICENSE README docs/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/django/django.info b/development/django/django.info
new file mode 100644
index 0000000000..9add45f5a5
--- /dev/null
+++ b/development/django/django.info
@@ -0,0 +1,8 @@
+PRGNAM="django"
+VERSION="0.95.1"
+HOMEPAGE="http://www.djangoproject.com/"
+DOWNLOAD="http://www.djangoproject.com/download/0.95.1/tarball/"
+MD5SUM="07f09d8429916481e09e84fd01e97355"
+MAINTAINER="Daniel de Kok"
+EMAIL="danieldk@pobox.com"
+APPROVED="robw810"
diff --git a/development/django/slack-desc b/development/django/slack-desc
new file mode 100644
index 0000000000..cc40d6e8b9
--- /dev/null
+++ b/development/django/slack-desc
@@ -0,0 +1,11 @@
+django: django (Python web framework)
+django:
+django: Python is a high-level Python web framework that encourages rapid
+django: development and clean, pragmatic design. It includes a template
+django: engine, and an object-relational mapper.
+django:
+django: The django website can be found at:
+django: http://www.djangoproject.com/
+django:
+django:
+django: