summaryrefslogtreecommitdiffstats
path: root/development/docutils
diff options
context:
space:
mode:
author Robby Workman <rw@rlworkman.net>2010-05-11 22:22:26 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-11 22:22:26 +0200
commit44bbdff782a45512047c0854b6b32b7c722aad7f (patch)
treecef2677cfc4c58fb9be46057edff32c894bcccfb /development/docutils
parentd9a74b30336c7252190c295fdb6cf49183b98f1f (diff)
downloadslackbuilds-44bbdff782a45512047c0854b6b32b7c722aad7f.tar.gz
slackbuilds-44bbdff782a45512047c0854b6b32b7c722aad7f.tar.xz
development/docutils: Updated for version 0.5
Diffstat (limited to 'development/docutils')
-rw-r--r--development/docutils/docutils.SlackBuild61
-rw-r--r--development/docutils/docutils.info14
-rw-r--r--development/docutils/slack-desc22
3 files changed, 63 insertions, 34 deletions
diff --git a/development/docutils/docutils.SlackBuild b/development/docutils/docutils.SlackBuild
index 7f488ade24..99ff22ecb0 100644
--- a/development/docutils/docutils.SlackBuild
+++ b/development/docutils/docutils.SlackBuild
@@ -1,39 +1,68 @@
#!/bin/sh
-# Slackware build script for docutils.
+# Slackware build script for docutils
-# Written by Jick Nan (jick.nan@gmail.com)
+# Copyright 2006-2008 Robby Workman Northport, AL, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=docutils
-VERSION=snapshot
+VERSION=0.5
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
-rm -rf $PRGNAM
-tar -xzvf $CWD/$PRGNAM-$VERSION.tgz || exit 1
-cd $PRGNAM || exit 1
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-python setup.py bdist || exit 1
-tar zxvf dist/$PRGNAM-*.linux-i686.tar.gz -C $PKG || exit 1
+python setup.py install --root=$PKG
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG_INFO $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 *.txt $PKG/usr/doc/$PKG_NAME-$VERSION
+cp -a *.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/docutils/docutils.info b/development/docutils/docutils.info
index cc32cece05..7afc3dffe0 100644
--- a/development/docutils/docutils.info
+++ b/development/docutils/docutils.info
@@ -1,8 +1,8 @@
PRGNAM="docutils"
-VERSION="snapshot"
-HOMEPAGE="http://docutils.sourceforge.net/"
-DOWNLOAD="http://docutils.sourceforge.net/docutils-snapshot.tgz"
-MD5SUM="2b93dc97eb14d6ddc77152853fedb85a"
-MAINTAINER="Jick Nan"
-EMAIL="jick.nan@gmail.com"
-APPROVED="rworkman"
+VERSION="0.5"
+HOMEPAGE="http://docutils.sourceforge.net"
+DOWNLOAD="http://downloads.sourceforge.net/docutils/docutils-0.5.tar.gz"
+MD5SUM="dd72dac92fc8e3eb0f48c3effeef80f6"
+MAINTAINER="Robby Workman"
+EMAIL="rw@rlworkman.net"
+APPROVED="David Somero" \ No newline at end of file
diff --git a/development/docutils/slack-desc b/development/docutils/slack-desc
index 9b15ab9d15..28ea4f4e9b 100644
--- a/development/docutils/slack-desc
+++ b/development/docutils/slack-desc
@@ -5,15 +5,15 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
-docutils: Docutils (Python Documentation Utilities)
+ |-----handy-ruler----------------------------------------------------|
+docutils: docutils (Python Document Utilities module)
+docutils:
+docutils: Docutils is an open-source text processing system for processing
+docutils: plaintext documentation into useful formats, such as HTML or LaTeX.
+docutils: It includes reStructuredText, the easy to read, easy to use,
+docutils: what-you-see-is-what-you-get plaintext markup language.
+docutils:
+docutils: Homepage: http://docutils.sourceforge.net/
+docutils:
+docutils:
docutils:
-docutils: Docutils is a modular system for processing documentation into useful
-docutils: formats, such as HTML, XML, and LaTeX. For input Docutils supports
-docutils: reStructuredText, an easy-to-read, what-you-see-is-what-you-get
-docutils: plaintext markup syntax.
-docutils:
-docutils:
-docutils:
-docutils:
-docutils: