summaryrefslogtreecommitdiffstats
path: root/development/gambas3/qt5-ext-5.7.patch
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2017-01-25 09:26:17 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-28 07:38:31 +0700
commit4db471ca5f84f0fa5b7e276dc788974bf319b0e5 (patch)
tree8e7cae89a4bb98685fef819b155def7e09281b3c /development/gambas3/qt5-ext-5.7.patch
parent169eed41b43446e52dba597cf9407a96a84dbe36 (diff)
downloadslackbuilds-4db471ca5f84f0fa5b7e276dc788974bf319b0e5.tar.gz
slackbuilds-4db471ca5f84f0fa5b7e276dc788974bf319b0e5.tar.xz
development/gambas3: fix build against Qt 5.7.1
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'development/gambas3/qt5-ext-5.7.patch')
-rw-r--r--development/gambas3/qt5-ext-5.7.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/development/gambas3/qt5-ext-5.7.patch b/development/gambas3/qt5-ext-5.7.patch
new file mode 100644
index 0000000000..662a3edcd5
--- /dev/null
+++ b/development/gambas3/qt5-ext-5.7.patch
@@ -0,0 +1,41 @@
+Commit [r8061] Maximize History
+
+[GB.QT5.EXT]
+* BUG: The component now should compile correctly with C++11.
+Authored by: gambas 3 days ago
+Browse code at this revision
+Parent: [r8060]
+changed /gambas/trunk/gb.qt5/configure.ac
+changed /gambas/trunk/gb.qt5/src/ext/Makefile.am
+/gambas/trunk/gb.qt5/configure.ac Diff Switch to side-by-side view
+--- a/gambas/trunk/gb.qt5/configure.ac
++++ b/gambas/trunk/gb.qt5/configure.ac
+@@ -14,11 +14,6 @@
+ qt5, QT5, gb.qt5, [src],
+ 'Qt5Core >= 5.3.0' Qt5Gui Qt5Widgets Qt5Svg Qt5PrintSupport Qt5X11Extras x11
+ )
+-
+-## GB_COMPONENT_PKG_CONFIG(
+-## qt5ext, QT5EXT, gb.qt5.ext, [ext],
+-## 'Qt5Core >= 5.4.0' Qt5Gui Qt5Widgets
+-## )
+
+ GB_COMPONENT_PKG_CONFIG(
+ qt5webkit, QT5WEBKIT, gb.qt5.webkit, [webkit],
+@@ -55,6 +50,4 @@
+ src/ext/Makefile \
+ )
+
+-## src/ext/Makefile \
+-
+ GB_PRINT_MESSAGES
+--- a/gambas/trunk/gb.qt5/src/ext/Makefile.am
++++ b/gambas/trunk/gb.qt5/src/ext/Makefile.am
+@@ -6,6 +6,7 @@
+
+ gb_qt5_ext_la_LIBADD = @QT5EXT_LIB@
+ gb_qt5_ext_la_LDFLAGS = -module @LD_FLAGS@ @QT5EXT_LDFLAGS@
++gb_qt5_ext_la_CXXFLAGS = @THREAD_INC@ $(AM_CXXFLAGS) -std=c++11
+ gb_qt5_ext_la_CPPFLAGS = @QT5EXT_INC@ -I$(top_srcdir)/share -I$(top_srcdir)/src/share
+
+ gb_qt5_ext_la_SOURCES = \