summaryrefslogtreecommitdiffstats
path: root/development/gauche
diff options
context:
space:
mode:
author Jockey S. Kyd <jockey.kyd@gmail.com>2011-09-27 08:20:09 -0300
committer Niels Horn <niels.horn@slackbuilds.org>2011-09-27 08:20:09 -0300
commit63cd59235a7307bbb68e396fe69f0dae42879f18 (patch)
tree4ad86e6f84c6a61698565f9080c04c497dac2023 /development/gauche
parent102cefc4f0f25b6a27366197c45929caf058384f (diff)
downloadslackbuilds-63cd59235a7307bbb68e396fe69f0dae42879f18.tar.gz
slackbuilds-63cd59235a7307bbb68e396fe69f0dae42879f18.tar.xz
development/gauche: Added (R5RS Scheme implementation)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'development/gauche')
-rw-r--r--development/gauche/README4
-rw-r--r--development/gauche/gauche.SlackBuild84
-rw-r--r--development/gauche/gauche.info10
-rw-r--r--development/gauche/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/development/gauche/README b/development/gauche/README
new file mode 100644
index 0000000000..06704fc3ee
--- /dev/null
+++ b/development/gauche/README
@@ -0,0 +1,4 @@
+Gauche is an R5RS Scheme implementation developed to be a handy script
+interpreter, which allows programmers and system administrators to write
+small to large scripts for their daily chores. Quick startup, built-in
+system interface, native multilingual support are some of the goals.
diff --git a/development/gauche/gauche.SlackBuild b/development/gauche/gauche.SlackBuild
new file mode 100644
index 0000000000..d4faee97a9
--- /dev/null
+++ b/development/gauche/gauche.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+#
+# Written by Jockey S. Kyd (jockey dot kyd at gmail dot com)
+# Public domain
+#
+
+PRGNAM=gauche
+VERSION=0.9.2
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+DIST=Gauche-$VERSION
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $DIST
+tar xvf $CWD/$DIST.tgz
+cd $DIST
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --libdir=/usr/lib$LIBDIRSUFFIX \
+ --mandir=/usr/man/ \
+ --infodir=/usr/info \
+ --build=$ARCH-slackware-linux
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file \
+ | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
+ || true
+
+rm -f $PKG/usr/info/dir
+find $PKG/usr/info -type f -exec gzip -9 {} \;
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog Gauche.spec HACKING INSTALL INSTALL.eucjp \
+ NEWS README VERSION $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/gauche/gauche.info b/development/gauche/gauche.info
new file mode 100644
index 0000000000..547322ad89
--- /dev/null
+++ b/development/gauche/gauche.info
@@ -0,0 +1,10 @@
+PRGNAM="gauche"
+VERSION="0.9.2"
+HOMEPAGE="http://practical-scheme.net/gauche/"
+DOWNLOAD="http://prdownloads.sourceforge.net/gauche/Gauche-0.9.2.tgz"
+MD5SUM="9979de5be0e35e57131508c4c606f5cb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Jockey S. Kyd"
+EMAIL="jockey.kyd@gmail.com"
+APPROVED="Niels Horn"
diff --git a/development/gauche/slack-desc b/development/gauche/slack-desc
new file mode 100644
index 0000000000..9d10255d29
--- /dev/null
+++ b/development/gauche/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gauche: gauche (Gauche Scheme)
+gauche:
+gauche: Gauche is an R5RS Scheme implementation developed to be a handy
+gauche: script interpreter, which allows programmers and system
+gauche: administrators to write small to large scripts for their daily
+gauche: chores. Quick startup, built-in system interface, native multilingual
+gauche: support are some of the goals.
+gauche:
+gauche: http://practical-scheme.net/gauche/
+gauche:
+gauche: