summaryrefslogtreecommitdiffstats
path: root/development/google-go-lang
diff options
context:
space:
mode:
author Vincent Batts <vbatts@hashbangbash.com>2021-04-13 14:23:33 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-04-16 17:11:58 +0700
commitff42704bb29455b345e3c5817a6551be2307d737 (patch)
treeb1114315a045563bc7acad9127b9b4bd3bddd64a /development/google-go-lang
parent380fd7a1e31e9428f2ff263592a5d338a4b54dd0 (diff)
downloadslackbuilds-ff42704bb29455b345e3c5817a6551be2307d737.tar.gz
slackbuilds-ff42704bb29455b345e3c5817a6551be2307d737.tar.xz
development/google-go-lang: Updated for version 1.16.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/google-go-lang')
-rw-r--r--development/google-go-lang/google-go-lang.SlackBuild30
-rw-r--r--development/google-go-lang/google-go-lang.info6
2 files changed, 30 insertions, 6 deletions
diff --git a/development/google-go-lang/google-go-lang.SlackBuild b/development/google-go-lang/google-go-lang.SlackBuild
index 2207e81595..1afff977d9 100644
--- a/development/google-go-lang/google-go-lang.SlackBuild
+++ b/development/google-go-lang/google-go-lang.SlackBuild
@@ -27,7 +27,7 @@
# SOFTWARE.
PRGNAM=google-go-lang
-VERSION=${VERSION:-1.14.14}
+VERSION=${VERSION:-1.16.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -80,12 +80,28 @@ find -L . \
# as of >= go1.5, the cross-compiler does not need to be bootstrap, so the
# compiler need only be compiled for the host OS, which it detects
unset GOBIN GOPATH GOOS GOARCH
-unset BASH_ENV # Not sure why, but this causes run.bash to fail --rworkman
-export GOROOT_BOOTSTRAP="/usr" # gcc 5+ is go1.4 API, so we'll bootstrap with it
+# Not sure why, but this causes run.bash to fail --rworkman
+unset BASH_ENV
+
+# gcc 5+ is go1.4 API, so we'll bootstrap with it
+export GOROOT_BOOTSTRAP="/usr"
+
+# Default GOROOT is the parent directory of all.bash,
+# which is the current directory we're in.
+# Defining it here means we can use it below when building
+# shared libraries
export GOROOT="$(pwd)"
+
+# The value of GOROOT once the package is installed
export GOROOT_FINAL="/usr/lib${LIBDIRSUFFIX}/go${VERSION}/go"
+if [ "$ARCH" = "i586" ]; then
+ export GO386="softfloat"
+elif [ "$ARCH" = "i686" ]; then
+ export GO386="softfloat"
+fi
+
cd src
if [ "x${RUN_TEST}" = "xtrue" ] ; then
@@ -101,6 +117,14 @@ $GOROOT/bin/go install -buildmode=shared std
cd ..
+# remove Go build cache
+rm -rf pkg/obj/go-build/*
+
+# remove the doc Makefile
+rm -f doc/Makefile
+
+mkdir -p $PKG$GOROOT_FINAL
+
# Put the profile scripts for setting PATH and env variables
mkdir -p $PKG/etc/profile.d
cat > $PKG/etc/profile.d/go.csh << EOF
diff --git a/development/google-go-lang/google-go-lang.info b/development/google-go-lang/google-go-lang.info
index 9c2c0aa760..a4943b4624 100644
--- a/development/google-go-lang/google-go-lang.info
+++ b/development/google-go-lang/google-go-lang.info
@@ -1,8 +1,8 @@
PRGNAM="google-go-lang"
-VERSION="1.14.14"
+VERSION="1.16.3"
HOMEPAGE="http://golang.org"
-DOWNLOAD="https://storage.googleapis.com/golang/go1.14.14.src.tar.gz"
-MD5SUM="d74aae1179bcc61140a7b6648b3959bc"
+DOWNLOAD="https://storage.googleapis.com/golang/go1.16.3.src.tar.gz"
+MD5SUM="48183a40d6522f1ea59b7d63377b7072"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""