summaryrefslogtreecommitdiffstats
path: root/development/ipython
diff options
context:
space:
mode:
author Carlos Corbacho <carlos@strangeworlds.co.uk>2011-10-20 21:34:15 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2011-10-21 15:59:19 -0200
commit5ac0c4a40b984324740914dbcd9faff46e9413ee (patch)
tree9825143d77732a01a3d79563c88eaa7c392a5dd3 /development/ipython
parentb3fa5a9f4022839ead1be50591912220f11b9b28 (diff)
downloadslackbuilds-5ac0c4a40b984324740914dbcd9faff46e9413ee.tar.gz
slackbuilds-5ac0c4a40b984324740914dbcd9faff46e9413ee.tar.xz
development/ipython: Updated for version 0.11.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'development/ipython')
-rw-r--r--development/ipython/README20
-rw-r--r--development/ipython/ipython.SlackBuild26
-rw-r--r--development/ipython/ipython.info8
3 files changed, 25 insertions, 29 deletions
diff --git a/development/ipython/README b/development/ipython/README
index 3c78aaad06..182b1e5a2a 100644
--- a/development/ipython/README
+++ b/development/ipython/README
@@ -1,10 +1,12 @@
-IPython is a multiplatform, Free Software project (BSD licensed) that offers:
+IPython is a multiplatform, Free Software project (BSD licensed) that
+offers:
-* An enhanced Python shell designed for efficient interactive work. It includes
- many enhancements over the default Python shell, including the ability for
- controlling interactively all major GUI toolkits in a non-blocking manner.
-* A library to build customized interactive environments using Python as the
- basic language (but with the possibility of having extended or alternate
- syntaxes).
-* A system for interactive distributed and parallel computing (this is part of
- IPython's new development).
+* An enhanced Python shell designed for efficient interactive work. It
+ includes many enhancements over the default Python shell, including the
+ ability for controlling interactively all major GUI toolkits in a non-
+ blocking manner.
+* A library to build customized interactive environments using Python as
+ the basic language (but with the possibility of having extended or
+ alternate syntaxes).
+* A system for interactive distributed and parallel computing (this is part
+ of IPython's new development).
diff --git a/development/ipython/ipython.SlackBuild b/development/ipython/ipython.SlackBuild
index 5d215332a1..59255020e8 100644
--- a/development/ipython/ipython.SlackBuild
+++ b/development/ipython/ipython.SlackBuild
@@ -2,7 +2,7 @@
# SlackBuild for IPython
-# Copyright 2008-2009 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,9 +22,9 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PKGNAM=ipython
-VERSION=${VERSION:-0.10}
-BUILD=${BUILD:-2}
+PRGNAM=ipython
+VERSION=${VERSION:-0.11}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -37,7 +37,7 @@ fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PKGNAM
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
@@ -45,9 +45,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PKGNAM-$VERSION
-tar xvf $CWD/$PKGNAM-$VERSION.tar.gz
-cd $PKGNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -59,7 +59,7 @@ python setup.py install --root="$PKG"
mkdir -p $PKG/usr/doc
mv $PKG/usr/share/doc/ipython $PKG/usr/doc/ipython-$VERSION
-find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \;
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \;
mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
@@ -72,10 +72,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
-# Clean up the extra stuff:
-if [ "$1" = "--cleanup" ]; then
- rm -rf $TMP/$PKGNAM-$VERSION
- rm -rf $PKG
-fi
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/ipython/ipython.info b/development/ipython/ipython.info
index 174d3adc1b..0ab6ae502e 100644
--- a/development/ipython/ipython.info
+++ b/development/ipython/ipython.info
@@ -1,10 +1,10 @@
PRGNAM="ipython"
-VERSION="0.10"
+VERSION="0.11"
HOMEPAGE="http://ipython.scipy.org/"
-DOWNLOAD="http://ipython.scipy.org/dist/0.10/ipython-0.10.tar.gz"
-MD5SUM="dd10cd1b622c16c1afca2239fcc0dfdf"
+DOWNLOAD="http://archive.ipython.org/release/0.11/ipython-0.11.tar.gz"
+MD5SUM="efc899e752a4a4a67a99575cea1719ef"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Carlos Corbacho"
EMAIL="carlos@strangeworlds.co.uk"
-APPROVED="rworkman"
+APPROVED="Niels Horn"