summaryrefslogtreecommitdiffstats
path: root/development/kiwi
diff options
context:
space:
mode:
author Michael Wagner <lapinours@web.de>2010-05-11 20:00:26 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:26 +0200
commit51230a82e53443e8ba9f6394b5bda18fa982f51f (patch)
tree8cd6405017632b3dba8e83286226127cb68d0649 /development/kiwi
parentc83673694faca217c2926178d93b34facfba698c (diff)
downloadslackbuilds-51230a82e53443e8ba9f6394b5bda18fa982f51f.tar.gz
slackbuilds-51230a82e53443e8ba9f6394b5bda18fa982f51f.tar.xz
development/kiwi: Added to 12.0 repository
Diffstat (limited to 'development/kiwi')
-rw-r--r--development/kiwi/README8
-rw-r--r--development/kiwi/kiwi.SlackBuild60
-rw-r--r--development/kiwi/kiwi.info8
-rw-r--r--development/kiwi/slack-desc19
4 files changed, 95 insertions, 0 deletions
diff --git a/development/kiwi/README b/development/kiwi/README
new file mode 100644
index 0000000000..90364d2e6c
--- /dev/null
+++ b/development/kiwi/README
@@ -0,0 +1,8 @@
+kiwi (a framework for developing graphical applications in Python)
+
+kiwi is a framework composed of a set of modules, which eases Python
+development using PyGTK. Kiwi makes graphical applications *much*
+faster to code, with good architecture and more Python-like bindings;
+it also offers extended widgets based upon the original PyGTK widgets.
+
+kiwi depends on PyGTK, which is available from SlackBuilds.org.
diff --git a/development/kiwi/kiwi.SlackBuild b/development/kiwi/kiwi.SlackBuild
new file mode 100644
index 0000000000..dfa24d4fff
--- /dev/null
+++ b/development/kiwi/kiwi.SlackBuild
@@ -0,0 +1,60 @@
+#!/bin/sh
+#
+# Slackware Build Script for kiwi
+# (C) 2008 Michael Wagner <lapinours@web.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=kiwi
+VERSION=1.9.19
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Adjust docdir
+sed -i "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION,g" setup.py
+
+python setup.py install --root=$PKG
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Remove empty directories
+find $PKG -depth -type d -empty -exec rm -rf {} \;
+
+cd $PKG
+/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/kiwi/kiwi.info b/development/kiwi/kiwi.info
new file mode 100644
index 0000000000..27253ba078
--- /dev/null
+++ b/development/kiwi/kiwi.info
@@ -0,0 +1,8 @@
+PRGNAM="kiwi"
+VERSION="1.9.19"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/"
+DOWNLOAD="http://download.gnome.org/sources/kiwi/1.9/kiwi-1.9.19.tar.gz"
+MD5SUM="366f03d614735c910736875cd5070c5c"
+MAINTAINER="Michael Wagner"
+EMAIL="lapinours@web.de"
+APPROVED="rworkman"
diff --git a/development/kiwi/slack-desc b/development/kiwi/slack-desc
new file mode 100644
index 0000000000..01bd8eb4f1
--- /dev/null
+++ b/development/kiwi/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+kiwi: kiwi (a framework for developing graphical applications in Python)
+kiwi:
+kiwi: kiwi is a framework composed of a set of modules, which eases Python
+kiwi: development using PyGTK. Kiwi makes graphical applications *much*
+kiwi: faster to code, with good architecture and more Python-like bindings;
+kiwi: it also offers extended widgets based upon the original PyGTK widgets.
+kiwi:
+kiwi: Homepage: http://www.async.com.br/projects/kiwi/
+kiwi:
+kiwi:
+kiwi: