summaryrefslogtreecommitdiffstats
path: root/development/kiwi
diff options
context:
space:
mode:
author Mikko Varri <vmj@linuxbox.fi>2010-05-12 17:38:36 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 17:38:36 +0200
commitc42391c0b55925fa58bd37f60e2e4553488958ab (patch)
treef9aabc6782846c9d61a8274ecb71fb5e7a6da7c4 /development/kiwi
parent897fdfcb8e9fff9b4b12fc1475a11947d2109997 (diff)
downloadslackbuilds-c42391c0b55925fa58bd37f60e2e4553488958ab.tar.gz
slackbuilds-c42391c0b55925fa58bd37f60e2e4553488958ab.tar.xz
development/kiwi: Updated for version 1.9.23
Diffstat (limited to 'development/kiwi')
-rw-r--r--development/kiwi/README15
-rw-r--r--development/kiwi/kiwi.SlackBuild49
-rw-r--r--development/kiwi/kiwi.info10
-rw-r--r--development/kiwi/slack-desc28
4 files changed, 46 insertions, 56 deletions
diff --git a/development/kiwi/README b/development/kiwi/README
index 90364d2e6c..9d6d313191 100644
--- a/development/kiwi/README
+++ b/development/kiwi/README
@@ -1,8 +1,11 @@
-kiwi (a framework for developing graphical applications in Python)
+Kiwi is a framework and a set of enhanced PyGTK widgets designed to
+make building programs with graphical interfaces both easy to write
+and easy to maintain. Kiwi is pure Python and released under the LGPL.
-kiwi is a framework composed of a set of modules, which eases Python
-development using PyGTK. Kiwi makes graphical applications *much*
-faster to code, with good architecture and more Python-like bindings;
-it also offers extended widgets based upon the original PyGTK widgets.
+Fully object-oriented, and roughly Smalltalk's MVC, Kiwi provides a
+simple, practical way to build forms, windows and widgets that
+transparently access and display your object data. Kiwi is inspired
+by Allen Holub's Visual Proxy.
-kiwi depends on PyGTK, which is available from SlackBuilds.org.
+NOTE: Additional functionality is provided, if pygobject, zope.interface,
+ and/or SQLObject are installed.
diff --git a/development/kiwi/kiwi.SlackBuild b/development/kiwi/kiwi.SlackBuild
index dfa24d4fff..01cc173642 100644
--- a/development/kiwi/kiwi.SlackBuild
+++ b/development/kiwi/kiwi.SlackBuild
@@ -1,28 +1,12 @@
#!/bin/sh
-#
-# Slackware Build Script for kiwi
-# (C) 2008 Michael Wagner <lapinours@web.de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Slackware build script for kiwi
+
+# Written by Mikko Varri (vmj@linuxbox.fi)
+# Public domain
PRGNAM=kiwi
-VERSION=1.9.19
+VERSION=${VERSION:-1.9.23}
ARCH=noarch
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -38,23 +22,26 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Adjust docdir
-sed -i "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION,g" setup.py
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
python setup.py install --root=$PKG
+rm -rf $PKG/usr/share/doc # duplicate
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog NEWS PKG-INFO README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-# Remove empty directories
-find $PKG -depth -type d -empty -exec rm -rf {} \;
-
cd $PKG
-/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+
diff --git a/development/kiwi/kiwi.info b/development/kiwi/kiwi.info
index 27253ba078..c400b0a52a 100644
--- a/development/kiwi/kiwi.info
+++ b/development/kiwi/kiwi.info
@@ -1,8 +1,8 @@
PRGNAM="kiwi"
-VERSION="1.9.19"
+VERSION="1.9.23"
HOMEPAGE="http://www.async.com.br/projects/kiwi/"
-DOWNLOAD="http://download.gnome.org/sources/kiwi/1.9/kiwi-1.9.19.tar.gz"
-MD5SUM="366f03d614735c910736875cd5070c5c"
-MAINTAINER="Michael Wagner"
-EMAIL="lapinours@web.de"
+DOWNLOAD="http://ftp.gnome.org/pub/gnome/sources/kiwi/1.9/kiwi-1.9.23.tar.gz"
+MD5SUM="e68e3da96c3848ac534fbd200ffcd35a"
+MAINTAINER="Mikko Varri"
+EMAIL="vmj@linuxbox.fi"
APPROVED="rworkman"
diff --git a/development/kiwi/slack-desc b/development/kiwi/slack-desc
index 01bd8eb4f1..aa1282f559 100644
--- a/development/kiwi/slack-desc
+++ b/development/kiwi/slack-desc
@@ -1,19 +1,19 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
+# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
-kiwi: kiwi (a framework for developing graphical applications in Python)
-kiwi:
-kiwi: kiwi is a framework composed of a set of modules, which eases Python
-kiwi: development using PyGTK. Kiwi makes graphical applications *much*
-kiwi: faster to code, with good architecture and more Python-like bindings;
-kiwi: it also offers extended widgets based upon the original PyGTK widgets.
-kiwi:
-kiwi: Homepage: http://www.async.com.br/projects/kiwi/
-kiwi:
-kiwi:
-kiwi:
+kiwi: kiwi (A framework for Python applications with GUIs)
+kiwi:
+kiwi: Kiwi is a framework and a set of enhanced PyGTK widgets designed to
+kiwi: make building programs with graphical interfaces both easy to write
+kiwi: and easy to maintain. Kiwi is pure Python and released under the
+kiwi: LGPL. Fully object-oriented, and roughly Smalltalk's MVC, Kiwi
+kiwi: provides a simple, practical way to build forms, windows and widgets
+kiwi: that transparently access and display your object data. Kiwi is
+kiwi: inspired by Allen Holub's Visual Proxy.
+kiwi:
+kiwi: http://www.async.com.br/projects/kiwi/