summaryrefslogtreecommitdiffstats
path: root/development/ming/ming.SlackBuild
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2012-09-03 20:56:49 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-04 23:50:25 -0500
commitc36043820b20dbc601aeed91b4ebee0c3fb18a0b (patch)
tree0d96b0318f5eb5ff5a5f3462066890cfbcd58e15 /development/ming/ming.SlackBuild
parent61e6de614c8d27fcb91177d381e0e02b81f1f93b (diff)
downloadslackbuilds-c36043820b20dbc601aeed91b4ebee0c3fb18a0b.tar.gz
slackbuilds-c36043820b20dbc601aeed91b4ebee0c3fb18a0b.tar.xz
development/ming: Fix building perl extension.
Also partially fixed building the php extension. It builds fine with a "normal" php 5.4 now, but still fails with a zts enabled one like shipped in Slackware. Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'development/ming/ming.SlackBuild')
-rw-r--r--development/ming/ming.SlackBuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/development/ming/ming.SlackBuild b/development/ming/ming.SlackBuild
index 09007f7acd..7cc39896be 100644
--- a/development/ming/ming.SlackBuild
+++ b/development/ming/ming.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ming
-# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2008-2012 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=ming
VERSION=0.4.4
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -65,6 +65,12 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# Fix PHP 5.4 compatibility
+patch -p0 -d php_ext -i $CWD/patch-ming.c.diff
+
+# Fix building against perl 5.16
+patch -p1 -i $CWD/0001-GvCV-isn-t-an-lvalue-since-Perl-5.13.10.patch
+
# static library is activated because the perl extension needs it
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -81,9 +87,15 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-cd php_ext
- make install DESTDIR=$PKG
-cd -
+# Building the php extension against a zts enabled php fails currently.
+# Feel free to uncomment this in case you have a normal php. -HW
+
+#cd php_ext
+# make install DESTDIR=$PKG
+#cd -
+
+# Install config file for PHP.
+#install -D -m 644 $CWD/ming.ini $PKG/etc/php/ming.ini.new
cd py_ext
python setup.py install --root=$PKG
@@ -95,9 +107,6 @@ cd perl_ext
make install DESTDIR=$PKG
cd -
-# Install config file for PHP.
-install -D -m 644 $CWD/ming.ini $PKG/etc/php/ming.ini.new
-
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null