summaryrefslogtreecommitdiffstats
path: root/development/ming
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@liwjatan.at>2010-05-11 22:53:34 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-11 22:53:34 +0200
commit7801f694bb5533927e58ab127400be01dbf338d9 (patch)
treee474dbafdef299154ff3e70ec71b84caa27f1410 /development/ming
parentefe054ac0f24f818e70b05cf136b56e1df1d0f32 (diff)
downloadslackbuilds-7801f694bb5533927e58ab127400be01dbf338d9.tar.gz
slackbuilds-7801f694bb5533927e58ab127400be01dbf338d9.tar.xz
development/ming: Added to 12.1 repository
Diffstat (limited to 'development/ming')
-rw-r--r--development/ming/README12
-rw-r--r--development/ming/ming.SlackBuild112
-rw-r--r--development/ming/ming.info8
-rw-r--r--development/ming/slack-desc19
4 files changed, 151 insertions, 0 deletions
diff --git a/development/ming/README b/development/ming/README
new file mode 100644
index 0000000000..a840aa7b00
--- /dev/null
+++ b/development/ming/README
@@ -0,0 +1,12 @@
+Ming is a Flash (SWF) output library. It can be used from PHP,
+Perl, Ruby, Python, C, C++, Java, and probably more on the way.
+It comprises a lot of Flash functionality, including features
+of Flash 6. Specifically, it lets you create: shapes (including
+morphs), text, sprites (aka movie clips), buttons, and actions
+in flash movies, plus more. The goal for Ming is to abstract
+away all of the mundane specifics of the SWF file format.
+
+This package contains the c++, perl, python, php and tcl-plugin.
+To enable the php-plugin you have to add
+ extension=php_ming.so
+to the appropriate place in /etc/httpd/php.ini \ No newline at end of file
diff --git a/development/ming/ming.SlackBuild b/development/ming/ming.SlackBuild
new file mode 100644
index 0000000000..3921e70374
--- /dev/null
+++ b/development/ming/ming.SlackBuild
@@ -0,0 +1,112 @@
+#!/bin/sh
+
+# Slackware build script for ming
+
+# Copyright 2008 Heinz Wiesinger <pprkut@liwjatan.at>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ming
+VERSION=0.4.0.rc1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# static library is activated because the perl extension needs it
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-static \
+ --enable-tcl \
+ --build=$ARCH-slackware-linux \
+ --host=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG
+
+cd php_ext
+ make install-strip prefix=$PKG/usr
+cd -
+
+cd py_ext
+ python setup.py install --root=$PKG
+cd -
+
+cd perl_ext
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make install DESTDIR=$PKG
+cd -
+
+mv $PKG/usr/share/man/man3/* $PKG/usr/man/man3/
+
+rm -rf $PKG/usr/share
+
+# Remove perlocal.pod and .packlist from $PKG
+( for i in perllocal.pod .packlist *.bs; do
+ find $PKG -name "$i" -exec rm -rf {} \;
+ done
+ # Remove empty directory
+ rm -rf $PKG/usr/lib/perl5/5.8.8/
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog COPYING HISTORY INSTALL LICENSE* NEWS README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/ming/ming.info b/development/ming/ming.info
new file mode 100644
index 0000000000..82b3400443
--- /dev/null
+++ b/development/ming/ming.info
@@ -0,0 +1,8 @@
+PRGNAM="ming"
+VERSION="0.4.0.rc1"
+HOMEPAGE="http://www.libming.org"
+DOWNLOAD="http://downloads.sourceforge.net/ming/ming-0.4.0.rc1.tar.bz2"
+MD5SUM="3353ae645623e9e9be9a87e7eb9fa4a1"
+MAINTAINER="ppr:kut"
+EMAIL="pprkut@liwjatan.at"
+APPROVED="David Somero" \ No newline at end of file
diff --git a/development/ming/slack-desc b/development/ming/slack-desc
new file mode 100644
index 0000000000..6d6753ebf6
--- /dev/null
+++ b/development/ming/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------|
+ming: ming (swf output library)
+ming:
+ming: Ming is a Flash (SWF) output library. It can be used from PHP,
+ming: Perl, Ruby, Python, C, C++, Java, and probably more on the way.
+ming: It comprises a lot of Flash functionality, including features
+ming: of Flash 6. Specifically, it lets you create: shapes (including
+ming: morphs), text, sprites (aka movie clips), buttons, and actions
+ming: in flash movies, plus more. The goal for Ming is to abstract
+ming: away all of the mundane specifics of the SWF file format.
+ming:
+ming: Homepage: http://www.libming.org