summaryrefslogtreecommitdiffstats
path: root/development/numpy
diff options
context:
space:
mode:
author Aleksandar Samardzic <asamardzic@matf.bg.ac.yu>2010-05-11 20:00:27 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:27 +0200
commitf51716089e2a17c8cdda17b085f285f8e664c70f (patch)
tree861a6f0d2f45a19061941f6a4e04e7cbc1a2bc3b /development/numpy
parent1ffcd1f797bbc2a5feaece3f25b99901459a871f (diff)
downloadslackbuilds-f51716089e2a17c8cdda17b085f285f8e664c70f.tar.gz
slackbuilds-f51716089e2a17c8cdda17b085f285f8e664c70f.tar.xz
development/numpy: Added to 12.0 repository
Diffstat (limited to 'development/numpy')
-rw-r--r--development/numpy/README13
-rw-r--r--development/numpy/numpy.SlackBuild54
-rw-r--r--development/numpy/numpy.info8
-rw-r--r--development/numpy/slack-desc19
4 files changed, 94 insertions, 0 deletions
diff --git a/development/numpy/README b/development/numpy/README
new file mode 100644
index 0000000000..6ab3f1293e
--- /dev/null
+++ b/development/numpy/README
@@ -0,0 +1,13 @@
+The fundamental package needed for scientific computing with Python is
+called NumPy. This package contains:
+ * a powerful N-dimensional array object
+ * sophisticated (broadcasting) functions
+ * basic linear algebra functions
+ * basic Fourier transforms
+ * sophisticated random number capabilities
+ * tools for integrating Fortran code.
+
+Besides its obvious scientific uses, NumPy can also be used as an
+efficient multi-dimensional container of generic data. Arbitrary
+data-types can be defined. This allows NumPy to seamlessly and
+quickly integrate with a wide-variety of databases.
diff --git a/development/numpy/numpy.SlackBuild b/development/numpy/numpy.SlackBuild
new file mode 100644
index 0000000000..b7e4e6eb10
--- /dev/null
+++ b/development/numpy/numpy.SlackBuild
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+# Slackware build script for NumPy
+
+# Written by Aleksandar B. Samardzic <asamardzic@matf.bg.ac.yu>
+
+NAME=numpy
+VERSION=1.0.4
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$NAME}
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $NAME-$VERSION
+tar xvf $CWD/$NAME-$VERSION.tar.gz
+cd $NAME-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py build
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$NAME-$VERSION
+cp -a COMPATIBILITY DEV_README.txt LICENSE.txt README.txt THANKS.txt\
+ $PKG/usr/doc/$NAME-$VERSION
+cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/numpy/numpy.info b/development/numpy/numpy.info
new file mode 100644
index 0000000000..618691b65d
--- /dev/null
+++ b/development/numpy/numpy.info
@@ -0,0 +1,8 @@
+PRGNAM="numpy"
+VERSION="1.0.4"
+HOMEPAGE="http://numpy.scipy.org/"
+DOWNLOAD="http://downloads.sourceforge.net/numpy/numpy-1.0.4.tar.gz"
+MD5SUM="8f011e9d7697da570efaac61c51725e0"
+MAINTAINER="Aleksandar B. Samardzic"
+EMAIL="asamardzic@matf.bg.ac.yu"
+APPROVED="rworkman"
diff --git a/development/numpy/slack-desc b/development/numpy/slack-desc
new file mode 100644
index 0000000000..e711828604
--- /dev/null
+++ b/development/numpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+numpy: NumPy (a foundation Python package for scientific computing)
+numpy:
+numpy: NumPy is an extension to the Python programming language, adding
+numpy: support for large, multi-dimensional arrays and matrices, along
+numpy: with a large library of high-level mathematical functions to
+numpy: operate on these arrays.
+numpy:
+numpy: NumPy home page is: http://numpy.scipy.org/
+numpy:
+numpy:
+numpy: