summaryrefslogtreecommitdiffstats
path: root/development/pip
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-05-03 15:31:08 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-05-03 15:31:08 -0500
commitaf5062470253b9afae7071c3cb8eab4f1e2c9c9b (patch)
tree2cfa6d9faaca9a1c2b92745342e5fb89c7f811d8 /development/pip
parent9444e5a3ec1d2a86686becdabfbc14255420c498 (diff)
downloadslackbuilds-af5062470253b9afae7071c3cb8eab4f1e2c9c9b.tar.gz
slackbuilds-af5062470253b9afae7071c3cb8eab4f1e2c9c9b.tar.xz
python/pip: Moved from Development category
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development/pip')
-rw-r--r--development/pip/README26
-rw-r--r--development/pip/pip.SlackBuild49
-rw-r--r--development/pip/pip.info10
-rw-r--r--development/pip/slack-desc19
4 files changed, 0 insertions, 104 deletions
diff --git a/development/pip/README b/development/pip/README
deleted file mode 100644
index f2dbe460da..0000000000
--- a/development/pip/README
+++ /dev/null
@@ -1,26 +0,0 @@
-pip is a replacement for easy_install (from pysetuptools). It uses mostly
-the same techniques for finding packages, so packages that were made
-easy_installable should be pip-installable as well.
-
-pip is meant to improve on easy_install. Some of the improvements:
-
-- All packages are downloaded before installation. Partially-completed
- installation doesn't occur as a result.
-- Care is taken to present useful output on the console.
-- The reasons for actions are kept track of. For instance, if a package is
- being installed, pip keeps track of why that package was required.
-- Error messages should be useful.
-- The code is relatively concise and cohesive, making it easier to use
- programmatically.
-- Packages don't have to be installed as egg archives, they can be
- installed flat (while keeping the egg metadata).
-- Native support for other version control systems (Git, Mercurial and
- Bazaar).
-- Uninstallation of packages.
-- Simple to define fixed sets of requirements and reliably reproduce a set
- of packages.
-
-pip is complementary with virtualenv (can be found at SBo), and it is
-encouraged that you use virtualenv to isolate your installation.
-
-pip requires pysetuptools.
diff --git a/development/pip/pip.SlackBuild b/development/pip/pip.SlackBuild
deleted file mode 100644
index c67e2a8484..0000000000
--- a/development/pip/pip.SlackBuild
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pip
-# Written by Audrius Kažukauskas <audrius@neutrino.lt>
-
-PRGNAM=pip
-VERSION=${VERSION:-0.8.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/pip/pip.info b/development/pip/pip.info
deleted file mode 100644
index d199b7b0b1..0000000000
--- a/development/pip/pip.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pip"
-VERSION="0.8.2"
-HOMEPAGE="http://pip.openplans.org/"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pip/pip-0.8.2.tar.gz"
-MD5SUM="df1eca0abe7643d92b5222240bed15f6"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
-APPROVED="Niels Horn"
diff --git a/development/pip/slack-desc b/development/pip/slack-desc
deleted file mode 100644
index 39dfde099f..0000000000
--- a/development/pip/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pip: pip (a better easy_install replacement)
-pip:
-pip: pip is a replacement for easy_install from pysetuptools.
-pip:
-pip: Homepage: http://pip.openplans.org/
-pip:
-pip:
-pip:
-pip:
-pip:
-pip: