summaryrefslogtreecommitdiffstats
path: root/development/psyco
diff options
context:
space:
mode:
author xroberx <xroberx@gmail.com>2010-05-12 23:28:48 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 23:28:48 +0200
commit7df396eaf0438a8f9c1d8e007eeb99b19787795e (patch)
tree685340b1d7cfcdbf4fe0e81a931d8509c7d45935 /development/psyco
parent03e9d7d8cdb62dd5f1d1c7d91fc476f7ff85b177 (diff)
downloadslackbuilds-7df396eaf0438a8f9c1d8e007eeb99b19787795e.tar.gz
slackbuilds-7df396eaf0438a8f9c1d8e007eeb99b19787795e.tar.xz
development/psyco: Added to 12.2 repository
Diffstat (limited to 'development/psyco')
-rw-r--r--development/psyco/README2
-rw-r--r--development/psyco/psyco.SlackBuild52
-rw-r--r--development/psyco/psyco.info8
-rw-r--r--development/psyco/slack-desc19
4 files changed, 81 insertions, 0 deletions
diff --git a/development/psyco/README b/development/psyco/README
new file mode 100644
index 0000000000..3022155fe0
--- /dev/null
+++ b/development/psyco/README
@@ -0,0 +1,2 @@
+Psyco is a Python extension module which can massively speed up the
+execution of any Python code.
diff --git a/development/psyco/psyco.SlackBuild b/development/psyco/psyco.SlackBuild
new file mode 100644
index 0000000000..026528489e
--- /dev/null
+++ b/development/psyco/psyco.SlackBuild
@@ -0,0 +1,52 @@
+#!/bin/sh
+
+# Slackware build script for Psyco
+# Heavily based on Aleksandar Samardzic Numpy script
+# Written by xroberx <xroberx@gmail.com>
+
+PRGNAM=psyco
+VERSION=${VERSION:-1.6}
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION-src.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING.txt INSTALL.txt README.txt MANIFEST\
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/psyco/psyco.info b/development/psyco/psyco.info
new file mode 100644
index 0000000000..28cbb1abb3
--- /dev/null
+++ b/development/psyco/psyco.info
@@ -0,0 +1,8 @@
+PRGNAM="psyco"
+VERSION="1.6"
+HOMEPAGE="http://psyco.sf.net/"
+DOWNLOAD="http://downloads.sourceforge.net/psyco/psyco-1.6-src.tar.gz"
+MD5SUM="8816fca8ba521e05d18dde3e1a11b0bd"
+MAINTAINER="xroberx"
+EMAIL="xroberx@gmail.com"
+APPROVED="rworkman"
diff --git a/development/psyco/slack-desc b/development/psyco/slack-desc
new file mode 100644
index 0000000000..761e84baec
--- /dev/null
+++ b/development/psyco/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+psyco: psyco (Python speed booster)
+psyco:
+psyco: Psyco is a Python extension module which can massively speed up the
+psyco: execution of any Python code.
+psyco:
+psyco: Homepage: http://psyco.sf.net/
+psyco:
+psyco:
+psyco:
+psyco:
+psyco: